Eero pro won’t connect to Ring Base Station.

I tried to connect my Ring base station to eero pro wirelessly but with no success. I called help center and they tried their best to fix it. I hard wire them and the work but I can’t connect them wirelessly. Can anyone help me?

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Solved. Thank you Kelton - eero support - for your help.

  • Out of curiosity, what was the solution? My Ring Pro base has been connected fine until my Eero Pro received a software update to v3.19.2. Now my base station can't see my wifi network at all.

    • windsorguy13 In my case, my Ring base station needed a reboot. Contacted Ring support and they remotely rebooted and then my base station was able to see and connect to my network again.

      • Eero
      • Eero.4
      • 2 mths ago
      • Reported - view


      Go to your eero app > Settings > Troubleshooting > "My device won't connect".

      Follow the on-screen instructions, and they attempt to connect your Ring device again. 

Like Follow
  • 2 mths agoLast active
  • 4Replies
  • 69Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support