2

Latest firmware update - How's it going?

Noticed an update was pushed last night. So far things are looking good {fingers crossed}. Just wanted to see what others experiences are.

I have a pfsense firewall and double-nat setup - the main eero controls my home subnet. Originally was getting quirky connection behaviors (SONOS issues etc) but simplifying my network - removing excess switches on the eero's subnet / relocating devices like my slingboxes AND now this update seems to have stabilized things. Am hoping this also resolves some android wifi connection issues I've encountered. Time will tell I guess but woohooo for now ..

Thanks again for all your hard work!!!!!

47replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • erktrek 

    Just a quick followup - I unplugged my internet connection and waited a few minutes.

    Sonos speakers did NOT become ungrouped! This indicates to me that there may be a possible periodic network/route issue between the BOOST and EERO. Note: for giggles I replaced my ethernet cable on the BOOST as well.

     

    E,

    Like
  • Possible bad Ethernet cable causing the issue?

    Like
  • My sonos system seemed to "split" regularly when on eero. Only one speaker would show up in the app, but a different one would actually be playing music at the time. Any speaker would randomly stop and wouldn't reappear until I did something (like unplug/reconnect almost any device). What was also weird, is the speaker that continued playing is the fully wireless one. The wired one was usually the one that stopped playing, could be seen in the app, but couldn't control the boost connected other speaker.

    I'm on google wifi today and I had a speaker stop playing music, but came back on its own 30-60 seconds later.

    For what it's worth, orbi and eero both struggled with Sonos. Google wifi may also, but seems to have the problems far less often (so far).

    Most of my sonos usage was before firmware 2.1 which may have fixed some of the issues by addressing STP protocol priorities. I gave up just after the 2.1 update happened.

    Like
  • dleute 

    I had a similar situation before I simplified my home subnet. One speaker would be playing but my app would report another one as the one playing. Spotty controls like for volume. Audioskips/disconnects. Devices dropping in and out for no apparent reason. It was maddening.

    Originally tried bridging but that did not work out so went to a double-nat setup and changed my networking which worked better  - removed excess switches/devices etc.

     

    Out of curiosity if you were using the BOOST why would you hardwire a SONOS device? I mean I know that the IP addresses of the devices show up on the local subnet but I just assumed that you should always use either the BOOST's mesh setup or the personal WIFI/LAN.
     

    The latest issue for me seems to be the wired BOOST disconnects from the EERO from time to time.

    Like
  • erktrek 

    Current Sonos firmware heavily prefers its own network but can function without it by linking to your wifi. It is no longer actually required to have a bridge or boost device.

    I was keeping my Sonos Connect wired to a satellite eero. The connect (or any sonos device) becomes the main unit serving the purpose of a previously required bridge/boost. The only reason to have boost now is if you need a sonos network but can't wire any speaker/sonos device directly to your network. You can connect a boost at your router and all other speakers will connect to it and each other.

    More than that, if you wire *any* sonos device, you have no choice but to use the sonos boost network. The only way to avoid that is to setup all speakers/devices wirelessly (on your wifi network) and never wire any of them. This may have worked better for eero, but I didn't try it.

    To prevent circular networks from multiple wired Sonos devices, a protocol called STP is used. The goal of this protocol is to prevent network loops which create broadcast/traffic problems. However, this protocol is handled differently/blocked by different networking devices. This has been a significant source of Sonos issues in combination with a variety of networking gear including eero.

    I have no idea how this protocol would interact with a mesh network. I don't know how STP traffic would interact between different eero units. It is designed to protect/assist in circular network loops on a wired network. That logic has to be different when in a mesh connected wired network. I imagine the ports on every eero would have to be considered as a single switch for STP to work correctly. (I am purely guessing, I do not have the necessary networking knowledge of STP protocol to actually know)

    You can see what mode your sonos is in by going to settings -> About my sonos network. Each device has a WM: and then a number. each number corresponds to a mode. WM: 0 means use the boost network. Every device will show this if in range of a sonos network with any device wired. If no devices are wired, it will show WM: 1 if using your wifi. All devices are likely to have a 1 in that case. WM: 2 I have not seen as I don't do a surround sound playbar system. But that's what that one indicates. There may be others.

    So, I am not actually using a boost device, but effectively have the same thing by wiring my Connect to an eero.

    My guess is there are still STP issues when BOOST (or any Sonos device) is wired to an eero. Hence the drops/connectivity issues. One flaw is a single wired device now becomes a single point of failure for the Sonos system. Hence why an all wireless setup may be better. If an eero stops responding, the device should move to another eero that has signal within range. Again, haven't tried it, but theoretically should work. Sonos has been flawless on my Airport Extreme. And almost no failures on Google Wifi.

    Too much information? ;)

    --Derrek
     

    Like
  • Thanks again everyone for chiming in. If you are still experiencing any issues with Sonos on your eero network, please contact eero support. You can give us a call at 1-877-659-2347 or email support@eero.com.

    If we can't resolve your case ourselves, we'd be happy to put you in touch with our contacts at Sonos support. We've worked closely together in the past and have been able to resolve all of the customer cases we've seen thus far. We're here to help!

    Like
  • dleute 

    That's cool I'm familiar with the concepts and those SONOS Settings BUT always interested to learn something new or fill in the frighteningly large gaps in my knowledge base!  STP is used by the eeros as well  according to the support team. My poor network foo likely caused a bunch of issues. Thanks again for your response!

     

    To me using a combo of wired devices AND the SONOSNET seems perilous in a routing sense. Especially when the mesh works so well on it's own. From my reading of the installation docs you can certainly mix and match wired/wireless on the "STANDARD" sonos setup without SONOSNET/BOOST but I've never tried that.

     

    In terms of my setup - I  want to keep the SONOS traffic off my wireless network but prefer the flexibility of having wireless speakers that I can move around as needed. The BOOST mesh has been great for this. Not really worried so much worried about single point of failure for the BOOST cause I could theoretically work around it..

     

    EERO Support helped / is helping me figure these things out.  Process was a little slow but things are now working well enough to not be bothersome.

     

    Jeff C. - Thanks again for you guys letting us have this forum to chat it's been helpful and somewhat cathartic. ^_^

     

    E.

    Like
  • I just didn't have the time to fight with it. My network is comparatively simple. The only issue is the fluctuation in number of wifi devices. But, I didn't get to try the 2.1 firmware before returning eero. It also wasn't the only issue. I ran into a bunch of others with video conferencing and raw performance.

    Like
  • dleute 

    I hear you!! My secret suspicion is that EEROs wired networking still needs some additional love. I've been trying to isolate my homelan, reducing the # of wired devices as much as possible. This latest grouping thing with me is somewhat of a smoking gun.. though SONOS just had an update as well. Getting harder and harder to troubleshoot things as I add more layers.. completely my fault of course.

    Like
  • erktrek 

    Yeah, I took all complexity out of my networking a long time ago. I've been much happier since then.

    All this makes me want to get a 48 port switch and wire my house for an ethernet port every 6 feet. ;)

    Like
  • See the problem with that is then you'll want to have multiple subnets just so you can split your home stuff from your office stuff and maybe toss in a development and or a devices subnet as well which means vlans maybe a VPN for nice secure remote browsing and down the rabbit hole you'll go once again!

    Like
  • Many many years ago I tested high end cisco beta products on a large scale network. I got most of that out of my system then. That was back when iOS meant you were dealing with a cisco networking product. ;)

    No, I gave up on the tinkering side of things a long time ago. I haven't built a computer in at least a decade. I focused purely on software and cloud. I just want my home/home office stuff to work. Hence why I've been Apple product heavy for a while. Now that Apple is going down hill I'm trying to find alternatives. Hence eero.

    Speaking of which, my google wifi connection became ridiculously poor. Hopefully I don't start having issues with that as well. (It's actually a gift I'm testing. I don't like putting something in my mom's house that I haven't used. Impossible to support).

    --Derrek

    Like
  • After a month and a half of tooling around with my Eero and Sonos configurations, I gave up and pulled the Eero's from my network.  I reinstalled my 7 year old D-Link router and my Sonos works perfectly once again.  No drops, no lost connections, no problems.  I didn't receive much help from Eero support and was basically on my own trying to make it work.  Going forward, if I have a lot of time to waste, perhaps I'll try to make the Eeros work (if they fix their firmware), but for anyone using a Sonos, I definitely would NOT recommend purchasing the Eero routers.  If all you need is basic wifi to connect some tablets, phones and laptops, Eero should be fine.  If uninterrupted wifi is required, go with the commercial grade brands.

    Like
  • Patrick L —

    I'm sorry to hear of your continued troubles with your eero WiFi system. There shouldn't be any issues with Sonos. I see that we were last in touch with you on January 6th, but our team hadn't heard back. We'd be happy to continue to work with you on resolving this issue.

    If you'd like, please feel free to follow up on your support ticket (the email is support@eero.com) so that our team can continue to take a look and make sure your Sonos are able to work without interruption.

    Like
  • Patrick L 

    That's a bummer - things have stabilized somewhat for me. Again I have the BOOST running SONOSNET and a bunch of speakers. The EERO seems to drop hardwired links from time to time and for the BOOST this is disastrous as it wipes out all groupings. I know individual speakers do this - drop from a group and that kinda makes sense BUT the boost should be a little more robust. Have already spoken to SONOS about this but likely I'm just a crazy person - no doubt EERO guys and gals think so too..

    So it's the perfect storm of issues - Weird EERO network/routing dropouts for wired devices and fragile BOOST/SONOSNET behavior. I'm afraid if I switch to regular WIFI connections for the speakers it could make things worse. That seems like greater potential for issues given that more SONOS devices will be connected (wirelessly or wired) to the EERO network directly instead of through the BOOST. Also note that the groups do not break up if the internet goes down. As long as there is a network connection all is well - I tested this.

    Another thing I found that greatly increased failures was the use of a VLAN (802.1Q) switch with mulitple VLANs. EERO does not play nice with tagged ports and routing for some reason. Maybe it's something similar to the spanning tree packet issues they were having pre firmware update. At any rate isolated my subnet and put the EERO that was connected via a VLAN switch back on wireless. My EERO network is now about as "simple" as I can make it without major overhaul.

    Still getting weird wired disconnects but they are less frequent. Also certain wireless devices are still having trouble connecting like my wifes S7. Had to "reserve" the IP in the EERO and then manually enter it in her wifi settings. Had to do the same for a wireless HP MFC printer which was dropping the connection but not reconnecting.

    Like
  • Jeff C. -

    Thanks for the comment.  However, I did respond to the follow-up the same day (Jan 6), but I never received a response.  I'd be willing to work with someone from Eero support if they had any set-up or configuration suggestions.  Up to now, there was the suggestion from Eero support that my modem (Arris SB 6183) could potentially be causing the streaming issues.  I switched that out with the Arris 6190 and there was no change in performance.  I understand Eero is young and early adopters tend to have these types of problems.  I just didn't feel like I was making any progress which is why I pulled the Eeros to confirm without any doubt the problem was with the Eero router/AP set up.

    Like
  • 😱My eero's are showing all red. I have to use celluar data as home wireless just went down on eero

    Like
  • Flintlock76 have you tried unplugging all your Eeros, rebooting your cable modem, and then plugging your Eeros back in after your cable modem finished restarting?

    Like
  • Richard1864 

    Like
  • Yes, after doing that, several times, wifi is back. Downloading the update. Getting the red light on my erros has been a reoccurring theme ever since I bought it😭

    Like
  • Hi all-  As mentioned above, I replaced all my Eeros with my old (very old) router and my Sonos was again working perfectly.  Obviously, something was going on with how my Sonos controllers/sources were connecting to my Eeros.  Because the Eeros do provide a much better wifi network than my old router, I re-installed my three Eeros (all wired).  As a result, I hadn't used my Sonos in over a month.  Fast forward to yesterday and I thought I'd give the Sonos another try.  I did this because I know both Sonos and Eero had pushed firmware updates over the the last month and I thought maybe somehow it would all be fixed.  Well, to my surprise my Sonos now works flawlessly with my Eero network once again!  There are no longer any drops or interruptions.  All my Sonos controllers retain their connection for as long as I'm playing music.  This makes me very happy since I don't have to play my music over my Echo anymore!  Anyway, thanks all for the help and suggestions....Eero and Sonos CAN coexist without having to create any complex work-arounds!

    Like
  • Patrick L oh that's great to hear!  Been thinking about getting Sonos and was waiting to hear from you more experienced guys and gals if they were working better together now. Thank you for your update!

    Like
Like2 Follow
  • 2 Likes
  • 2 yrs agoLast active
  • 47Replies
  • 4123Views
  • 7 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com