Adding Gen 1 to and existing Gen 2

I have a working Gen 2 with a gateway and 2 beacons. A friend gave me an unopened 3 pack of Gen 1 units. While they are blinking blue, my app sometimes finds them and sometimes not. Even when they are found, the next step to check the connection always fails. Even when I am 2 inches from one of my beacons or the gateway. I reset them (back to factory setting) just i case, but no difference. Happens with all 3 units. Does anyone know how I can get them to join my network?  Thanks in advance. 

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Tried to connect with serial number and worked fine. Maybe this will help someone else. 

    Like 1
  • Spoke too soon. Fails when trying to connect to the Internet. Any thoughts? Thanks

  • Hi, BillZ – Thanks for reaching out, and welcome to the Community Forum! 

    Sounds like you've got a bit of a frustrating situation here, but I think there's a pretty simple solution! Since you're trying to add Gen 1 units to your network, what I believe you're seeing is a consequence of those units being on a much older native firmware version. We've made a lot of changes and improvements to the firmware over the last few years, including a complete overhaul of our mesh infrastructure with the introduction of TrueMesh on v.2.0 (for reference, we're now on v.3.7!)

    As a workaround in your particular case, I believe that all you'll need is to hardwire or daisy-chain those Gen 1 units to your existing Gen 2 gateway (or a network switch) and then attempt to add them via the app. By using the ethernet connection, we can bypass some of the wireless restrictions that exist between older and newer firmware versions. Once they're added to the network, a firmware update will let them start meshing wirelessly as expected.

    If you'd like any assistance with that, or you see any issues even after giving that a try, please call us directly at 877-659-2347 and we'll work on a solution with you. Thanks so much for bringing this to our attention, and welcome again to the forums!

    Drew, eero Community Team

      • BillZ
      • BillZ
      • 4 yrs ago
      • Reported - view

      Drew Thank you. I will give it a try and report back.

  • SOLVED! Thanks Drew. Worked like a charm.

Like Follow
  • 4 yrs agoLast active
  • 5Replies
  • 332Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support