2

Slow LAN speeds between devices on Eero Pro 6

Anyone else notice this issue? I switched from using Eero Pro to Eero Pro 6, and I instantly noticed that I could no longer steam Plex from my desktop to my laptop through wifi. I ran some speed tests transferring local files between devices and saw I was only getting about 1-2MB/s,  even though my Pro 6 are showing very strong signal strength and placement is the same. This is with 2 Eero Pro 6, and my WAN speed remains unaffected. I changed one of them back to the old Pro and the issue resolved. I called Eero support and took the guy 45 minutes to understand the issue and escalate to tier 2. It's an odd issue and i'm hoping more people can chime in if they're having the issue as well. 

If my laptop is connected to the same Eero Pro 6 that my desktop is on and I do a local transfer, it's fine. (60MB/s), but if I go downstairs and am connected to the second Eero Pro 6 (which is gateway), then the transfer speed drops to 1-2MB/s (whether it's a local file transfer or a local stream through Plex or Roon). This makes no sense when my desktop has WAN speeds of 30MB/s through the same Gateway Eero Pro 6 that my laptop is connected to. Clearly LAN speeds are somehow being affected when they shouldn't be. 

The weird thing is that upgrading to the Pro 6 did improve my WAN speed to my desktop (200mbps -> 350mbps), but for some reason now my LAN speed is super slow. 

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I'm getting similar issues. Wifi client external speedtest.net test shows near 300-500 mbit. Running iperf same physical spot, iperf test only ~130 mbit. There is something going on with internal LAN speed.

     

    Eero pro wifi 5 6.3.0

    Like
  • Hello Mzaur8 & ceevee ,

    Waiting for Tier 2 is going to be the best bet here. They will need time to dig through the network reports to identify what might be causing the behavior. I have sent you both a message, when you have time can you answer the questions and follow the instructions there so we can be sure that this is being looked into?

    Like
  • I was able to solve this by deleting the network then creating the network from scratch. Will report if performance degrades again.

    Like
  • Nice. I’m still waiting on tier 2 support to contact me. I tried deleting network but didn’t fix it. I think this particular issue is specific to Eero pro 6 

    Like
  • I am seeing this on an eero 6. Connections LAN/wireless <-> WAN and LAN/wired <->WAN are fast. Going between one wired and one wireless device on the local net, so LAN/wireless <-> LAN/wired, is also fast. But LAN/wireless <-> LAN/wireless is extremely slow. The devices are connected to the same eero.

    If anyone has an update on this, please post.

    Like
      • michael658
      • michael658
      • 8 mths ago
      • Reported - view

      kpghost I'm having this exact same issue on my Eero 6. I only have 1. Everything is fast except WiFi to WiFi LAN transfers, which are only going around 20 Mbps. I tried resetting my network and starting over but that didn't fix it. I also tried toggling various settings but nothing seems to work.

      Like
Like2 Follow
  • 2 Likes
  • 8 mths agoLast active
  • 6Replies
  • 225Views
  • 7 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com