Manual selection of 2.4GHz frequency for devices too dumb to know they can't connect at 5GHz

I have an older dumb smart switch that successfully connects to wifi, but at 5GHz... which it's not compatible with. It needs 2.4GHz but is too old/dumb to request that. So it connects at 5Ghz and fails to communicate.

Why can't I have manual control to specify on the eero interface to specify a specific connection frequency?


1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • You can temporarily disable 5GHz in the app to allow these types of devices to get connected. In the app go to Settings > Troubleshooting > My device won’t connect

Like1 Follow
  • 1 mth agoLast active
  • 1Replies
  • 29Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support