0

When will eero fix the iOS disconnect issue?

Hi, new eero 6 user here. My iPhone 12 Pro and iPad Pro 5th gen 12.9 both randomly lose internet connectivity. User clayj among others have been telling support about the issue for months! When can we expect more than a repeat of the same response from support? You know the issue, buy an iPhone 12 or new iPad and test it, please 😂

I received the eero unit from my new ISP, it’s running the latest 6.4.0 which I had hoped would address the issue, y’know given its now been months since it was raised, sadly no fix. Do we have a beta build to try with a fix included? 

I’m still within my cooling off period with the new ISP so this issue might cause me to terminate the agreement, please fix it.

4 replies

    • eero_support
    • 2 yrs ago
    • Reported - view

    Hello AllTaken ,

    Thank you for reaching out to us here on the community and welcome to the eero family. I do understand how frustrating it can be when your network or devices are not working correctly and I would like to help you troubleshoot the behavior that you are experiencing with your iPhone 12 Pro and iPad Pro 5th gen 12.9.

    Not every network is the same, so what solves the problem on one network might not work on another. But there are two common steps that we have had other customers take that has resolved this behavior. The first step was to disable WPA3 on the eero network. The second being disabling the private address feature on the Apple device for the eero network only. Can you please give these a try and see if it resolves the behavior?

    Also, I have sent you a direct message that will allow you to get a ticket created so I can take a look at your network on the back end to see if there might be anything else that could be causing this behavior. If the steps above do not resolve this behavior please review the direct message and follow the directions there so we can continue to troubleshoot.

    • stacey_brassington
    • 2 yrs ago
    • Reported - view

    Hi, I am frustratingly having the same issues. At the beginning everything worked fine but since updating I’ve had none stop problems with my iPhone, laptops and printers. I keep being disconnected and asked for the password and being told it is wrong (which it is not!) wpa3 is off. I also tried turning off the 5ghz which worked briefly for my iPhone. I’m getting fed up with wasting my time trying to get this solved, Eero was supposed to help my wifi signal not make it none existent. I will be looking to send them back and get my money back from UW at this rate! 

    • clayj
    • 2 yrs ago
    • Reported - view

    "The second being disabling the private address feature on the Apple device for the eero network only."

    Yeah, no. That may be a workaround, but it is not an actual fix. We should be able to have Private Address turned OFF so that we can use IP address reservations.

    • Catherinehilton
    • 2 yrs ago
    • Reported - view

    I have had connectivity issues for a week now. It’s slower than dial up. My husband got eero without my knowledge or consent and I’ve never been unhappier. I want the whole system refunded. I have iPhone and I cannot even open a video on the news anymore. What do I need to do to turn in all products. Customer service was very unhelpful and offered no information at all. 

Content aside

  • 5 mths agoLast active
  • 4Replies
  • 763Views
  • 6 Following