1

WPA3 setting and Samsung TV

Anyone else had an issue with Samsung TV connecting to WiFi when the WPA3 Eero Labs setting is enabled? 

6 replies

    • eero_support
    • 3 yrs ago
    • Reported - view

    Hello Apcoo,

    Have you checked to see if your TV supports WPA3? What is the model number of your TV?

      • Apcoo
      • 3 yrs ago
      • Reported - view

      Hi, it affects 3 of our Samsung TVs - one is model UE55TU7020KXXU, the other 2 are UE32T5300AK. With WPA3 enabled on Eero discover, none of the TVs will connect (I have other non-WPA3 devices which still connect but just show as ‘WPA2-basic’ on the Eero app) 

    • jjunge
    • 1 yr ago
    • Reported - view

    Bumping this. Same issue and very frustrating. If these TVs don’t support WPA3 then why don’t they just fallback to WPA2 like every other device in the house. Only the Samsung TV’s in my home have this issue.

    • Will32
    • 1 yr ago
    • Reported - view

    My Samsung 2021 Smart tv does support WPA3

    • giley
    • 1 yr ago
    • Reported - view

    I have this with the Samsung UE43TU7020K. Had to restart Eeros after disabling WPA3 for it to connect.

    • Enthusiast
    • thatsthequy
    • 1 yr ago
    • Reported - view

    Two of my networks with Samsung TVs have WPA3 disabled. All of my other networks have it enabled without issue.

    One time in the past I did get the TV to connect, but only after I rebooted the TV by unplugging it from the wall.

Content aside

  • 1 Likes
  • 1 yr agoLast active
  • 6Replies
  • 770Views
  • 5 Following