Unable to remove IPv6 DNSs on 6.3.0

I received my Eero Pros today and the setup for mesh was quicker and easy.  After the setup, I disabled secured, enabled HomeKit, and decided to change the DNS to CloudFlare’s IPv4 and IPv6 DNSs.  After I noticed that it wasn’t working, I tried changing it to Google’s public IPv4 DNS and removed the CloudFlare’s IPv6.  Then I noticed that it wasn’t working either but also the CloudFlare IPv6 were still there.  I tried changing it to default and back again, but it doesn’t go away.



  • Version: 6.3.0 
  • IPv6: Off
  • HomeKit: On
  • Thread: On
  • Eero Secured: Off

Everything else is default.

I saw some topics about a bug related to HomeKit being enabled and not being able to use custom DNS, but disabling it would defeat the purpose of buying these routers.  Is there any bug fix release coming soon addressing these issues (Including custom DNS with HomeKit enabled?

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello JJB57 ,

    I would suggest you reach out to support. I'll send you a chat, if you have not called support already and got this resolved follow the instructions in my chat and we should be able to get this fixed for your pretty quickly.

      • JJB57
      • JJB57
      • 1 yr ago
      • Reported - view

      James thanks for the quick response.  I have not resolved this issue, so I’ll be reaching out to support later today.

  • I think there's a bug in the Eero software when it comes to IPV6. If you enable IPV6, then enter in your custom IPV6 addresses. If you decide later on to go back to IPV4, you can remove the IPV6 custom addresses and reboot, they magically appear back. I don't think they do anything, I just think it is a bug.

  • What's happening is that the default IPv6 DNS from your ISP is being pushd to your client.

      • ponsholm
      • ponsholm
      • 1 yr ago
      • Reported - view

      Stephanie_Sy In default DNS mode, if an ISP does not provide IPV6, this area should not be populated at all.

      If you opted for "custom DNS" and enter Google or CloudFlare values for IPV4/IPV6 (under enable IPV6) and then decided to change your mind to go back to IPV4, what used to happen the IPV6 values tend to remain.

      This is what I was referring to above. (latest iteration of Eero app may have fixed this) 

Like Follow
  • 1 yr agoLast active
  • 5Replies
  • 89Views
  • 4 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support