0

Eero DNS caching isn't caching...

Or is it just me...?

When I turn of the DNS caching (I had this previously with Eero 5, and now with Eero 6), while it does resolve the queries, it just simply doesn't cache them. Next time the same query sent to Eero takes again similar amount of time to respond (15-30 ms).

When I use dummy linux box with dnsmasq running on it, I can clearly see result of caching: cutting regular cold query from 15-30 ms to just 5 or 6.

Ironically, if I turn off caching, and sent query to Eero then: the story is different and resolve is in fact faster 😂

Has anyone else observed this behavior? Mind you yes, I tried resetting network, setting everything from scratch, etc... 

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Same here.  eero Pro 6 with eero Secure subscription.  Repeated dns requests take 70-80ms each time. I suspect they turn off DNS caching locally in the appliance when you have a Secure/Secure+ subscription, as much of the protections comes from using their resolvers.  If a web site has a long TTL and gets compromised, you wouldn't want to have to wait for the TTL to expire before Secure/Secure+ warns you about the web site and redirects you to the eero "website is blocked" page.

    Like
Like Follow
  • 3 days agoLast active
  • 1Replies
  • 31Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com