Ipads unable to join the network

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • has anyone ever had issues connecting the ipads to the Eero network?  for some reason since I got the Eero I have not been able to connect 2 different ipads to the network,  I did all recommended troubleshooting with Apple first and what it seems is that something on the eero networks is blocking the ipad access.  These ipads I was able to connect to other networks with no issues at all, so definitelly seems that somehow something in the eeros is denying the access to the network.  Any ideas or comments of what to do?  I already try rebooting from the modem, router and reset eero, but nothing will bring the access back to ipads.  I try disabling the Band Steering and nothing, pausing the 5ghz temporarily and neither that work...this is crazy, so any ideas will be well received.  Thankyou

      • thatsthequy
      • Enthusiast
      • thatsthequy
      • 7 mths ago
      • Reported - view

      Msada If they are running iOS 12.2 or older, make sure WPA3 is disabled in eero Labs.

  • thanks, I actually updated the ipads to the newest version, and one of them I reset all content and started it from scratch, I remove the option WPA3 and also the Band Steering and nothing, got the same message, then I try to connect the ipads to other networks and they connect seamlessly with no issues, so there has to be something on the eero that is bloking both ipads; just have not been able to figure it out...help welcome!

  • On your iPads, have you tried resetting their Network Settings?  Go to Settings>General>Reset>Reset Network Settings and then try connecting to the Eeros. 

      • Msada
      • Msada
      • 6 mths ago
      • 1
      • Reported - view

      Richard1864 thanks, what was causing the issue was the WPA3 but the first time did not work until I remove the WPA3 option and the reset the Eero, that actually changed the setting and it worked.

      Like 1
    • Msada Great!  I didn’t think of disabling WPA3, wonderful thinking there!  I will remember that!  :)

  • perfect

  • As I'm having a similar issue with my iPad, is it really just the WPA3 or have others found another issue ? My iPad also doesn't perform too well when using FaceTime. 

Like Follow
  • 8 days agoLast active
  • 8Replies
  • 266Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support