0

Devices "stuck" on original Eero

I finally setup my eero pro setup this morning, and so far I like the app and ease of use. I set the unit that is connected to my AT&T U-Verse modem first and had to wrestle with the DMZ+ Mode to get it to work. Since I have a lot of IOT devices, I kept the same SSID and password as my previous Netgear Router. This meant that while I was getting the DMZ+ mode to work, all of my devices connected to the initial eero. I then went about setting up the other eeros, at opposite ends of my home (I have the 3 pack). However, when I go into the app, I see that everything is still connecting to my original unit, even my AppleTV that is literally right next to one of the Eeros. Do I have to just wait it out while eero directs my devices to the correct unit? Or is there something else going on?

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi  ericmcgovern

    Thanks for reaching out and welcome to the eero community!

    It sounds like you never rebooted your network (which isn't necessary) so the devices stayed connected to the eero they were already connected to. Since devices like Apple TVs don't roam, they won't look to change the eero they are connected to. In order to move the device to a closer eero, we recommend rebooting that device, or if not possible, rebooting the incorrect eero it is connected to.

    I hope this helps!

    Like
    • Jeff C. thanks for the response! I have one device in particular that is connecting to an eero that is much further away than the one it should be connecting to. I rebooted that device (a Skybell) and it connected to the correct eero. However, a few hours later I looked it in the app and it hooked back up to the one that is further away. Not sure I am that concerned, because it is showing full strength even connected to the "wrong" one. 

      Could it be my eeros are too close together?

      Like
      • Jeff C.
      • eero Community Manager
      • Jeff_C
      • 4 yrs ago
      • Official response
      • Reported - view

      ericmcgovern  —

      We should take a look. Feel free to give us a call at 1-877-659-2347 or email us at support@eero.com .

      Like
  • Was there a resolution to this? I keep experiencing the same issue with my Skybell connecting to the base eero rather than the one closest to it. I've reset the Skybell, but it always reverts back to the base eero after some time.

    Like
  • I'm having the exact same issue with a Skybell HD. I have 3 wired 2nd generation eeros, and both Skybells connect to the base, and literally have one bar. Each have a very close wired eero, but won't connect to either. Any help would be great. This is one of the most critical items on my network, and worked fine with my Asus network and extenders before migrating to the eero.

    Like
      • alpharon
      • alpharon
      • 3 yrs ago
      • Reported - view

      damoncahill I'm still having this problem. The only band-aid solution that works for me is to reset the Skybell. This works for a couple weeks until I have to reset it again for the same issue.

      Like
    • alpharon I tried that, and no luck for me. I have two SkybellHD. The one on the side of the house connects to the wired eero right inside the Front door (two eeros closer). The one on the front door connects to an eero upstairs on the opposite end of the house. Again, two eeros are much closer, including the one right inside the door that my side door garage Skybell connects to. Neither have a great connection. I understand the client makes the roaming decision, but this is so frustrating!

      Like
  • Hi folks - I am a new Eero customer as well (3 hardwired Gen2's).  I see similar behavior from my iPhoneX where it stays connected to an Eero far away.  I am told in discussion with support that  it has to do with how the devices select the network (it is the devices that select the access point, not vice versa). At lleast for Apple, the phones will continue to select the same station they were connected to previously unless the signal strength gets quite low.  The solution I've found that works is to go into the app and 'reset' the Eero station that the device is currently connected to (the one that is far away) and then the device (at least my iPhone) will connect to the near/strong Eero.  It isn't ideal and I hope they find a way in the app to help - maybe by kicking that device off of it's Eero so it has to find another?  Note I also think I probably didn't really need the 3 in my 2100 sq. ft house but I wanted Wifi to be awesome everywhere.  

    Like
    • Saratoga_Steve letting the access point (in this case, the eero) kick clients off gets really tricky and basically ends up causing more problems than fixing them. An easier workaround to your issue is just turn off WiFi your iPhone, wait a couple seconds, and turn it back on. Then your iPhone should connect to the nearest eero (with the stronger signal).

      3 eeros for 2100 sq/ft isn’t terribly unreasonable. I use 3 to cover my 2172 sq/ft. I could use 2 to cover *inside* my house, but having the 3 gives me better coverage outside my house while in the yard. 

      Like
Like Follow
  • 3 yrs agoLast active
  • 9Replies
  • 1951Views
  • 7 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com