Can't seem to connect - Sonic Fiber w/ Eero

I have sonic fiber and my setup chokes in the middle of registering eero.   Eero is found, and the internet connection step seems to complete, but during registration I get the error that eero couldn't connect to the internet.   I've tried 1000 things and can't seem to make it work.

Here's my setup:

Fiber comes in to the house and terminates at the Sonic ONT.  the ONT is connected to the Sonic Smart R/G.   I connected the Eero to the back of the gateway.   I previously had the same setup with a TP-Link Archer C9 (which recently failed) and it was working awesomely (with download speeds in the 800s and uploads in the 900s).

What am I missing?

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi littlemonster

    Sorry to hear the issue you are running into.

    During setup, did you power cycle your fiber modem? If not, please powercycle it during set up and see if that resolves the issue.

  • Yep.  I've tried that several times :-(

      • Jeff C.
      • eero Community Manager
      • Jeff_C
      • 4 yrs ago
      • Reported - view

      littlemonster —

      Thanks for trying that. 

      If you haven’t yet, could you try the other Ethernet port on the back of the eero? If that resolves the issue, or doesn’t, please send us a note at support@eero.com so a member of our support team can take a look into the issue you’re running into.

  • Absolutely.   That is one thing I didn't try.   Will do that and update here and create a ticket if necessary.  Thanks so much for your help.

  • I got it.  It’s all good.  Working great!

Like Follow
  • 4 yrs agoLast active
  • 5Replies
  • 612Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support