Multiple Devices Showing as Offline when they Aren’t


I purchased 4 Eero devices (standard, not pro or beacon) yesterday. Today I installed all four, which are all wired in via Ethernet. 

the signal strength is fantastic everywhere and I am very pleased with the results. It has pretty much tripled my WiFi speed too. 

my only issue is that, out of 51 connected devices, around 17 are constantly showing as offline when they are in fact online and working fine (lights, cameras, phones etc). 

I have restarted the entire network from the app but they still show as offline (some of them show activity when pressed in the app too which is also weird). 

Does anyone have any advice on this?


Many thanks



27replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Can you describe your topology?  Is there at least 1 eero upstream of the switch where the other 4 are plugged in?

  • Hello


    iI am not entirely sure what you mean. However, the network did an update overnight and seems to have rectified itself! :)

  • I have the same scenario. Modem connects to eero pro. Also have two beacons. Everything seems to be working fine. But always see a bunch of devices showing offline. 

  • I just setup a new eero and noticed the same.  It was working fine until I tried to update which failed and now having issue with most of the devices showing offline while they aren't.  Also update isn't going through.  Not sure as everything is working except the app displaying the infromation.  

  • You need to call Support before they close in a few hours. If you miss them they are working tomorrow. 

  • I tried calling and was on hold for over 30+ min and then gave up.  What would support do that I can't do by just rebooting them?  Are they able to check the registration on their end and possibly clear it out?

  • Yes, you’d be surprised at what they can do. They can rebuild an unresponsive eero network completely if your app is not responding to commands as long as the gateway eero is online. 

  • Thanks on the phone with them now.  Tried some things still waiting on them as it seems 2 out of 3 eero didn't get updated and when we try updating they fail.

    I think due to that in the app the devices that are connecting to the other 2 eero are showing offline in the app even they are online.  Possibly all related to not all eero being on the same software version.

      • David S
      • David_S
      • 2 yrs ago
      • Reported - view

      sal0000 Great ! They'll get you fixed up..hang in there!

  • Thanks David.  They informed me that the main eero was updated but the other 2 failed and the download for software was queued up.  They cleared that and it still didn't help.  I had to add a router between my cable modem and eero for it to go through.  Odd they told me that Aaris SB6183 doesn't work well with Mesh system.  First time I have heard of that.  The reason many devices were offline even though they were online is because those devices were connecting to the 2 eero that were one version behind the main eero.  


    Hopefully this doesn't happen again as the only issue I ran into thus far was OS update not the usage of the wifi as it seems to be working great.  

  • Glad to hear they got you back online regardless Sal!

    I'm not entirely surprised about their comment regarding the SB6183. I know eero had issues with 6183s a year or so ago with a particular, older firmware version. Evidently some ISPs have refused to keep their 6183s up to date...and our ISPs are responsible for keeping all modems owned by them or purchased by their customers up to date with current firmware.

    Here's a link to this issue in eero's knowledge base:


    I'm running firmware version: D30CM-OSPREY- on my 6183 which so far has been problem free...finger's crossed.

    Like 1
  • I purchased a 3 pack of eeros (Model: J010011) a few weeks ago and put 2 in service.  After I updated the firmware last week to version 6.0.2-11, all of my wired devices are not showing as "Offline" sometimes.  Occasionally one or two devices will go online for a bit then go back to offline.  I have restarted and power cycled my router and eeros and still the same issue.

    Like 1
  • same thing happened to me ljschoepke  I haven't really notice them go back online. It's only with the wired devices.

  • Same for me, all my wired devices are working but show in the app as offline. 

    Like 1
  • I seem to have the same issue since the update. The majority of my wired devices are showing offline even they appear to be functioning correctly (with the exception of port forwarding as far as I can tell). They intially show as online if they are restarted or powered up and it appears to be random which devices stay online (not eero device specific) as i two devices plugged into the the same eero but one shows as online and the other is offline. I have an unmanaged switch connected to the main unit and all the devices are showing as offline now but it used to work fine before the update.

    Like 1
  • Same issue for me. My wired devices shows that it is offline but it’s working fine. 

    Like 1
  • I'm glad I'm not the only one having this problem! I just ditched multiple wireless access points around our house for two Eero 6 pro devices to streamline our connectivity. I love the iOS interface and the ability to name network devices, but several devices connected by CAT5 are displayed as offline. They still work, as others have reported, but it's bothersome to observe this bug. If you don't already know the IP address of the device you're out of luck trying to make it work (I'm talking about two surveillance cameras specifically). I reported the problem online to Eero support and I'll report back if they offer a solution. I would also add that it would be nice to be able to access the mesh network from a browser like every other router I've ever owned.

    Like 1
  • Same issue here, devices showing offline when they're not. Devices showing up with new names. All after the 6.0.2-11 update. Does Eero tech monitor these threads? Is there a way to rollback the update?

    Like 1
  • same on my system too after update most wired connection showing offline but working not what i expect on a mesh system that's not the cheapest by far 

  • Eero customer support finally got back to me three days after I reported the problem with the interface not showing all hard-wired devices. The rep basically ignored my question (or didn't understand it) and gave some generic instructions that had nothing to do with the issue.

    I was so fed up I initiated a return of my two Eero 6 Pro routers and today when asked why I told them exactly what had happened. Here's the response I got: 

    "I do apologize with the experience you had with the previous rep. I can confirm we know what's going on with the app. It is purely cosmetic and we are working on fixing it and bringing an update to the eero system as well as the app. If you would still like me to continue with the return I will."

    I suggested to the second rep that Eero should monitor its own community forums to understand the frustration experienced by its customers. I probably would have stuck around with Eero if the company had acknowledged it has a problem and is working to fix it. But I've already set up my new Google Nest mesh and it's working great.

  • After I updated the firmware last week to version 6.0.2-11, all of my wired devices are not showing as "Offline" sometimes.  Occasionally one or two devices will go online for a bit then go back to offline.  I have restarted and power cycled my router and eeros and still the same issue.

  • 6.0.3 came out today and it seems it fixed the issue.

  • I just upgraded and my one specific device stills go offline after about an hour, and IS NOT operational. Not sure if this is the same symptom as the rest on this thread, but seems pretty close

  • 6.0.3 hasn't pushed through to mine, still on an shows me up to date. Anybody know how to force updates?

  • The biggest issue with a device showing as “not connected” when in fact the WiFi is working perfectly, is that you can’t print from the device as long as it’s “not connected”.   

    My Epson 3710 works flawlessly from every device as long as it’s showing connected to Eero and as long as the device (laptop, iPad, iPhone,etc) is showing connected.   My MacBook Pro is currently connected to WiFi, but is shown as “not connected” to Eero, therefore cannot print to Epson 3710 printer.   Very frustrating!!!

    Any help??  Any suggestions??

  • I have had the same issue from day one with my eero pro 6 network. Wired devices generally show up as offline. It seems mostly cosmetic since they seem to work. Have not experienced the failure to print issue, but have not checked it yet.

    I am working with support on an issue with some devices not working with ipv6.

    I spent a pretty penny on 3 eero pro 6, and am subscribed to the security plus package. They are getting a fair chunk of my money, so I sure hope they work out the issues. 

Like2 Follow
  • 1 yr agoLast active
  • 27Replies
  • 2631Views
  • 21 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support