0

Not getting advertised speed on Pro 6e

I’ve got gigabit fiber service into house. Gateway eero Pro 6e is connected to modem. And then out to gigabit unmanaged switch. MoCA wired backhaul to first satellite Eero Pro 6e (Motorola MoCA 2.5 adapters, RG6 coax and Cat6 Ethernet cables). 
 

Speed at modem, via Eero app is mid to high 900s up and down. AppleTV connected to satellite Eero via Ethernet, and getting 903Mbps. But iPhone connected to the satellite eero Wi-Fi is only getting 340-426 Mbps. MacBook Pro (2019 Intel model) is only getting 313Mbps. These tests are all through Speedtest app. 
 

Fast.com gives a speed of 480 Mbps for the MacBook, 570 Mbps for iPhone.
 

is this the fastest I can expect over Wi-Fi even with the wired backhaul? Eero’s literature makes it seem like speeds should be much higher. 

8 replies

null
    • cMoo92
    • 7 mths ago
    • Reported - view

    Sounds like everything is working normally. Most likely, those speeds on your phone and laptop are essentially as much as those devices support over Wi-Fi.

      • mikegoldnj
      • 7 mths ago
      • Reported - view

      cMoo92 Thanks. It’s a bit confusing based on what they state regarding the specs. 
       

      “Supports network speeds up to 2.3 Gbps (a gigabit wired and 1.6 Gbps wireless).”

      • cMoo92
      • 7 mths ago
      • Reported - view

      mikegoldnj yes, it is *technically* capable of that, but not in a real world environment. Your devices will have different capabilities based on their Wi-Fi chip, plus other devices connected to your network, plus environmental interference, etc, etc, etc. 

      • mikegoldnj
      • 7 mths ago
      • Reported - view

      cMoo92 Here’s a somewhat related question.  How is it possible that the wired data rate for my gateway Eero (connected directly to fiber modem) is 1 Gbps but the wired data rate for the satellite connected to the gateway via MoCA has a wired data rate of 2.5 Gbps?

      • cMoo92
      • 7 mths ago
      • Reported - view

      mikegoldnj Because the ethernet port on the fiber modem only supports 1Gbps. 

      • mikegoldnj
      • 7 mths ago
      • Reported - view

      cMoo92 Thanks again.  I would have thought that that bottleneck would have been passed through downstream. So this metric is merely the speed possible between the two directly connected ports?

      • cMoo92
      • 7 mths ago
      • Reported - view

      mikegoldnj that is correct

    • iamtmo
    • 6 mths ago
    • Reported - view

    I have an even more stripped-down version of this with 1GB Fiber up and down with Eero ^e connected directly to Fiber ONT which has a multi GB port. Just like this on my iPhone 14 Pro, I get 300 to 400 Mbps max, and the same on my 3-week-old M2 Mac Book Pro. The MBP gets easy Gbit on ethernet as do a couple of windows 11 machines I've tested. Just the wifi will never get that 1Gb where the eEro show mid to upper 900s all the time and I see the same over ethernet. I know the wifi on both of my devices should see the 1GB but I have never seen it even with a direct speed test from eEro/ISP ONT to ISP Speedtest. I see tons of other complaints from other users with other routers on forums as well so I believe it's devices, not eEro. I've just been connecting everything I can like firesticks, TVs, and computers via ethernet and phones just suck as slower speeds.

Content aside

  • 6 mths agoLast active
  • 8Replies
  • 148Views
  • 3 Following