Eero Mesh & Smart Plugs

Afternoon all, 
I have a strange issue happening and cannot pin point where the issue lies. 

I have two Teckin Smart Plugs (2.4GHz) which have connected and worked with my Mesh without any issue at all.  

Recently, I tried to reconfigure them but they will not connect into their native app whilst 5GHz is active on my Eero.  I have temporarily paused the band and they still won't connect. 

The only way I can get them to connect is by using a Mobile Hotspot. 

These plugs were working with my mesh as they were actively used at the beginning of the year. 

Has anyone else experienced the same?  Is there a correlation between the latest updates and these issues. 



3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi @ginge

    Try making sure WPA3 is disabled (eero app->Discover->eero Labs.  I have heard anecdotal information that WPA3 might interfere with those plugs.  Have you tried resetting the plugs to factory defaults in case something has gone wonky in the plug itself?

    Like 1
      • Ginge52
      • Ginge52
      • 3 mths ago
      • Reported - view

      Hi Michael, 

      Thank you!  I have just disabled WPA3 and the plugs were discovered immediately. 

      Thanks for the support! 

    • Ginge52 Excellent!  I'm glad it was something simple.

Like Follow
  • 3 mths agoLast active
  • 3Replies
  • 50Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support