Recent issue where Mac OS software doesn't download correctly

I've been struggling with Eero for the last 1-2 months.  I've had a system that ran really smooth for the last 9 months.  What I thought was a Mac issue turned out to be an eero issue.  I have a network of 9 second get eero devices.  One of the eero's was acting as the router.  

I've been unable to download and install most iOS and Mac OS software updates for the last 1 to 2 months.  I have an iMac Pro, a MacBook Pro, and a Mac Pro.  I've had issues with wired and wireless connections.  Software will fail to install due to checksum issues or simply messages that there was errors downloading software.  It's been a real challenge to do anything and I really struggled to get updated from Mojave 10.14.0 to 10.14.1.  

Today I turned off all of eero's network security features and beta software.  This didn't fix the issue.  I then removed the eero that was acting as the router and replaced it with a Cisco small business router.  I set the eero's to bridged mode.  After I did this I was able to update all of my Mac computers to 10.14.1 without issue.  Not sure what the issue is, but thought that I should share.  I would love for eero to fix this so I can use an eero as the router and so I can use all of the advanced features again.  

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I’m not quite sure this is actually an eero issue. My suspicion is that it’s actually a DNS issue through eero Plus (which uses Zscaler’s service), or possibly even something on Apple’s end. I had a similar issue with my MacBook Pro not getting 10.14.1. I don’t recall if I had the same issue at home (using Zscaler), or just at work (using OpenDNS)—I’m actually pretty sure I just had the issue at work and didn’t even try at home (I rarely use my MBP at home).

    I think it may have just been more or less a coincidence that switching to the different router fixed the issue. The reason being that just because you had disabled eero Plus, your devices probably still had the Zscaler DNS IP addresses. Switching to the new router forced all your devices to get a new IP address and thus new DNS addresses. Had you tried doing a DHCP refresh on your devices after turning off eero Plus?

  • Thanks for the input.  I also thought it might be related to eero Plus, which I have.  I tried turning off the features in the eero software, but that didn't fix the issue.  I did not do a DHCP refresh.  That could be something to look at if I move back to using the eero as a router.  Right now everything is running very smooth with the Cisco RV320 router, so I haven't wanted to mess with anything.  I'll submit more info when/if I have more issues or feel like messing with things again and seeing what happens.  

  • I updated my MacBook to Mojave from High Sierra using eero as my router and it went smoothly. I do not have eero plus security though. 

  • Click "HP printer error code 0x83c0000a" this will bring you to a tab that lists your printer. Search for the name of your printer and right-click. Make sure your printer has been set as the default printer from the drop-down menu.

  • I only have eero secure but have had no issues updating Mac OS on any Mac devices prior to or after subscribing to Eero Secure.  

Like Follow
  • 7 mths agoLast active
  • 5Replies
  • 262Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support