2

Sonos on Guest network

Why doesn't the Sonos (connect amp) work in the eero guest Network, even with my phone on the guest Network as well?

I have all of my IoT devices (ecobee, echo, etc.) and the family cell phones in the guest Network, keeping only the true computers in the full Network. Everything else works great, but I can't get the Sonos app to recognize the Sonos if it is in the guest Network after successfully setting it up?

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This is because all the devices in your guest network are isolated from each other (this is for security measures). They can’t see other devices on the same network. Your other IoT devices work because you are connecting to them over the internet and not your local network. The Sonos works differently though where it has to be able to see the devices on the local network. If you move the Sonos to the local network (along with whatever other devices that need to see it like your phone), then it will work properly.

    Like
    • cMoo92 I understand what you are a saying, however, it doesn't seem like the devices in the guest network are isolated from each other. When in the guest network together I can cast Spotify to my Amazon Echo, that option only becomes available when the cast target is available on the same network (which is what I wanted to do to the Sonos), not via the internet.

      In any case, thank you for the response. I have moved the phones, tablets, Echo and Sonos inside the network and all is 'well'.

      Like
    • toddbecker glad to hear everything is working well for you. 

      I think I can solve the puzzle about why Spotify was working while on the guest network. I don’t own and have never used any Echo products, but I did some quick research online and it appears that what you’re referring to with playing Spotify on your Echo is done via Spotify Connect, which doesn’t require the devices to actually see each other (I have used this before on my Mac and iOS devices using Spotify). I believe they can know when they are on the same network by looking at the public IP address. So again, like your other IoT devices, this worked because Spotify on both devices was communicating through an external server.

      Like
  • I know this is an old thread. I believe the reason you are not able to use Sonos speakers on the guest network is due to multicast being blocked.

    I am linking this thread to a feature request to enable multicast on the guest network (which would allow Sonos speakers to work on guest networks). 
    https://community.eero.com/t/y7g40n/allow-airplay-apple-tv-chromecast-control-on-guest-networks

    Like
Like2 Follow
  • 2 Likes
  • 3 yrs agoLast active
  • 4Replies
  • 901Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com