0

Using Custom IP address and Internal Subnet will not work

I have the need to have my eero subnet to match that of my main router for internal communication across devices and to be able to set static IPs. 

I do not want to use bridge mode on my eero system because I will lose the features I bought the system for.

I have Verizon FIOS directly into my home vie eathernet to my own router that also serves as a firewall. I don't want the eero as my external device as I have read that the security features for the built-in firewall are lacking (such as allowing spoof attacks with my internal addresses), and there is no public info I can find on the basic FW features. I am not interested in eero Plus to gain access to basic features.

My problem: Every time I change the DHCP section to custom, my second eero drops off and will no longer connect, even if I remove it and add it back after the change. Also, the main eero shows as green and says "everything Looks good", but it will not let anything connect to it until I change it back to "Automatic".

What I am doing:

- My external router is set as 192.168.1.2, DHCP issuing from 192.168.1.50-99

- My main eero runs via eathernet from that router

- My second eero is wired vi eathernet 2 floors up.

- I tried various address schemes (10.0, 192.168.7, ect.)

- Settings under Network --> DHCP & NAT --> Manual IP:

  - IP address Prefix: 192.168.0.0

  - Lease Range: 

    - Subnet IP: 192.168.1.0

    - mask: 255.255.255.0

    - Starting IP: 192.168.1.100

    - Ending IP: 192.168.1.254

  -After I do this it will save and restart. The new address scheme will stick, but the second eero will just say needs manual restart forever and will not connect, even if I remove it and add it again. Also the main eero will not let anything connect even though showing as green until I set it back to auto.

Workaround I tried: I tried to just let eero do automatic and set my external router to the eero scheme after setup, but then the eero needs to be rebooted to get the DHCP lease from the router, and there is this totally unnecessary "feature" in eero that rests to a new IP scheme on reboot. (Why?? is this an effort to sell eero plus to be able to use static internal IPs?)

Is there a way to use a custom IP scheme that will stick after reboot? Did I waste the $400 when I bought it (a while ago, just got around to setting it up).

I'm on eero pro 3 pack gen 1 and all updates are applied. My second eero is wired via eathernet and in default setup connects flawlessly.

I know that was long, but wanted to be throughout. I appreciate any help.

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I'm using 172.18.222.x with 3 eero 2nd gens and 2 beacons without issue.  Perhaps I'm not understanding what you're trying to do.

    Reply Like
      • bille2021
      • bille2021
      • 1 yr ago
      • Reported - view

      txgunlover Did you do anything specifically different than what I describe above? You're on 2nd gen. I wonder if this could be a 1st Gen issue. The symptoms seem more like a limitation and not an error on my part as far as I can see.

       

      Thanks.

      Reply Like
    • bille2021 Nope, all of my eero's and beacons take the change after applying the setting on the eero acting as router.

      Reply Like 1
  • Support hard coded my preferences in the cloud and it works now.

    Reply Like
  • I have this exact issue.  Does support monitor these threads?

    Reply Like
      • bille2021
      • bille2021
      • 7 mths ago
      • Reported - view

      Boydweber I don't know if they monitor this site, but of you contact support they'll hardcode the sudnet you want on their side for you. That way it won't change when you reboot.

      Reply Like
Like Follow
  • Status Answered
  • 7 mths agoLast active
  • 6Replies
  • 2405Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com