3

Disable custom DNS as an option when Eero Secure is active

I hit a snag with my Eero mesh network because I normally use the custom DNS settings to a private server I manage for my home network. When I enabled Eero Secure I could tell that a different DNS server was being used because my private network domains stopped resolving. The custom DNS was still enabled and configurable so I was perplexed for a while until it occurred to me the content filter was probably using a specific DNS server and had overridden my custom DNS settings. I disabled Eero Secure and custom DNS worked again. My suggestions:

  1. Disable (gray out) Custom DNS as an option in the event it has is already being used if Eero Secure is activated.
  2. Show an alert that Custom DNS will be deactivated in the event it is being actively used when a user attempts to activate  Eero Secure.

greyscale

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I ran across the same issue. I finally checked at https://www.dnsleaktest.com and it showed the system using the eero secure dns servers which explained the results I was getting. I still have secure enabled, it was just confusing at first that my custom dns entries were not resolving and nothing showing in the app that explained it.

    Like
Vote3 Follow
  • 3 Votes
  • 6 mths agoLast active
  • 1Replies
  • 93Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com