3

Eero network no longer compatible with Private Relay

This morning my iPad popped up a notification that Private Relay does not work with my Eero network. 

I've been on iPadOS 15 the past week. I have Eero secure enabled. And everything has been working fine since until today it forced me to turn off private relay. 

Is Apple's new feature not compatible with Eero? And any fixes coming if so? 

34replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I just received a notification a few moments ago.  

    Like
  • I had the exact same message this morning.  But for me, I I've wanted it off at home, and actually blocked it with pihole.  I just want to be able to use while away from home. 

    Like
    • Hello rminear68 chump247 premier_blue ,

      You can turn off Private Relay for just your eero network by going into your iPad or iPhone in the following area: open the Settings app > select Apple ID (at the top above Airplane Mode) > select iCloud > select Private Relay > toggle off the “Private Relay” switch

      On a MAC you can disable Private Relay for your eero network by doing the following: pen System Preferences > click Network, select the eero network name (must be connected), uncheck the "Use iCloud Private Relay" box

      Alternatively you can disable Private Relay for every device on your network by adding two links to the block list.

      mask.icloud.com

      mask-h2.icloud.com

      Like 1
      • Betsy
      • Betsy
      • 4 wk ago
      • 1
      • Reported - view

      James I have this issue too. I don’t want to turn off private relay. It’s a major feature of iOS15 that I love. I’ll get a new router system before I turn off private relay for sure. Please resolve this on your end!

      Like 1
      • sri
      • sri
      • 3 wk ago
      • Reported - view

      Betsy Same here. I dont want to turn off private relay. I want Eero to make it so that I can continue using private relay

      Like
  • I have also same issue any suggestion regarding this so please reply. Thanks in advance.

     

    MyCCPay

    Like
  • I also have this issue. I want to use private relay while on my eero network. It only stopped working with the 6.5.0 update please fix it.

    Like
  • Does Eero have a whitelist?

    Like
  • I too expect to be able to continue to use private relay on my home Eero network.  FYI, I haven’t updated to 6.5.0 yet and am also getting the message.  I’m currently on v 6.4.0-2092.

    This seems like something that should be addressed.

    Like
  • Also having same issue: updated to 6.5 and got the same error message in iOS. I'm really looking forward to using Private Relay as much as possible. I can think of nefarious reasons why eero/Amazon wouldn't want people to use it, but I'll give them the benefit of the doubt for now, hope it's just a mistake. They're going to have a lot of unhappy or ex-customers if they maintain a block on this feature.

    Like
  • Can we get a position from Eero on this? Is this a “fix” that’s in the works? I know Apple releases these new features without enough advanced notice for others to adjust, so I can be patient while you work through fixing it, but I need to know that a fix is in the works.  If, on the other hand, you intend to leave it as is, then it’s only fair that you let us know that so we can make a decision as consumers and customers whether we’ll stick with your product or go elsewhere.

    We as individuals may not have much left for a voice, but we can still make statements with our $s.  Just to be clear, if there is no intent to fix this, then my Eero system will be on eBay shortly and another solution active in my home.

    Seriously hoping for a formal Eero reply here.

    Like 6
      • frozo
      • frozo
      • 3 wk ago
      • 1
      • Reported - view

      RGordon013 I am 100% with you on this. 

      Like 1
      • birdsey
      • birdsey
      • 3 wk ago
      • 2
      • Reported - view

      RGordon013 Ditto. I'm running eeroOS 6.5.1. I was hoping that would fix this issue but I was notified yesterday that iCloud Private relay cannot be used on this network, so the issue persists. I totally understand that a fix could take a few weeks, but it would be nice to know a fix is coming or that the issue has even been acknowledged by erro.

      Like 2
    • RGordon013 count me in on this as well. I’d rather use iCloud private relay than eero, if I have to choose. 

      Like 1
      • sri
      • sri
      • 3 wk ago
      • Reported - view

      msfeinstein +1 on making private relay work on Eero. I got the same message. Eero, can you let us know if you are working on it?

      Like
  • Hi All,

    I initially clicked Use Without Private Relay several weeks back.  Today, I went back in and enabled Private Relay on all my Apple devices and thus far, things appear to be working ok.

    Like
  • Within the eero app follow these steps.

    1. Click on Discover tab on bottom nav.
    2. Select "eero Secure" at top to drill down.
    3. Scroll down to the Advanced section at bottom, and select "Block & allow sites"
    4. Select Allowed tab and then you will see an "Add Allowed Site" button.
    5. Click on this to add the entries James listed above 

      mask.icloud.com

      mask-h2.icloud.com

    6. Enable Allow for Network.

    7. It may ask you to allow aliases it finds, click to add these as well.

    Hope this helps everyone.

    Like 4
  • Thanks to those who found and posted the related solution! Really appreciate it.  I made the changes remotely on my network, will test it tonight when I get home.  Sounds like it’s fixed, based on other responses.  That solution makes is logical, what isn’t is why it’s not globally white listed by Eero.  Still, if this addresses it, then so be it.

    Like
  • I added those to my white list and am still getting the notice that relay isn’t available. Going to try a restart of the network and ensure I’m on the latest release. Otherwise there must be additional settings needed. 

    Like 1
  • UPDATE: The fix worked for a little while, but for a couple days now, even with the domains whitelisted, again I'm getting the "Your network settings prevent content from loading privately" error in Mail on iOS and macOS, even with Advanced Security and Ad Blocking turned off in eero. I used Little Snitch to see if the OS was trying to reach any other "mask" domains, but did not see anything new.

    Like
  • Same. I wonder if canceling Eero secure will fix it. At least until I can find a new router system and sell this one.

    Like
    • Same here. Reverted to the same behavior after a few days. 

      Like
  • You might try restarting your eero network. That’s the only other thing I’ve done since I added those entries.  I think I have restarted my Mac with Monterey as well. 

    Like
  • This is killing me.   Why did 6.5 block it.   iCloud pr is also more important to me than eero
     

    I don’t subscribe to eero secure, so is there a way otherwise to allow private relay?   

    Like
  • I added euro Secure as above.  iCloud Support did not work until I changed the iCloud settings (as above) AND went into the Network settings for each device and checked “iCloud Private Relay” for my network.  So far, things are working.

    Like 1
      • mrthrd
      • mrthrd
      • 2 wk ago
      • Reported - view

      ScottA yes this second step is important !

      Like
  • A fe more notes:  1) on iPhones and iPads, you need to configure the network in Wi-Fi settings.  2)  You may have to turn off Wi-Fi or restart your device for everything to take effect.

    Like
  • I tried the steps above (eero secure + subscriber) and it would work for a day or two, then it would stop working. I opened a case with eero Support and this was the disappointing response I received:

    “Hello Peter,

    Thank you for contacting eero technical support!

    Sadly eero secure + is not compatible with iCloud private relay.
    You would not be able to use both of them at the same time.

    Let us know if you require more assistance on this.

    Have a nice day,”


    I’ve asked if deactivating eero secure + would resolve the issue but haven’t heard back yet.

    Like
  • I have eero secure and it's still working after almost 10 days.  Don't think there's any difference with secure+ that would cause the issue.  You might try "Forget Network" for the problem wifi connection and try adding it back.  It could be there's some caching happening somewhere.

    Like
  • I have had mixed results with the solutions above.  iPhones and iPads are working 90% of the time, my wife's Mac works 50% of the time and my Mac doesn't work at all.  I haven't determined the difference between the systems  yet.

    Like
  • As many have reported, this is a hit or miss solution. Also, if you’re running Pi-hole on raspberry pi it will disable network wide adblocking. You’ll have to manually remove the iCloud entries to restore Pi-hole functionality. ¯\_(ツ)_/¯

    Like
Like3 Follow
  • 3 Likes
  • 11 days agoLast active
  • 34Replies
  • 685Views
  • 25 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com