4

Eero network no longer compatible with Private Relay

This morning my iPad popped up a notification that Private Relay does not work with my Eero network. 

I've been on iPadOS 15 the past week. I have Eero secure enabled. And everything has been working fine since until today it forced me to turn off private relay. 

Is Apple's new feature not compatible with Eero? And any fixes coming if so? 

68 replies

null
    • Betsy
    • 2 yrs ago
    • Reported - view

    Same. I wonder if canceling Eero secure will fix it. At least until I can find a new router system and sell this one.

      • msfeinstein
      • 2 yrs ago
      • Reported - view

      Same here. Reverted to the same behavior after a few days. 

      • Have you tried unplugging it and plugging it back in?
      • dsimerly
      • 1 yr ago
      • Reported - view

      Betsy I don't subscribe to eero Secure and it's happening for me. I think Amazon/eeror just isn't really as committed to allowing their users to protect ourselves as they'd like us to believe. If eero doesn't step up and fix this soon, I'll be looking for an alternative mesh network solution.

    • dppeak
    • 2 yrs ago
    • Reported - view

    You might try restarting your eero network. That’s the only other thing I’ve done since I added those entries.  I think I have restarted my Mac with Monterey as well. 

    • Dugbug
    • 2 yrs ago
    • Reported - view

    This is killing me.   Why did 6.5 block it.   iCloud pr is also more important to me than eero
     

    I don’t subscribe to eero secure, so is there a way otherwise to allow private relay?   

    • ScottA
    • 2 yrs ago
    • Reported - view

    I added euro Secure as above.  iCloud Support did not work until I changed the iCloud settings (as above) AND went into the Network settings for each device and checked “iCloud Private Relay” for my network.  So far, things are working.

      • mrthrd
      • 2 yrs ago
      • Reported - view

      ScottA yes this second step is important !

    • ScottA
    • 2 yrs ago
    • Reported - view

    A fe more notes:  1) on iPhones and iPads, you need to configure the network in Wi-Fi settings.  2)  You may have to turn off Wi-Fi or restart your device for everything to take effect.

    • Davis05
    • 2 yrs ago
    • Reported - view

    Eero, just know that firmware issues sours existing users, and keeps new ones away too. I know you don’t like issues either, but apparently something has to change on Eero’s side of things for faster resolution or widespread rollbacks or something when issues occur. Also, for the love of everything why is there no ability to hold off on firmware upgrades? If you are going to force people to upgrade at minimum give the option to remain one or two versions behind for stability’s sake. 60 day hold option people can choose to let bugs get worked out. Something, anything needs to be done for Eero’s reputation and customer happiness.

    I’m testing a TP Link x20 mesh setup now and it’s working out great! Zero issues so far and I’m at twice the speed of the Plume based system I’m coming from, maxes my internet speed when connected wireless, when on secondary mesh APs no less, so I am happy. Full 200mbps no matter where I test at. I’ll upgrade to a higher end TP Link system now that I know it’s a solid solution.

    I will continue to read here, and maybe one day I’ll join if things get better and forced upgrades don’t continue to bring people down. Thanks again for all the valuable information everyone!

     

    MyCardStatement Login

    • pdxcubfan
    • 2 yrs ago
    • Reported - view

    I tried the steps above (eero secure + subscriber) and it would work for a day or two, then it would stop working. I opened a case with eero Support and this was the disappointing response I received:

    “Hello Peter,

    Thank you for contacting eero technical support!

    Sadly eero secure + is not compatible with iCloud private relay.
    You would not be able to use both of them at the same time.

    Let us know if you require more assistance on this.

    Have a nice day,”


    I’ve asked if deactivating eero secure + would resolve the issue but haven’t heard back yet.

    • dppeak
    • 2 yrs ago
    • Reported - view

    I have eero secure and it's still working after almost 10 days.  Don't think there's any difference with secure+ that would cause the issue.  You might try "Forget Network" for the problem wifi connection and try adding it back.  It could be there's some caching happening somewhere.

    • ScottA
    • 2 yrs ago
    • Reported - view

    I have had mixed results with the solutions above.  iPhones and iPads are working 90% of the time, my wife's Mac works 50% of the time and my Mac doesn't work at all.  I haven't determined the difference between the systems  yet.

    • prince_1999
    • 2 yrs ago
    • Reported - view

    As many have reported, this is a hit or miss solution. Also, if you’re running Pi-hole on raspberry pi it will disable network wide adblocking. You’ll have to manually remove the iCloud entries to restore Pi-hole functionality. ¯\_(ツ)_/¯

    • RyanArm
    • 2 yrs ago
    • Reported - view

    This is the SOLUTION for me. When you get the prompt saying your WiFi network isn’t compatible with iCloud private relay, just tap on “Use Other Network,” and then just go back to what you were doing. Everything continues working normally despite the prompt. It’s a ghost prompt!

    • ak1234567
    • 1 yr ago
    • Reported - view

    I believe I have it working on iPhone and iPad (via the allowed addresses and steps above) but can't seem to get it workin on a Mac. Any ideas?

    • ScottA
    • 1 yr ago
    • Reported - view

    The recent upgrade of MacOS 12.1 seems to have corrected the problem on my MacBook Pro.  I did have to check the box in Settings -> Apple ID -> Private Relay

    • obviouslysilent
    • 1 yr ago
    • Reported - view

    Honestly this is another tactic or lets say a way to monitor our activity in which Amazon can use to track us for advertisement purposes. The sad thing the cost of this item, should come with open access and not limit us with our private relay. Please fix this or we will spread the word and go to another router base system. Thanks in advance.

      • frozo
      • 1 yr ago
      • Reported - view

      obviouslysilent You are exactly right. There is no other reason not to support it. What are our mesh alternatives and do they allow Private Relay? I’m jumping ship too. 

      • obviouslysilent
      • 1 yr ago
      • Reported - view

      frozo  I’ll give them one month, if no resolution, I’ll try netgear mesh 6.0 and test it. If this doesn’t work I heard Tp link works. 

      • mrthrd
      • 1 yr ago
      • Reported - view

      obviouslysilent looking for another option too that support HomeKit, mesh and private relay. 

      • ak1234567
      • 1 yr ago
      • Reported - view

      This is unfortunate. I've been genuinely impressed with Eero's devices and software—I find their app incredibly easy to use and I love knowing which devices are actively connected to each access point, name/ rename devices, block and pause devices, etc. I've been paying for basic Eero Secure and have been happy with it. But this seems like a transparent money grab to push users to upgrade to Eero Secure+ (which includes VPN functionality), and presumably for ad tracking purposes. Intentionally disabling functionality provided by others as a cash grab is a deal breaker, provided that proves to be the case.

      • Have you tried unplugging it and plugging it back in?
      • dsimerly
      • 1 yr ago
      • Reported - view

      frozo a gent in earlier comments above has already tested TP Link, and found that it not only allows iCloud Relay, but is also faster than eero as a mesh network. It's what I'll be looking at if eero doesn't fix this without forcing us to subscribe to "Secure."

      • mrthrd
      • 1 yr ago
      • Reported - view

      Dave I’m using TP Link for our small business and works great. The only reason I opted for eero at home was the HomeKit compatibility. For the same reason as you I’m looking for an alternative that support mesh and HomeKit. 

    • obviouslysilent
    • 1 yr ago
    • Reported - view

    Check this out to see if it fixes the issue. Make sure device is up to date. Go to your Wi-Fi on device, find your network, open it up, make sure private wi if is on. Then check limit IP address tracking, make sure it is on. If it is already on, toggle it on and off and back on.  After that go and check your private relay is now working on your network. Mine has been working for about 8 hrs and will monitor to see if it is resolved. Hope it helps. Sad thing support offer 0 support on this…

    • matthewearle
    • 1 yr ago
    • Reported - view

    UPDATE: I got Private Relay working on my network!

    The eero technical support rep gave @pdxcubfan the answer in an unhelpful way. I was poking around in Settings > Network settings > DNS in the eero app and saw "To change your DNS settings, you must disable all eero Secure+ features" — eero needs to control DNS in order to do what it does. But Private Relay does its own thing with DNS as described in the iCloud Private Relay Overview.

    I had already turned off the Secure+ features listed on the Secure+ screen (Advanced Security, Ad Blocking), per the suggestion, but I had to remove the Private Relay domains from the Allowed list (Block & allow sites, at the bottom of the Secure+ settings) before Secure+ was disabled and the DNS settings became accessible.

    In other words, if any of the traffic filtering features are enabled in the Secure+ settings, Private Relay will not work. (You don't have to cancel account integrations with 1Password, Encrypt.me, and Malwarebytes.)

    I'd like to use Secure+ features, but Private Relay is the priority, as others have noted. I have ad/tracking blocking (1Blocker) and Malwarebytes running on my Apple devices already, so I feel pretty well protected. It would be nice to get more clarity into why they're incompatible though — it seems like whitelisting the domains should've done the trick. If it's truly impossible for Private Relay and Secure+ to work together, a device-level inclusion/exclusion for Secure+ processing would allow them to at least coexist. My non-Apple devices could sure use some extra protection!

Content aside

  • 4 Likes
  • 8 mths agoLast active
  • 68Replies
  • 5456Views
  • 40 Following