1

Eero network no longer compatible with Private Relay

This morning my iPad popped up a notification that Private Relay does not work with my Eero network. 

I've been on iPadOS 15 the past week. I have Eero secure enabled. And everything has been working fine since until today it forced me to turn off private relay. 

Is Apple's new feature not compatible with Eero? And any fixes coming if so? 

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I had the exact same message this morning.  But for me, I I've wanted it off at home, and actually blocked it with pihole.  I just want to be able to use while away from home. 

    Like
    • Hello rminear68 chump247 premier_blue ,

      You can turn off Private Relay for just your eero network by going into your iPad or iPhone in the following area: open the Settings app > select Apple ID (at the top above Airplane Mode) > select iCloud > select Private Relay > toggle off the “Private Relay” switch

      On a MAC you can disable Private Relay for your eero network by doing the following: pen System Preferences > click Network, select the eero network name (must be connected), uncheck the "Use iCloud Private Relay" box

      Alternatively you can disable Private Relay for every device on your network by adding two links to the block list.

      mask.icloud.com

      mask-h2.icloud.com

      Like
Like1 Follow
  • 1 Likes
  • 12 days agoLast active
  • 2Replies
  • 55Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com