0

Beacon Speeds third of Eero Pro?

Just installed an Eero pro and two beacons. When holding my phone next to the pro I get about 350Mbps. However when I do the same with either beacon, I get about 90Mbps.

The beacons all show full signal strength to each other. 

The speeds drop as I move further away from the beacons, to the point that my old non mesh wifi range extender was getting better results.   


Is this expected behavior? I expected similar speeds from all points on a mesh network. 

 

Thanks for any help or insight. 

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Have you verified your phone is actually connected to the Beacon you’re trying to test from? It’s up to your phone to choose which AP to connect to, so it’s possible it’s still hanging on to the eero Pro.

    Also, it can take a couple days for the mesh to fully optimize, so since you just set it up you may want to give it until Monday or so to see if things improve. 

    Like
  • Yes, I’ve made sure the phone is connected to the beacon I’m testing (it seems to do a nice job of finding the correct part of the mesh). 
     

    I’ll give it a couple days, but should I expect speeds to be similar at different points on the mesh?

     

    Thanks!

    Like
Like Follow
  • 4 wk agoLast active
  • 2Replies
  • 11Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com