Setup app stuck on “Looking for eero devices” page

I bought a 3 pack eero 2nd gen system at Best Buy.

During setup the app gets stuck on the “Looking for eero devices” page. 

The light on the eero blinks blue then goes solid blue so I know it is paired.

I tried restarting both the eero and the app.

I also tried a different eero and I still get suck on that page.

I also tried using an iPad instead of my phone - same results.

Any tips as to what I am doing wrong?



1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I was able to solve it.  I plugged the eero into my old router and then it set up.

    Later when I connected it back to my cable modem I was able to complete the setup.

    The next challenge came when I connected the first eero back directly to my cable modem.  I got a message from my ISP asking me to enter in my username and password before they would enable my broadband connect.  This is likely the fundamental problem with my initial setup where I did have eero connected directly to the cable modem.

    Based on my experience I would recommend plugging eero into your existing router for setup, and only once that is complete then move it directly to your cable modem.


Like Follow
  • 5 days agoLast active
  • 1Replies
  • 4Views
  • 1 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support