0

Changing Gateway IP address and range

Hi, I just got an Eero Pro and am trying to figure out how to change my gateway IP address for my network to 192.168.0.1 as opposed to the default 192.168.4.1 
As I want my IP addresses to be 192.168.0.x as opposed to 192.168.4.x

31replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hello bickybhogal ,

    You can change this in the eero app. Settings -> Network Settings -> DHCP & NAT -> Manual IP

    Like 1
  • In case this helps anyone else out, I just got off the phone With Eero C.S. - who was great BTW - there is a couple of caveats in setting this up.

     

    Once you select the the Manual IP area you are presented with 3 options for your network IP:

    • 192.168.0.0
    • 10.0.0.0
    • 172.16.0.0

    Generally the Subnet mask is going to be 255.255.255.0.

     

    Now the starting IP that I wanted to use was 192.168.1.1 simply because I already had multiple devices with static IP addresses. However when trying to enter that as an option things were not working. App stated it needed to reboot the router, but nothing was happening.

    The trick was to set the starting IP to 192.168.1.0, and apparently you cannot go over 254 for the ending IP. for me, the final result was as follows:

    1. Starting IP: 192.168.1.0
    2. Subnet mask: 255.255.255.0
    3. Starting IP: 192.168.1.110
    4. Ending IP: 192.168.1.254

    which did the trick.

    Like 1
      • helispot
      • helispot
      • 4 mths ago
      • Reported - view

      AgentEccks  This saved me!  Before this, I'd save the settings (wrongly putting 192.168.1.1 in the gateway IP box), save it, said it would reboot the router, but kept defaulting back to Automatic.  Changed 192.168.1.1 to 192.168.1.0 (don't ask me why) and it worked, including...   Manual IP page coming up as expected the next time in the app config, and, curiously, the main app page now shows the eero IP of being 192.168.1.1, even though I had to enter in 192.168.1.0 to get it to "take."  Who knows.  Thanks for this post.  Gold.  Would have been dead without it (or had my network on 192.168.4.1, which I didn't want).

      Like
      • AgentEccks
      • AgentEccks
      • 3 mths ago
      • 1
      • Reported - view

      helispot  I'm glad it helped!  😉

      Like 1
      • jstevans
      • jstevans
      • 3 mths ago
      • 1
      • Reported - view

      AgentEccks I am really struggling with the changes that I believe adding my Eero has caused (not necessarily bad, just disruptive until I figure it all out).  The devices on my network used to be able to talk to each other, they saw each other.  Now they do not fully do so.  I believe the reason is that some devices now have IPs 192.168.1.XX (which is the way they have always been) while others, in no pattern I can discern, have 192.168.4.XX.  As a result, some devices can see each other, others cannot.

      Your posting "Changing Gateway IP address and range" was helpful as was the rest of that thread.

      I am trying to force the Eero to have 192.168.1.XX IP addresses.  I began following your input and became confused.

      Perhaps your entry that reads:

      Starting IP: 192.168.1.0
      Subnet mask: 255.255.255.0
      Starting IP: 192.168.1.110
      Ending IP: 192.168.1.254

       

      Was intended to read:

      Subnet IP: 192.168.1.0 ("Subnet" rather than "Starting", this is the order in which these items appear on the UI on my phone as shown in the embarrassingly large screen shot below)
      Subnet mask: 255.255.255.0
      Starting IP: 192.168.1.110
      Ending IP: 192.168.1.254

      Jay

      Like 1
      • gunn
      • gunn
      • 3 mths ago
      • Reported - view

      jstevans Thank you for this! 

      I too was very confused by the double "Staring" IP address settings that were listed in a couple of the posts (the original and one reply). THANK YOU for clearing that up for me!

      These are the settings that worked for me. After rebooting my Eero, it had a Gateway IP of 192.168.1.1 and all of my WiFi devices began getting addresses after 192.168.1.110.

      Subnet IP: 192.168.1.0
      Subnet mask: 255.255.255.0
      Starting IP: 192.168.1.110
      Ending IP: 192.168.1.254

      Thanks again!

      Tom

      Like
      • AgentEccks
      • AgentEccks
      • 3 mths ago
      • Reported - view

      jstevans Hello...

      My post is exactly what I intended. By your own image, you first need to select your network prefix. Obviously you want in the 192.168.0.0 network:

       

      Then you will need to enter the Sub IP range to match (192.168.1.0) you cannot set it to 192.168.1.1 - it will not work. It needs to be the 192.168.1.0 (at least in this example) obviously it would be different if you selected differently above:

       

      The starting IP and Ending IP can be whatever suits you. Those were my selections since I already have LOT of static IP's below the 192.168.1.110 (it still hands out empty slots below there even though I do not want it to)

      I believe when I did the automated setup (wizard), it actually setup to the 192.168.4.X network which required me to redo everything and ALL my devices because they had already connected (power down the devices, update the static IP in the App then power up the devices once again to get correct IP's).

      Once you reboot after applying the setting above, you should see this:

       

      My second eero is set with a static IP of 192.168.1.2 making sure that all devices are in the same network and guests are on their own segment as well, keeping them out of the home network. If I had another eero, it would be set to 192.168.1.3.

       

      I hope that helps clear things up.

      Like
      • AgentEccks
      • AgentEccks
      • 3 mths ago
      • Reported - view

      jstevans Also FYI...

      Ending IP can not go past the 254 limit. You can set it less than that, but not more, that won't work either.

      Like
      • jstevans
      • jstevans
      • 3 mths ago
      • Reported - view

      AgentEccks Thank you for such a thorough response.  I will now dive in and get me network back in order.  Thank you again.

      To the Eero team - this situation where installing the Eero changes the 192.168.1.xx used in most residential installations to 192.168.4.xx should be made very clear in the installation process.  Those of us with any fixed IP addresses get burned by it and the "fix" of moving to manual DCHP and forcing a 192.168.1.xx mode is not at all evident.

      In fact, I would strongly suggest adding an explicit option during the setup process to use 192.168.1.xx with an explanation as to why. I know the "4" can identify the IPV4 addresses as the "6" ca identify the IPV6 ones but really, is that worth the disruption caused by surprising us?

      Thanks to the community!

      Jay

      Like
      • jstevans
      • jstevans
      • 3 mths ago
      • Reported - view

      AgentEccks One more question - just checking to be sure this is the process I should use to get back to a 192.168.1.xx network.

      1. Open Eero -> Settings -> Network settings -> DHCP & NAT
      2. Change the DHCP & NAT from Automatic to Manual IP
      3. Leave IP Prefix unchanged as 192.168.0.0
      4. Edit Subnet IP to be: 192.168.1.0
      5. Edit subnet mask to be: 255.255.255.0
      6. Edit Starting IP to 192.168.1.110 (or as low as desired)
      7. Edit Ending IP to 192.168.1.254 (or lower if needed)
      8. Bridge remains off (unselected)
      9. Save all these using the button in the upper right corner
      10. Approve the reboot and wait for the Eero UI to show my three Eeros are connected again
      11. Reboot ALL my devices so the new Eero settings above force each device into a 192.168.1.xx IP address

      How'd I do?  My family might fire me from my IT job if I leave them without Wi-Fi again, gotta get this right.

      Thank you again for your time and assistance.

      Jay

      Like
      • AgentEccks
      • AgentEccks
      • 3 mths ago
      • Reported - view

      jstevans Sounds about right.

      Keep in mind that if there is something you want on a specific IP, you will need to add that device MAC ID and IP reservation prior to rebooting the device.

      I had a spreadsheet of all my connected devices and shut everything down (luckily my wife was out of town at the time I did all this), entered each device into the app then went one device at a time to make sure everything connected where I wanted it.

      I have blocks of IP's set for categories, i.e. Routers 192.168.1.1 / 192.168.1.2, etc. Printers, Entertainment equipment, devices, computers, printers, security cameras, VoIP devices, appliances, smart devices etc.... That is why I wanted to start handing out IP's at the x.x.x.110 threshold.

      Like
      • jstevans
      • jstevans
      • 3 mths ago
      • Reported - view

      AgentEccks You are a very organized soul!  Admirable.

      You say that if I "if there is something you want on a specific IP" then I "will need to add that device MAC ID and IP reservation prior to rebooting the device." 

      I think that if the device, such as a desktop/laptop/printer/etc. can be set to a specific IP within itself then I can just set it's IP and Im done - true? 

      I think your comment related to less flexible devices, like a TV, which I cannot set internally to a fixed IP?  For that dumb-ish device I'd do what you mentioned, power down the device, load the device's MAC and my desired IP for it into the Eero, then turn the device back on.  Did I get it right?

      As an aside - I just got the "Eccks" = X.  Slow some days.  Very slow some days.

      Jay

      Like
      • AgentEccks
      • AgentEccks
      • 3 mths ago
      • Reported - view

      jstevans LOL...

      Yes, that is correct. But since I still have issues with the router handing out empty IP spaces below the x.x.x.110 threshold, I have concerns that it would always work, but my printer does seems to work that way.

      Like
      • jstevans
      • jstevans
      • 3 mths ago
      • Reported - view

      AgentEccks After a long pause while addressing other tasks I finally got back to getting back to a 192.168.1.xx network.  I followed the steps above and things mostly worked.  Once I put the Eero into Bridge Mode to resolve the conflict between it and my Verizon FiOS router (search this site for FiOS for more info, annoying that this wasn't mentioned in the Eero setup - or that I didn't see it) everything was perfect!

      I'll eventually figure out the FiOS router issue and get off Bridge Mode but right now I'm happy.  Special thanks to AgentEccks.

      Like
      • AgentEccks
      • AgentEccks
      • 3 mths ago
      • Reported - view

      jstevans I had FiOS when I lived in California, but I only had if for Internet so I didn't have any set top boxes. I'm guessing you are keeping the FiOS router for the Set top boxes??? If so, I would try putting the FiOS router into bride mode and let the eero routers handle the rest.

      Anytime you have two routers in the mix, you can expect some issues if they are both configured using the same network IP's and are both trying to hand out IP's to devices trying to connect to the network.

      I'm glad that you were able to get things updated and working.

      Like
  • UPDATE:

    As in my settings above, where the router shouldn't be handing out any new IP addresses below 192.168.1.110, it seems that it is not following this setup. My Wife was out of town when this was setup, and yet when she returned, her Laptop was given an IP address of 192.168.1.18???????

    Since there is no Browser GUI, or the fact that there is not any Release/Renew feature, I spent the better part of the day unplugging everything from the network, assigning between 30-40 static IP addresses (below the 192.168.1.110 range), then plugging each device back in one-by-one to make sure that each one connected with the proper info.

    Also, because I was roaming all over the house, I didn't have much of a change to plug my phone into power, so by the time all this was completed, my phone was nearly dead.

    Clearly, there is room for improvement regarding the interfaces for these devices. However, so far (not even a whole day with these setup) the consistency and speed of the connections are far better than my older equipment.

    Just one day in, I would love to see an option for selecting your network template during the setup, rather than it choosing for you then having to go back and change/update everything after the fact. I would really love to see a Release/Renew feature to make setup easier when assigning Static IP address, I would love to see enforcement of the Manual DHCP & NAT settings, and obviously I would really love to see a Web GUI rather than being forced to use the App. There are benefits to both, but I believe setup would be more efficient via a Web GUI.

    Like
  • To change the router's IP address, log in to the router as an administrator. From the control panel, change the IP address to whatever you like. However, this IP address is usually changed when there's a problem with it. The default IP address should suffice for most situations.

    Like
      • AgentEccks
      • AgentEccks
      • 3 mths ago
      • Reported - view

      PeeplesP1   RE "log in to the router as an administrator"

      I am not sure if this is possible with a standard purchase, but my 2 eero routers were provided by my ISP so trying to go to the base IP address of 192.168.1.1 results in the following:

      • "eero secure

        Whoopsie
        Your device is not allowed to access this site.

        We hate to be the bearers of bad news, but this site has been blocked. If you believe that this site was categorized incorrectly, you can report it as inaccurate."

      I assumed that this message was due to the fact that no Web GUI was available, but maybe it  is locked by my ISP???

      Like
      • gunn
      • gunn
      • 3 mths ago
      • Reported - view

      AgentEccks You are most likely seeing this because you tried to go to the IP address of your eero device using a web browser. They don't have a Web GUI as you guessed, so the ONLY way to configure the eero devices is through their Android or iOS app, unfortunately. 

      I really debated purchasing the eero system due to this limitation. And as I sat there configuring it on my little phone, reserving numerous IP addresses and entering MAC addresses, all the while my phone battery began to get dangerously low, I really hated myself for choosing it. I can't understand why they don't give us a Web GUI so I can use my 28" monitor, right alongside my Excel spreadsheet of IP addresses to configure it, instead of my little phone...arghhh.

      Like
  • I just want know CAN gateway IP be changed? How do I change my router's IP range?

    Like
  • @Shaw4635 - The answer to your question is yes. However, it will take a bit of configuration on  your part. All the information you will need to make the changes are here in this post.

    Good luck.  🙂

    Like
  • Have a question that semi ties into this thread, I think I know the answer, but going to ask anyhow in hopes that there is a work around.

    We got this eero 6 thing from our ISP, they kind of insisted upon it, but gave it to us for free, so trying to work with it, ISP claims its only thing that will work on their fiber gigabit system.  Previous system was traditional modem to router setup, we have a bunch of static IP address PoE cameras that are insanely hard to change the IP address on.   None of these camera's are those silly RING, Nest or UFFY type, these are all HIKVision & Dahua running through Blue Iris.

    The simplest solution for us would be to change the LAN IP address the eero is dishing out to match what our camera's are all set to, everything else on network is DHCP, its just the camera's that need static.  

    AgentEccks posted above:

    Once you select the the Manual IP area you are presented with 3 options for your network IP:

    • 192.168.0.0
    • 10.0.0.0
    • 172.16.0.0

    Was able to find this screen, however am I to understand those are the only 3 options for IP address changes?  None of those work for our system, how do I specify the IP address we need.  I just lol @192.168.0.0 that is just asking every hacker on the planet to hack or hijack your network.  

    gunn thanks for posting that these clowns don't have a web GUI, am trying to do this remotely over the phone explain it to my son, we kept typing in IP address and router interface would not pull up, was pulling my hair out trying to figure it out, now I know why we couldn't.

    Like
  • I am slight confused by the above. The GUI doesn’t seem to have somewhere to enter the gateway address you want. Does it assume .1 is the router of the subnet you choose?

    Like
  • Dego said:
    192.168.0.0
    10.0.0.0
    172.16.0.0

     Simply select the IP network range that you prefer to use. On the following screens, anywhere there is a '0' are the numbers that you enter for your preferences.

    i.e.:  192.168.1.1, 192.168.2.1, etc.

    Like 1
      • bazcurtis
      • bazcurtis
      • 12 days ago
      • Reported - view

      AgentEccks That is perfect thanks

      Like
      • bazcurtis
      • bazcurtis
      • 12 days ago
      • Reported - view

      AgentEccks Sorry one more question. What is the lease time off these DCHP pools?

      Like
      • AgentEccks
      • AgentEccks
      • 12 days ago
      • Reported - view

      bazcurtis You can just use the defaults unless you have specific requirements.
      I have LOTS of static IP's so the IP doesn't change and I know what they are.
      As the leases expire, it just means that another device could be assigned a different IP address.

      Like
      • bazcurtis
      • bazcurtis
      • 12 days ago
      • Reported - view

      AgentEccks My too. All my static IPs are down below 50. My old range was 130-240. I checked and I had 42 devices using DHCP. I have shortened the range to 190-240. Once I see all the device up in that range, I will swap the EERO over to 100-189 and take it from there. Unfortunately my old DHCP TTL was set to 24 hours. I have also shortened that to an hour. I just wonder what EERO use.

      Like
  • Off-hand, I'm not sure. I believe I just left the defaults, turned everything off, and started one-by-one setting up the static IP's. Took pretty much all day.

    Like
Like Follow
  • 10 days agoLast active
  • 31Replies
  • 1977Views
  • 10 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com