Network attached storage keeps disappearing from local area network

I have 4 Eero Pro 6's in my network and a QNAP TS-251 network attached storage device connected to my Eero gateway over ethernet.

The device always remains connected to the internet, but the mounted Apple Filing Protocol (AFP) drive constantly disappears from my local area network.

I've tried a variety of things to prevent this from happening. I tried connecting the NAS to my network over wifi instead of hardwired into my gateway over ethernet, this didn't fix anything. I've also tried assigning the NAS a static IP address and then added a IP reservation from the Eero mobile app, that also didn't change anything.

The NAS has IPv4 and IPv6 enabled. 

When the local AFP drive disappears, the GUI login for the NAS also become inaccessible. Normally I can login to the device directly from its IP address, However when the drive disappears, that IP address becomes inaccessible even though the NAS is still connected to the internet.

The NAS also hosts my Plex server. When that IP address becomes inaccessible, I can still stream media hosted on the NAS via Plex, but even when I'm connected to my home network, Plex treats the traffic as if it were coming from an outside network and transcodes the media rather than streaming it at full resolution.

I never had any issues with this device until I switched from an Asus AI Mesh home network to Eero.

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I've also added in port forwarding on the Eero IP reservation for the NAS's web UI (8082) and for the Apple Filing Protocol drive (548) without any improvement.

  • I’d recommend stopping using the AFP protocol since it was deprecated 10 years ago, and instead try using SMB. That could very well be your issue.

      • patdugan
      • patdugan
      • 1 mth ago
      • Reported - view

      cMoo92 both SMB and AFP are enabled. Both drop from the network at the same time.

  • I opened the following ports to correspond with the NAS web UI, the AFP and SMB services, as well as the local PLEX service.


  • I was still having intermittent issues with the NAS disappearing from my local area network even after statically assigning the IP address and manually opening the ports I needed.

    I found that entirely disabling QuFirewall on the NAS actually improved reliability further. I'm not sure specifically what firewall rules on the device may have been impacting local visibility.

Like Follow
  • 1 mth agoLast active
  • 5Replies
  • 22Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support