1

Plex remotes access using EERO

So I just upgraded my old apple router to EERO PRO. And the one thing I am having trouble with is I can not access my plex media remotely? I have read a few things saying that EERO can not do this unless it is set in bridge mode? if this is true this would totally negate the reason to have such a nice router setup. Is there any one that is having success with plex remote access and using EERO routers?

19replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • You need to set up the appropriate port forwards.

    Like
  • under the plex server it tells me to Manually specify public port and i click that box for the port it suggest. then i go into the EERO app and enable port forwarding under my mac mini (my plex serve is stored) and do the port it tells me to do but still can not reach the serves remotely. I am really hoping to get this working so I can recommend these routers to my family and friends  

    Like
    • Seven7527 I use Plex on my eero network and you don’t need to manually set a port in Plex or port forwarding in the eero app. Just enable remote access in Plex and Plex takes care of everything.

      Having eero in bridge mode would make this not work.

      Like
  • Ok so I went deleted the port forwarding rule. And restarted the Mac mini and the router and still can not connect remotely? Wish I could figure this out 

    Like
    • Seven7527 you probably need to turn on UPnP in your eero network settings. 

      eero app > Network Settings > Advanced Settings

      Like
  • Just checked and yes it was already enabled. So no that’s not the answer 

    Like
    • Seven7527 that’s really weird. Do you have another router in front of your eero? What I mean is, is your eero plugged into strictly a modem, or is it a modem/router combo?

      Like
  • I have a att U-verse router modem but it’s in bridge mode. It the same router modem I was using with my old Apple airport with no issues.  

    Like
    • Seven7527 AT&T states they don’t let you out your Uverse gateway into bridge mode. Are you actually running it in bridge mode, or are you referring to IP Passthrough mode? If it’s the passthrough option, did you switch the MAC address for that configuration from your Airport MAC address to your eero gateway MAC address?

      https://www.att.com/esupport/article.html#!/smb/KM1188700

      Like
  • Ok yes you are correct. So logged in the modem router and had to go to fire wall status and add my eero to the list of allowed devices. Also set it up (DMZplus mode) - Set the selected computer in DMZplus mode. All inbound traffic, except traffic which has been specifically assigned to another computer using the "Allow individual applications" feature, will automatically be directed to this computer.  After that i restarted the modem and routers and now everything is working great!!! Thanks for your help

    Like 1
      • t0lbert
      • t0lbert
      • 1 yr ago
      • Reported - view

      Seven7527 can you please explain this more?  im in the same boat as you were.  can't get it to work.  have same modem.  messed with the setting on uverse modem. no luck...thanks

      Like
  • I also have same eero + ATT U-verse setup. Port forwarding as in https://support.eero.com/hc/en-us/articles/207908443-How-do-I-configure-port-forwarding- fixed my plex issue.

    I did port fowarding for my mac where plex is installed

    Like
  • I have the same issue but my setup is eero+Verizon Fios router. Do people have any suggestion if the setup above will work. i did what is listed here https://support.eero.com/hc/en-us/articles/207908443-How-do-I-configure-port-forwarding- but no luck.

    Like
  • try disabling ipv6 in plex settings (Network), eero and fios router. restart everything. Not sure if it will work in your case. sometime ipv6 causes issue

    Like
  • I have an Xfinity Wifi Router (xFi Advanced Gateway) in Bridge mode. After that I have the Eeros. I seem to have been able to connect to Plex remotely after restarting Plex but it does not "stick". I am trying to set it up so it works permanently. I seem to have no luck. I have set up a manual port in the Eero and with Plex. Plex is able to connect momentarily (1-2sec) but then something changes and the connection in Plex says "Not available outside your network".

    I wonder if the Xfinity router is the issue? Can it be in "bridge mode" The software in the Xfinity box I clicked said bridge mode.

    If its not that what else should I change and test?

    Like 1
      • aethstoll
      • aethstoll
      • 2 mths ago
      • Reported - view

      atbattson I am having the exact same issue... driving me nuts

      Like
      • atbattson
      • atbattson
      • 2 mths ago
      • Reported - view

      aethstoll I worked it out.
      Only took half a day of focus to work it out. Realised that although I had put our Comcast Wifi/Modem/Router in bridge mode for the eero/Wifi/Router my wife bought, when the Comcast router died a while back and Comcast came and set us up with a new one, the guy did not set it up in Bridge mode so the two routers where fighting each other. That fixed it. Phew

      Like
      • atbattson
      • atbattson
      • 2 mths ago
      • Reported - view

      atbattson I also made sure I disabled ipv6 in plex settings.

      Like
  • has anyone found a fix for Comcast port forwarding i had no issues with plex outside network until i hood up eero. now it doesn't work. I've tried everything no luck. i hope this an be fix would hate to give up such a good system.

    Like
Like1 Follow
  • Status Answered
  • 1 Likes
  • 1 mth agoLast active
  • 19Replies
  • 1350Views
  • 9 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com