44

Egress Hairpinning

I run a couple servers inside my network, mostly relying on a reverse-proxy to accept connections on TCP 443 and proxy the connections to the right internal server. I don't run separate internal v. external DNS. Instead, I have a more typical setup where I define an external DNS server in eero, then the eero includes its address as the DNS server in all DHCP addresses, and forwards the requests.

 

As a result, though, I can't access my server by [subdomain].[domain].com while *inside* my eero network. I have to instead use DNS shortnames. This is annoying for a number of reasons. 

159replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Amazon has the AmpliFi HD on sale: https://goo.gl/2A1Rrz

    Here is the UAP-Pro: https://goo.gl/DFPzVn

    And Google WiFi is on sale too!!!!: https://goo.gl/uji3Yf

    I have not heard the best stuff about the Orbi, though performance wise, it seems to be solid.

    Reply Like
  • One more +1 for this feature.  It is really hard to believe that it isn't supported yet, even though the cheap ass d-links & linksys routers do....

    Reply Like
  • +1. This is a basic feature needed for any router.  Please implement. Thanks!

    Reply Like
  • +1.  Only issue as far as I can tell.  I have 45 day return where I purchased, so going to monitor this thread closely.

    Reply Like
      • usr2284a
      • usr2284a
      • 2 yrs ago
      • Reported - view

      aharrod  this thread is almost a year old.  They have no plans to add it.  It won’t be added in the next 45 days, that’s for sure.

      Reply Like
  • +1!  This seems like a major omission for a router with home automation in it's infancy.  This missing feature is becoming more and more important by the day.  Eero, please add this feature ASAP!

    Reply Like
  • Just came back to say that the wait for hairpinning has become too much for me, and I ended up replacing my eero system with something that cost less and gives me not only hairpinning, DMZ, and QoS, but also gives me better coverage and throughput than eero did. I'll be resetting my eero units and selling them off to someone else who demands far less from their wireless router.

    Reply Like 1
      • Honus
      • Honus
      • 1 yr ago
      • Reported - view

      go_robot_go Love to hear what you ended up going with.

      Reply Like
  • Set up new eeros and was sad to see this is not supported. +1 for this feature please.

    Reply Like
  • Hi everyone —

    First and foremost, I'd like to thank all here for contributing to this topic and sharing your thoughts with us regarding your interest in Hairpin NAT. I'm excited to share that with eeroOS 3.3, Hairpin NAT is now officially supported on eero networks.

    To use Hairpin NAT, all you will need to do is create a port forward. Once done, you will be able to access your devices from both in and out of your network.

    If you are unsure what version your eero network is on, you can check by:

    1. Opening the app.
    2. Tapping the menu button.
    3. Tapping on Network Settings.

    Under the section Network software, you will either see Update available (needs to be updated) or Up-to-date (your network is on 3.3).  

    Again, we greatly appreciate everyone's patience and understanding as we've worked on getting this feature out. As a company, we hold a high standard in any feature we implement, and it requires the necessary vetting to ensure that anything implemented both keeps your network secure and working as expected. 

    If you have any questions, please let us know.

    Reply Like 4
      • Luc
      • Luc
      • 1 yr ago
      • Reported - view

      Jeff C. Is this also supported ports created via UPnP?

      Reply Like
      • Jeff C.
      • eero Community Manager
      • Jeff_C
      • 1 yr ago
      • 2
      • Official response
      • Reported - view

      Luc Hairpin NAT will be enabled on all port forwards both manual and UPnP.

      Reply Like 2
      • Luc
      • Luc
      • 1 yr ago
      • 1
      • Reported - view

      Jeff C. Awesome!

      Reply Like 1
    • Jeff C. how about showing an example of setting up port forwarding for hairpin?

      Reply Like
      • Honus
      • Honus
      • 1 yr ago
      • 1
      • Reported - view

      Jeff C. awesome! Works for me. I didn’t have to do anything special. My existing forwards just worked. 

      Reply Like 1
      • Figg
      • Figg
      • 1 yr ago
      • Reported - view

      Jeff C. Will this work if your modem/gateway's ports are closed?  I cannot port forward my modem/gateway anymore and I am wondering if this will work with my modems ports closed?  Sorry for my lack of knowledge on this topic.

      Reply Like
      • Jeff C.
      • eero Community Manager
      • Jeff_C
      • 1 yr ago
      • Reported - view

      Figg

      It won't. In order to use Hairpin NAT, the port must be open on all port forwards for both the eero and any upstream devices. Is your modem also a router? If so, are you able to disable the routing feature?

      Reply Like
      • Figg
      • Figg
      • 1 yr ago
      • Reported - view

      Jeff C.  I have an xfinity gateway - wifi router and modem all in one. (more importantly, xfinity has all control) Perfect solution for most users, but I like to tinker and tweak things.  I just ordered an Arris modem so now I should be able to make all port forwarding through my eeros once I get my own modem online.  Thank you for your help and valuable information.   

      Reply Like
      • rlopin
      • rlopin
      • 1 yr ago
      • Reported - view

      Jeff C. This works beautifully now. No more setting up two configurations for each network camera. Thank you for listening to the community and implementing this much needed feature!  

      Reply Like
      • GNadezda
      • GNadezda
      • 1 yr ago
      • Reported - view

      Jeff C. --

      I'm using a Frontier Actiontec MI424-WR router, and have my eero acting as my router, or at least I think that's what I'v configured. What I've done is set the eero as the DMZ Host on my router. Would that be similar to disabling the routing feature on the Actiontec? 

      Reply Like
  • 👏🏽👏🏽

    Reply Like 1
  • Is it just me or has this been broken again with the latest software update? It has been working fine for me for months. But a couple nights ago, my eero network updated to 3.12.0 and now I'm getting an error when trying to access from inside my eero network. "Can't establish a secure connection to the server" error. Connections from outside the eero network are fine, it's only a problem with local connections.

     

    This was all working perfectly until the eero software updated. Nothing else has changed.

    Reply Like 1
  • This is definitely not just you. This feature seems almost entirely broken with version 3.12.0. I just emailed eero support about it.

    Reply Like
  • I emailed them as well, but haven't heard back yet.

     

    I think I may have, at least temporarily, fixed it. I deleted my port forwards on the server in question and re-added them, and so far it seems to be better. Not sure if it will fix it permanently, so I'm hoping they register a fix anyway...

    Reply Like
  • Hi! I'm having the same issue right now. After one of the last updates all of the DDNS port forwarding stopped to work. 

     

    I need an urgent solution to this.

    Reply Like
      • txgunlover
      • txgunlover
      • 4 mths ago
      • Reported - view

      juampick They're aware, the .1 was supposed to fix it, but hasn't completely.

      Reply Like
      • juampick
      • juampick
      • 4 mths ago
      • Reported - view

      txgunlover I installed 13.12.1 yesterday and it's still not working. I deleted all my port forwarding and re-add only 1 to test, and no-working. Any estimation? I also added a ticket without response.

      Reply Like
      • txgunlover
      • txgunlover
      • 4 mths ago
      • Reported - view

      juampick Yep, that's why I said it hasn't fixed it.  They're definitely aware though, and ask that you put the tickets in so they can continue to gather data.

      Reply Like
Vote44 Follow
  • Status Implemented
  • 44 Votes
  • 4 mths agoLast active
  • 159Replies
  • 9860Views
  • 64 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com