0

Sonos - SonosNet only available on Wifi6? Anyway to have it broadly available?

Have 2 Eero Pros in my house, the one connected to the modem is hooked up to a Play:5 and that is outputting SonosNet. My other Eero is in the bedroom with wireless backhaul. I removed the saved network credentials from my Sonos app so it is only connecting via SonosNet and am on Ch 11.

After a slightly painful set-up process getting everything all the Sonos devices up and running, my only issue right now is that I can only control my speakers when my device is connected to Wifi 6.

Not sure if this can be fixed but is is super annoying. At least on my Android devices that support Wifi6, the Wifi6 symbol in the notification bar shows a “6” symbol. On Apple devices there is no indicator.

As soon as I go to the kitchen or the bathroom, Eero determines it is too far for Wifi6 and switches to regular wifi (Still 5ghz from checking the Eero app), the Sonosnet speakers can’t be found. Is there anyway to make it available on regular wifi?

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have the same topic on the Sonos forums too. Here is a response I got from a user there, might assist with Eero support over here:

    "That suggests some sort of channel isolation on your router, not allowing data coming in on Wifi6 to be sent back out on older bands. I’d be looking at settings on your router software, to see if there’s something there."

    Like
  • I’d recommend making things simpler and not use SonosNet. Just run all your Sonos speakers on your eero WiFi. I’ve had 8 Sonos devices all running wirelessly just on my normal eero WiFi for years without any issues.

    Like
    • cMoo92 Unfortunately doesn't work for my use case. I have some older devices that only connect to 2.4ghz. The speakers all work when I disable 5ghz for the 10 minutes that eero allows you to, but as soon as that 10 min is over, only my 5ghz speakers are available to control.

      SonosNet is the only way I found to make it reliably work... albeit only on wifi6.

      Like
  • What if you remove the 2nd Eero from your system through the app, then add it back in?

    Like
    • tomciara No luck. Also tried putting all the speakers on static IP and its the same.

      Like
Like Follow
  • 8 mths agoLast active
  • 5Replies
  • 38Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com