0

eero Pro 3 pack over Ethernet

I'm having problems installing my system all over Ethernet. I was able to connect the main gateway eero over Ethernet. However, the remaining two always default to wireless even thought they are plugged in to Ethernet lines.

Please see my setup in the image I posted here.

Here is my setup. The main gateway eero is connected directly to the Xfinity modem / router. From there the gateway eero is connect to a switch which connects to one more switch where the other two ethernet lines are connected.

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have a similar issue. I have connected two eero pros to my ethernet network however only one is connected via ethernet and the other is connected via wireless to the first one. I want the 2nd to be connected via ethernet too. This was the only reason I bought eero over others. What needs to be done?

    Like
  • Managed or unmanaged switches?  You need to use un-managed switches or turn off all management features of the switches.

    Like
  • I was not aware of managed or un-managed switches. This is a first for me. All of this worked in my previous home. We just built a new home and I was simply installing the exact same equipment and ran into this issue. My switches must be un-managed. They are just store bought Netgear ones.

    Like
  • I have fixed the issue at my end and now both routers are showing up as ethernet.
    I connected the first Eero pro (Main) to the modem and then connected an unmanaged switch. Then connected all my ethernet cables to the switch. In my kitchen, I connected the 2nd Eero pro (Kitchen) to the ethernet cable. When going thru the setup wizard, it looked like it wanted to connect wirelessly as it didnt require the ethernet cable, but once the setup was complete then it showed as ethernet connected.
     

    Like
  • That's great. What does it show when you click into each location? Mine also shows like yours. However, on the next screen it says Connection: Wireless

    Like
  • It shows "wired", and I'm getting blazing speeds.

    Like
  • 👍 - I wish I could get mine to do that.

    Like
  • I had to delete my network and redo everything. If you want to go down that path, I would setup eero1 as gateway, then switch1, then eero2. Then see how it behaves at that point. If it works as wired then I would disconnect and try at the end of switch2. Also, are your cables CAT6 or better?
    I think you are correct in your architecture, because I am following your design. I have two more eeros coming at the end of the week and I will update how they connect.

    Like
  • Gm, yes all of my lines are CAT6. I just got a new modem the SB8200 Surfboard to replace my Xfinity one. Once I get that setup I am planning to start over and see what happens. Thanks.

    Like
Like Follow
  • 3 wk agoLast active
  • 9Replies
  • 47Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com