Updating my eero software killed my speed

I just switched from a regular eero to the new eero plus. I upgraded my service with Spectrum and needed the eero plus to take advantage of those higher speeds.  After replacing the eero with the eero plus, I ran a speed test and got 500 down, about what I expected. But then the eero app said I needed to upgrade the software on that device, so I launched that process. 10 minutes later when it's back up I run another speed test. Now I'm getting around 80-100 meg down! What just happened and how do I fix this? FYI I did unplug and restart both the cable modem and the eero plus. No change. This sucks.

3replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi conejo23 Please give support a call so we can check into this situation.  I would also check the cable between the eero and the modem/internet, the speeds you are getting now (<100 mbps) imply a cable issue (which doesn't make sense given the reported sequence of events)

  • thanks for the quick response. I called and we determined that after the software update my laptop was connecting to my beacon instead of the Eero Pro. We upgraded the software on the beacon and I moved it a bit further from my office and all is well. Thanks!

    • conejo23 Excellent!  That is great to hear.  Thank you for the after-action report, we need more of those.

      Like 1
Like Follow
  • 2 mths agoLast active
  • 3Replies
  • 18Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support