Samsung TV Not Finding Default Gateway

Hi, so my Samsung TV is not able to connect to my network with a WIRED connection coming out of a secondary EERO.  This is when I use the TV's "Auto" setting to detect IP, Gateway and Submet mask.  However, if I manually set these, it is able to connect.  I could just leave it to the manual setting, but am curious as to why it may not be working, when everything else seems to be working.  Also noteworthy, the same TV has no issue connecting

My setup is a little complex:

ATT U-Verse Residential Gateway DMZ Mode to->Netgear R6300 Router (DHCP)->Main EERO (Bridge Mode to Router)->Cisco 24 port Gigabit Switch->EERO 2->Samsung TV

So, a totally hard wired connection to the TV, albeit through several devices.  BTW, the TV's able to connect wirelessly to my EERO network without any issues.

In case you're wondering, really didn't want to have the Netgear Router but I required some port forwarding that the EERO wasn't able to support, so I fell back to my Netgear Router to do the job.  

Questions:  

Any idea why the TV's not able to automatically figure out the gateway server on ?

When the EERO network is put in bridge mode, isn't any device that's connected to it get automatically routed to the upstream device the EERO is bridged to?  In my case, that's the Netgear Router, which is providing the DHCP service on my network.

For EEROs that are NOT the main EERO, doesn't anything that gets connected through them (either wired or wirelessly) get routed to the DHCP server on the network?  There's no option to specify the DHCP server for each EERO - is that true?

Thanks in advance for all your responses.

10replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Interesting update.  For kicks, I made a minor change to my network setup, which seems to have solved the issue.  Here's what worked for me:

     

    ATT U-Verse Residential Gateway DMZ Mode to->Netgear R6300 Router (DHCP)->

    ->Main EERO (Bridge Mode to Router)

    ->Cisco 24 port Gigabit Switch->EERO 2->Samsung TV

    To be clear, where as before everything only my main EERO was connected to my Netgear Router, now, I have 2 connections to my Netgear Router:  my main EERO, and my Cisco switch.

    I'm not sure what the implications of this will be, or what other issues may arise, but at least for now, this issue is resolved.  The Samsung TV, using auto mode was able to automatically obtain an IP and identify the gateway and dns servers.

    Reply Like
  • Realized I didn't finish the last sentence in the first paragraph of my original post.  Here it is:

     

    Also noteworthy, the same TV has no issue connecting wirelessly.

    Reply Like
  • Hi  socaluser —

    Thanks for writing in and welcome to the eero community!

    I am sorry to hear the issue you are experiencing with your TV on your eero network. In order for our team to investigate what is going on, we recommend contacting eero support. 

    To get started, please feel free to give us a call at 1-877-659-2347 or email us at support@eero.com.

    Thanks again, we hope to have this resolved for you shortly.

    Reply Like
  • Thanks Jeff.  Sure I'll send them an e-mail and reference my post.

    Reply Like
  • @socaluser welcome!

    Is it repeatable? Are you rebooting the primary eero between these topology changes?

    Reply Like 1
  • Thanks for the warm welcome FuzzyG !

    And what a great suggestion.  I put my original topology back together (which wasn't working) and rebooted my main EERO, and the secondary one.  Voila - it worked!

    It only raises one new question:  is there any way to re-boot through the app?  I pulled the physical plug after not being able to restart it any other way.

    Reply Like 1
  • Not yet. Head over to the feedback section if you feel like suggesting anything. 

    That being said you shouldn't have to reboot the eero that often (or at all) . It has services that are running that detect errors and attempts correcting any that are found. This may escape detection by the services as these were topology changes and the eero learn the paths of least resistance. When you change the physical layout without the reboot it may cause problems as these paths may no longer exist. 

    Reply Like 1
  • Great call there, FuzzyG !

    Glad everything is working for you now, socaluser  — let us know if you have any other questions. And as mentioned, head on over to the feedback section if you have any ideas you'd like to share :)

    Reply Like
  • Thanks FuzzyG and Jeff C. Will head over to the other section and propose the reboot change.

    Reply Like
  • I had the same issue with my Samsung TV, but I solved it by changing the DNS to Google DNS in the eero network settings.

    Reply Like 1
reply to topic
Like1 Follow
  • Status Answered
  • 1 Liked by
  • 11 mths agoLast active
  • 10Replies
  • 1249Views
  • 4 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com


Latest from the eero blog

eero, plus peace of mind

Learn more about eero Plus and how our security suite helps to keep both your devices and everyone in your home safe while online.