1

EERO compatibility with smart-plug devices?

Hi - I just installed my EERO system.   The iHome SmartPlugs I have (2) don't seem to be able to connect to this network.   Does anyone have recommendations for compatible smart-plug devices?  Thx!

34replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi, jc517b – 

    Thanks for taking the time to reach out, and welcome to the eero Community forum! I'm sorry to hear you're having some trouble with that automation equipment, but I'm not aware of any compatibility issues we have with iHome plugs. If you haven't yet, I strongly encourage you to give our support team a call at 877-659-2347 or shoot us an email at support@eero.com so we can dig a little deeper with you and get to the bottom of this.

    We appreciate you bringing this to our attention, and we look forward to hearing from you further so we can reach a resolution. Thanks again, and have a great day!

    Drew, eero Community Team

    Reply Like
  • Hey dude my iHome Smartplugs don’t work either. Did you find a solution? Please share if you did. I really really need this to work.

    Reply Like
      • jc517b
      • jc517b
      • 2 yrs ago
      • Reported - view

      Soloman Yes - I did get them to work.   The fix involved doing a hard-reset on the plugs:

      Make sure that you have the 8-digit code from the bottom of the plug written down or that you can easily see that code.

      1. Hold down the power button. The light will flash green, flash red and green, go out and then flash green again. Release your finger.
      2. Go to the settings on your phone and tap on WiFi. Please make sure your phone is connected to your home 2.4 WiFi network. You should see the iHome Smart Plug in the WiFi “Set Up New Device”. Tap on the plug and follow the instructions. Once WiFi says it's connected to the network, tap DONE.
      3. Next you will go into the iHome Control app and connect the plug to the Control App by clicking on the devices tab on the bottom of the page and add device.  Follow the app to connect your plug. 
      4. Once you get the plug connected tap on the information (i) to the right and it will say edit.  Then scroll to firmware to check for update.  It will tell you if the plug needs an update.

      The key was Step 2:  If I did that in the phone WIFI settings - then the iHome app could successfully complete the configuration.

      Reply Like
      • Soloman
      • Soloman
      • 2 yrs ago
      • 1
      • Reported - view

      jc517b  sorry kind of an idiot but I have eero Pro. Sooooo. I have one single wireless network and my device automatically picks the network.  How do  you choose 2.4?? Please help. Thank you also

      Reply Like 1
      • jc517b
      • jc517b
      • 2 yrs ago
      • Reported - view

      Soloman Shouldn't make a difference - in your iPhone's WIFI settings - just select your EERO network - whatever it's named ("MyNetwork") - then follow Step 2-4.  I believe all EERO networks broadcast at both 2.4 and 5.0.  Now if you're using an Android device, I'm not going to be able to help out there - you'll need to contact iHome's support for those instructions.

      Reply Like
      • Soloman
      • Soloman
      • 2 yrs ago
      • 1
      • Reported - view

      jc517b I am using an iPhone. My iPhone is always connected 5? How do I ever get connected to 2.4?   Plus my iHome plug shows up in the eero connected devices, I just can’t seem to complete setup in iHome app. I think it’s the 2.4/5 Business. How do you get your iPhone to pick.

      Reply Like 1
      • jc517b
      • jc517b
      • 2 yrs ago
      • Reported - view

      Soloman - sorry, I'm not a WIFI expert.   I just select my WIFI network "network name" - EERO broadcasts at all frequencies.  I don't see anything on my wifi page that explicitly says "5 GHz".   

      Follow step 1 to reset your plug back to defaults.   Make sure if flashes red, turns completely off, and then flashes green.

       

      Then on your iphone, go to Settings > WIFI - and make sure you're connected to your EERO network.   While your plug is plugged in - you should see "Set Up New Device" on this wifi screen.   Follow the instructions in step 2 to connect your plug to your network.   If that doesn't work - I think you'll just have to contact iHome support for further assistance.

      Reply Like
  • I have the same issue. How do I make eero automatically assign my iPhone to the 2.4 ghz signal so that it will work with iHone?

    Reply Like 2
  • Someone at eero:

    We REALLY need to know how to connect our phone to the 2.4GHz to complete the pairing setup that is required for certain HomeKit devices. I know for a fact, that if your phone is on the 5Ghz, the pairing will fail. If you go on both iDevices and iHome web sites respectively: 

    Ref 1) "iDevices products require a 2.4 GHz home Wi-Fi® network." 
    Ref 2) iHome: "If you have a Dual Band Router make sure your device (iPhone/iPad) is connected to a 2.4 GHz, Wi-Fi Network." 

    Your answer will greatly influence my decision in buying your router.
    Thank you

    Johnny

    Reply Like 1
    • Thanks for reaching out johnnygoodface , and welcome to the Community! While there's not a way to actively "force" a device to connect to one frequency or the other, please rest assured that we're actively working on some options that might make setup for devices like these easier in the future. 

      For the time being, if a device manufacturer requires the 2.4GHz frequency, then there are a handful of workarounds that can make setup easier. The most straightforward (although admittedly low-tech) is simply to power down any extra eeros and physically move further away from the primary unit – this will help your phone connect on 2.4GHz so that you can proceed with iDevice setup. 

      Past that, for any other assistance you need, we'll always be happy to help out directly, so giving us a call at 877-659-2347 is the first thing I recommend if you ever have any immediate questions or concerns with the product. Thanks again for joining us here, and we look forward to hearing any other thoughts and feedback you have!

      Kindly,
      Drew, eero Community Team

      Reply Like
  • I’m having the same issue.  The cable company insists that it is the device but all my smart devices won’t connect.  Please help. 

    Reply Like
    • Thanks for posting Wincelee , and a very warm welcome to the Community! If you're having a variety of devices having trouble connecting to the network, then it's more likely that you're seeing an issue unrelated to frequency. We'd definitely like to look into this with you, so please give us a call at 877-659-2347 so we can take a look at the network and offer you some guidance!

      Kindly,
      Drew, eero Community Team

      Reply Like
  • I am having similar problems.  I cannot get any 2.4ghz devices to connect to eero.  I have set up my old router with the exact same SSID and password, set up the WiFi device on that router, switched back to eero which also has same exact SSID and password to no avail.  The 2.4ghz devices won’t connect to the router.  I have hard reset all the devices and walked half a block from my home with my iPhone to try and force a connection to the 2.4ghz channel with my WiFi device plugged in on the front porch so I can stay connected....still nothing.  It seems that without the option to disable the 5ghz radio,  it’s impossible to set up any peripheral devices that only have a 2.4ghz radio.  This is a big deal considering that I am a Purchasing manager for a national builder who just made Eero mesh networks standard in all our homes.  I suspect we will be flooded with warranty calls!

    Reply Like 2
    • Thanks so much for bringing these concerns to our attention mstephens77 and sorry to hear about the frustration. I'd like to stress that the eero has no problem authenticating and connecting devices that are 2.4GHz-only, and that 5GHz radio broadcasting simultaneously doesn't prevent these devices from connecting in any way; most of the issues we see in this field have to do with associated mobile apps for these devices that require the phone running the app to also be on 2.4GHz in order to configure the respective device. For 2.4GHz-only devices that are able to be configured manually by interacting directly with the device interface – for instance, using a wireless printer's display screen to configure WiFi – there should be no issue whatsoever. 

      For the devices you're having trouble with, I definitely encourage you to check and see whether they can be manually configured without the use of an app, or if the company recommends any workarounds. We definitely appreciate you sharing your experiences and feedback with us here, but for actual troubleshooting assistance with the product, I definitely encourage you to reach out to our support team directly at 877-659-2347. Alternatively, if you'd like to send an email with the details to support@eero.com and put "Community" and my name somewhere in the subject line, I'd be happy to get a senior specialist on the case directly!

      Thanks again for sharing your thoughts with us! We're grateful to have you here, and we look forward to any other thoughts and feedback you have – from all of us at eero, welcome to the Community!

      Kindly,
      Drew, eero Community Team

      Reply Like
    • Drew Thanks for the response.  You are correct in stating that certain apps require both the phone and the device being set up to both be on the 2.4ghz band.  There are few devices out there (wifi switches, strip lighting, etc) that can be hard wired into a computer for manual set up.

      I tried again today to set up the device.  This time I walked about half a block away from my home and then verified in the eero app that my iPhone was connected to the 2.4ghz band of the router.  Once this was verified, I tried to configure my wifi device and again it failed.  

      What I do not understand is that if I am certain that both my iphone and the device being set up are on the 2.4ghz band,  why my setup is failing?  I was able to set up the device on my Asus RT-AC66U with no issues....but on the eero,  no dice. 

      The wifi device I am trying to configure uses WPA2 encryption which is compatible with eero.  Something about the mesh network is preventing me from setting up this device.  

      I have done exactly what eero's "low tech" workaround is to thie problem to no avail...

      I have reached out to Steve P. at eero and he is escalating my issue up the chain to see if there is anything your Pro Team in Austin can do to help me out.  Unfortunately, I fear that this issue will come up again and again with other customers so I hope eero has some sort of fix in the works,  otherwise we are all going to be relegated to a rather narrow set of wifi offerings that seem to play nice with the eero system.

       

      Thanks for your help!

      Reply Like 1
  • I spent a long time on the phone with Victor and a person at my cable company today.  I tried the “from far away” method to no avail. When the Austin team comes up with something, I’d love someone to contact me, too.  

    Reply Like
  • I ran into this issue too.  After reading this thread my solution was to pull out an old iPad mini I had hanging around and use it to connect to my Eero network on the 2.4ghz band (the old iPad does not have 5ghz capabilities) then download the Wemo app and follow the instructions.  After downloading the app I had me Wemo connected and configured in 2 minutes.  This is a terrible workaround and only works if you happen to have a 5+ year old device hanging around the house.

    Reply Like 1
    • randge that is such a brilliant idea! I never thought of that approach! 

      Reply Like
  • So I found an old Motorola smartphone circa 2012 that only has 2.4ghz.  I downloaded the app “Magic home WiFi” required to set up my LED WiFi controller.  Went through the setup having both devices on the same band.....and.....nothing!  The WiFi device failed to connect.  I know it works because I was able to set it up on my Asus router.  I am beginning to think it has to do with the fact that my Eero is using a static IP address at the direction of the eero team because I was unable to connect to my network attached storage device without a static IP and now it seems that may be causing a conflict when trying to set up other devices.  It is truly amazing that a far more complicated router such as an ASUS RT-AC66U had zero issues communicating with or allowing me to set up all of my various iot devices,  yet when I shifted to this “user friendly” eero mesh network, I keep encountering issues connecting new devices unless they are from major brands like google, nest, Leviton etc.  This is immensely frustrating and this mesh network is anything but user friendly when it comes to device setup.  The fact that we have to go to an electronics landfill to dig up outdated technology just to be able to connect certain WiFi devices is archaic. 

    Reply Like
    • Thanks for providing this additional information mstephens77 , and sorry to hear you'r continuing to experience some frustration setting up devices.

      To clarify, having a single IP reservation set for another device on the network won't cause issues for any other devices attempting to connect, so please rest assured that that likely isn't contributing to the issue you're seeing. In this situation, the most effective way to get to the bottom of this will be to reach out to the support team directly so that we can assist you in a dedicated way! As before, the offer stands for me to get your ticket over to a senior specialist, so please email support@eero.com and put "Community" somewhere in the subject line so I can more easily locate your ticket. Alternatively, we can work you directly by phone at 877-659-2347 if that's what you'd prefer!

      We look forward to hearing from you so that we can get to the bottom of this and resolve the issue together!

      Kindly,
      Drew, eero Community Team

      Reply Like
      • sfenigma
      • sfenigma
      • 3 wk ago
      • Reported - view

      Drew I'm having this exact same issue, I called support and spoke to a nice gentleman called Jose, he helped turn off the 5ghz so my phone and device were on the same band.  Still no joy.  The app sees the device and connects but when trying to initiate it on the Eero network, it's a no go. I'm of the same opinion that this is a limitation of Eero and am contemplating if it's the right choice for me. Of course, if it can be sorted I'll be happy.  Please let me know ASAP as it's limiting me from being able to get set up. 

      Reply Like
  • Some versions of Android will let you force 2.4GHz, even if they are 5GHz compatible devices. My Pixel 3 does not but I have an old Nexus tablet on Lollipop and that worked like a charm. It's under the advanced wifi settings. 

    I found that this article had some interesting insights: https//www.pocketables.com/2018/05/how-to-set-up-that-2-4ghz-device-on-your-dual-ghz-network.html/amp

    Reply Like
  • I'm having the sames issues with my Amazon smart plug. It requires 2.4GHz but I can see on the Eero app that it is on the 5GHz frequency.  There should be a way to manually force these devices to stay on the 2.4GHz frequency. I was able to initially set up the plug (so it must've started out on 2.4) but then a day later it's flashing red and can't connect to Alexa. I thought it was the plug so I returned it. Of course the replacement plug is doing the same thing. Up until now I have loved my Eero mesh and have readily recommended it to friends and family. But this is a BAD flaw that needs to be fixed ASAP. 

    Reply Like 1
      • txgunlover
      • txgunlover
      • 3 mths ago
      • 1
      • Reported - view

      trevorbyrne There are multiple easy work-arounds.  The easiest is to call support.  An alternative is to use a device that only supports 2.4ghz to add the smart plug.  Another, albeit more difficult, is to move the phone and smart plug to an area where the 5ghz signal is weak or non-existent.

      I have more than 100 devices and dozens of smart plugs that are 2.4ghz and these methods work 100% of the time for me.

      Reply Like 1
    • txgunlover I can set up the device using 2.4ghz by "tricking" my iPhone to use 2.4ghz by walking far away from the hub. That works for a few hours, but inevitably the plug loses connection to the Eero, presumably because the Eero is only using 5ghz in my small house. It might be that the plug is close to one of my eero units. 

      Reply Like
  • So I just setup 3 Eero Pros that work nicely so far...I'd like to purchase like others have mentioned a few smart plugs that are compatible with Eero.  Is there any know device?  I saw one dual band Leviton smart plug out there that is dual band.  Its not cheap at $28 per.  Will this one work?  

    Reply Like
  • It would seem to make sense with ALL the issues that people are having setting up 2.4 devices (including me) that Eero would enable a feature that would allow a temporary 2.4 channel only.

    Reply Like 2
      • DaveI
      • DaveI
      • 9 days ago
      • 1
      • Reported - view

      Hansenrk look forward to hearing about your test. What worries me is while the plug can connect to either, it still has to match your phone. And who knows when you do the setup, which speed (2.4 or 5) it’s connected to. I think it may be all luck you can get both matching up. Eero needs to make this easier instead of saying it’s the plugs issue because they need a phone app to setup....

      Reply Like 1
    • Hansenrk If you contact our support department they can temporarily turn off the 5GHz network while you get your 2.4 GHz devices connected. Once you are done we can turn the 5 GHz network back on. Please send an email to support@eero.com with [Community Forum] in the subject line and I'll make sure your ticket is escalated quickly.

      Reply Like 1
    • Sidney Thanks for offering a possible solution. But the smart plugs I've tried thus far (two different brands) cease to function once they lose any temporary 2.4 GHz connection.  In other words, once the mesh network is running strictly on 5GHz, the smart plug will not be accessed by the Amazon Echo. The smart plugs only communicate with 2.4 GHz (as do some other smart devices apparently). Maybe Eero needs to start making 5 GHz smart plugs that will work with it's mesh. I'd buy them!

      Reply Like
      • Hansenrk
      • Hansenrk
      • 9 days ago
      • 1
      • Reported - view

      Sidney thank you, I will give that a try.  I just wish we had the feature to do this ourselves....

      Reply Like 1
  • I did find one smart plug that is apparently dual band, the Leviton15P (probably the one referenced by DaveI ). Here's an article on it, and there's a link on this page to buy it on Amazon (currently $24.99). https://www.techhive.com/article/3318250/leviton-dw15p-smart-plug-review.html. I'm going to try it.

    Reply Like
      • DaveI
      • DaveI
      • 9 days ago
      • Reported - view

      trevorbyrne 

      Reply Like
  • I had to replace my wireless security cameras to a dual band (expensive upgrade). Now it is my smart Tp-Link light bulbs.  If I only knew that I would have these issues, I would not have purchased the eero mesh system.  
    i do think that with a simple factory mod that would allow for us to turn off the 5ghz just to get through these setups would help immensely 

    Reply Like 1
Like1 Follow
  • Status Answered
  • 1 Likes
  • 9 days agoLast active
  • 34Replies
  • 2446Views
  • 16 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com