1

EERO compatibility with smart-plug devices?

Hi - I just installed my EERO system.   The iHome SmartPlugs I have (2) don't seem to be able to connect to this network.   Does anyone have recommendations for compatible smart-plug devices?  Thx!

18replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi, jc517b – 

    Thanks for taking the time to reach out, and welcome to the eero Community forum! I'm sorry to hear you're having some trouble with that automation equipment, but I'm not aware of any compatibility issues we have with iHome plugs. If you haven't yet, I strongly encourage you to give our support team a call at 877-659-2347 or shoot us an email at support@eero.com so we can dig a little deeper with you and get to the bottom of this.

    We appreciate you bringing this to our attention, and we look forward to hearing from you further so we can reach a resolution. Thanks again, and have a great day!

    Drew, eero Community Team

    Reply Like
  • Hey dude my iHome Smartplugs don’t work either. Did you find a solution? Please share if you did. I really really need this to work.

    Reply Like
      • jc517b
      • jc517b
      • 1 yr ago
      • Reported - view

      Soloman Yes - I did get them to work.   The fix involved doing a hard-reset on the plugs:

      Make sure that you have the 8-digit code from the bottom of the plug written down or that you can easily see that code.

      1. Hold down the power button. The light will flash green, flash red and green, go out and then flash green again. Release your finger.
      2. Go to the settings on your phone and tap on WiFi. Please make sure your phone is connected to your home 2.4 WiFi network. You should see the iHome Smart Plug in the WiFi “Set Up New Device”. Tap on the plug and follow the instructions. Once WiFi says it's connected to the network, tap DONE.
      3. Next you will go into the iHome Control app and connect the plug to the Control App by clicking on the devices tab on the bottom of the page and add device.  Follow the app to connect your plug. 
      4. Once you get the plug connected tap on the information (i) to the right and it will say edit.  Then scroll to firmware to check for update.  It will tell you if the plug needs an update.

      The key was Step 2:  If I did that in the phone WIFI settings - then the iHome app could successfully complete the configuration.

      Reply Like
      • Soloman
      • Soloman
      • 1 yr ago
      • 1
      • Reported - view

      jc517b  sorry kind of an idiot but I have eero Pro. Sooooo. I have one single wireless network and my device automatically picks the network.  How do  you choose 2.4?? Please help. Thank you also

      Reply Like 1
      • jc517b
      • jc517b
      • 1 yr ago
      • Reported - view

      Soloman Shouldn't make a difference - in your iPhone's WIFI settings - just select your EERO network - whatever it's named ("MyNetwork") - then follow Step 2-4.  I believe all EERO networks broadcast at both 2.4 and 5.0.  Now if you're using an Android device, I'm not going to be able to help out there - you'll need to contact iHome's support for those instructions.

      Reply Like
      • Soloman
      • Soloman
      • 1 yr ago
      • 1
      • Reported - view

      jc517b I am using an iPhone. My iPhone is always connected 5? How do I ever get connected to 2.4?   Plus my iHome plug shows up in the eero connected devices, I just can’t seem to complete setup in iHome app. I think it’s the 2.4/5 Business. How do you get your iPhone to pick.

      Reply Like 1
      • jc517b
      • jc517b
      • 1 yr ago
      • Reported - view

      Soloman - sorry, I'm not a WIFI expert.   I just select my WIFI network "network name" - EERO broadcasts at all frequencies.  I don't see anything on my wifi page that explicitly says "5 GHz".   

      Follow step 1 to reset your plug back to defaults.   Make sure if flashes red, turns completely off, and then flashes green.

       

      Then on your iphone, go to Settings > WIFI - and make sure you're connected to your EERO network.   While your plug is plugged in - you should see "Set Up New Device" on this wifi screen.   Follow the instructions in step 2 to connect your plug to your network.   If that doesn't work - I think you'll just have to contact iHome support for further assistance.

      Reply Like
  • I have the same issue. How do I make eero automatically assign my iPhone to the 2.4 ghz signal so that it will work with iHone?

    Reply Like 2
  • Someone at eero:

    We REALLY need to know how to connect our phone to the 2.4GHz to complete the pairing setup that is required for certain HomeKit devices. I know for a fact, that if your phone is on the 5Ghz, the pairing will fail. If you go on both iDevices and iHome web sites respectively: 

    Ref 1) "iDevices products require a 2.4 GHz home Wi-Fi® network." 
    Ref 2) iHome: "If you have a Dual Band Router make sure your device (iPhone/iPad) is connected to a 2.4 GHz, Wi-Fi Network." 

    Your answer will greatly influence my decision in buying your router.
    Thank you

    Johnny

    Reply Like 1
    • Thanks for reaching out johnnygoodface , and welcome to the Community! While there's not a way to actively "force" a device to connect to one frequency or the other, please rest assured that we're actively working on some options that might make setup for devices like these easier in the future. 

      For the time being, if a device manufacturer requires the 2.4GHz frequency, then there are a handful of workarounds that can make setup easier. The most straightforward (although admittedly low-tech) is simply to power down any extra eeros and physically move further away from the primary unit – this will help your phone connect on 2.4GHz so that you can proceed with iDevice setup. 

      Past that, for any other assistance you need, we'll always be happy to help out directly, so giving us a call at 877-659-2347 is the first thing I recommend if you ever have any immediate questions or concerns with the product. Thanks again for joining us here, and we look forward to hearing any other thoughts and feedback you have!

      Kindly,
      Drew, eero Community Team

      Reply Like
  • I’m having the same issue.  The cable company insists that it is the device but all my smart devices won’t connect.  Please help. 

    Reply Like
    • Thanks for posting Wincelee , and a very warm welcome to the Community! If you're having a variety of devices having trouble connecting to the network, then it's more likely that you're seeing an issue unrelated to frequency. We'd definitely like to look into this with you, so please give us a call at 877-659-2347 so we can take a look at the network and offer you some guidance!

      Kindly,
      Drew, eero Community Team

      Reply Like
  • I am having similar problems.  I cannot get any 2.4ghz devices to connect to eero.  I have set up my old router with the exact same SSID and password, set up the WiFi device on that router, switched back to eero which also has same exact SSID and password to no avail.  The 2.4ghz devices won’t connect to the router.  I have hard reset all the devices and walked half a block from my home with my iPhone to try and force a connection to the 2.4ghz channel with my WiFi device plugged in on the front porch so I can stay connected....still nothing.  It seems that without the option to disable the 5ghz radio,  it’s impossible to set up any peripheral devices that only have a 2.4ghz radio.  This is a big deal considering that I am a Purchasing manager for a national builder who just made Eero mesh networks standard in all our homes.  I suspect we will be flooded with warranty calls!

    Reply Like 1
    • Thanks so much for bringing these concerns to our attention mstephens77 and sorry to hear about the frustration. I'd like to stress that the eero has no problem authenticating and connecting devices that are 2.4GHz-only, and that 5GHz radio broadcasting simultaneously doesn't prevent these devices from connecting in any way; most of the issues we see in this field have to do with associated mobile apps for these devices that require the phone running the app to also be on 2.4GHz in order to configure the respective device. For 2.4GHz-only devices that are able to be configured manually by interacting directly with the device interface – for instance, using a wireless printer's display screen to configure WiFi – there should be no issue whatsoever. 

      For the devices you're having trouble with, I definitely encourage you to check and see whether they can be manually configured without the use of an app, or if the company recommends any workarounds. We definitely appreciate you sharing your experiences and feedback with us here, but for actual troubleshooting assistance with the product, I definitely encourage you to reach out to our support team directly at 877-659-2347. Alternatively, if you'd like to send an email with the details to support@eero.com and put "Community" and my name somewhere in the subject line, I'd be happy to get a senior specialist on the case directly!

      Thanks again for sharing your thoughts with us! We're grateful to have you here, and we look forward to any other thoughts and feedback you have – from all of us at eero, welcome to the Community!

      Kindly,
      Drew, eero Community Team

      Reply Like
    • Drew Thanks for the response.  You are correct in stating that certain apps require both the phone and the device being set up to both be on the 2.4ghz band.  There are few devices out there (wifi switches, strip lighting, etc) that can be hard wired into a computer for manual set up.

      I tried again today to set up the device.  This time I walked about half a block away from my home and then verified in the eero app that my iPhone was connected to the 2.4ghz band of the router.  Once this was verified, I tried to configure my wifi device and again it failed.  

      What I do not understand is that if I am certain that both my iphone and the device being set up are on the 2.4ghz band,  why my setup is failing?  I was able to set up the device on my Asus RT-AC66U with no issues....but on the eero,  no dice. 

      The wifi device I am trying to configure uses WPA2 encryption which is compatible with eero.  Something about the mesh network is preventing me from setting up this device.  

      I have done exactly what eero's "low tech" workaround is to thie problem to no avail...

      I have reached out to Steve P. at eero and he is escalating my issue up the chain to see if there is anything your Pro Team in Austin can do to help me out.  Unfortunately, I fear that this issue will come up again and again with other customers so I hope eero has some sort of fix in the works,  otherwise we are all going to be relegated to a rather narrow set of wifi offerings that seem to play nice with the eero system.

       

      Thanks for your help!

      Reply Like
  • I spent a long time on the phone with Victor and a person at my cable company today.  I tried the “from far away” method to no avail. When the Austin team comes up with something, I’d love someone to contact me, too.  

    Reply Like
  • I ran into this issue too.  After reading this thread my solution was to pull out an old iPad mini I had hanging around and use it to connect to my Eero network on the 2.4ghz band (the old iPad does not have 5ghz capabilities) then download the Wemo app and follow the instructions.  After downloading the app I had me Wemo connected and configured in 2 minutes.  This is a terrible workaround and only works if you happen to have a 5+ year old device hanging around the house.

    Reply Like 1
    • randge that is such a brilliant idea! I never thought of that approach! 

      Reply Like
Like1 Follow
  • Status Answered
  • 1 Likes
  • 6 hrs agoLast active
  • 18Replies
  • 1517Views
  • 9 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com