0

Unresponsive Beacon

I am having an issue with an Eero Beacon. I set it up and it connected fine. A day or two later the app indicated that I had lost connection with the Beacon. I have not been able to reconnect it. The unit just flashes white constantly. I have tried a reset with no luck. I have taken it to a different Eero network and attempted to connect it also with no luck. Half of the time I plug it in and get nothing, the other half of the time I just get the flashing light. 

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • You'll need to reach out to eero support so they can assist you with troubleshooting this: support@eero.com

    Reply Like
  • Hi, DavidMartin1979 – Thanks for taking the time to bring this to our attention, and welcome to the eero Community forum! I wish it was under better circumstances, and sorry to hear you're having some trouble with that unit. 

    In this situation, while we'll need to gather some more information from you, it's likely that we'll end up escalating this to our Order Management team to consider the unit for replacement. Please feel free to email in to support@eero.com and put "Community Forum -- attn: Drew" in the subject line, or call in to 877-659-2347 and we'd be happy to get this squared away for you ASAP!

    Kindly,
    Drew, eero Community Team

    Reply Like
Like Follow
  • 10 mths agoLast active
  • 2Replies
  • 308Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com