eero unable access Internet via private LAN

I bought the eero Home WiFi system (eero + eero Beacon) to replace the aging AirPort Extreme (802.11n, 3rd generation) I use to provide myself WiFi at a vacation condo I own. My "ISP" in this case is an ethernet jack which issues me an IP like or similar and a router IP of

Connecting the eero directly to this private LAN results in failure to access the Internet. At first, I assumed this was because the private LAN enforces a local login requirement, but it turns out that is not the case. I think the eero is confused by the address space of the local private LAN somehow conflicting

Connecting my AirPort directly to this private LAN works because I configured the DHCP range of the AirPort router to to and ignore the AirPort's objection to the Double NAT.

I have no such control on the eero AFAIK, but connecting the eero to a LAN port on my AirPort permits the eero to successfully connect to the Internet and provide local network 192.168.7.x, subnet mask, router IP, now "Triple NAT" I assume.

Is there anything I can do to eliminate the AirPort router from this setup?

12replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  •  Hi, jbthomson2 –

    Thanks for taking the time to reach out, and sorry to hear about this frustration. I'm more than happy to help get to the bottom of this so we can get eero up and running in your home!

    In this case, with the eero's default IP address scheme being 192.168.7.x, there shouldn't be a subnet conflict or issue unless the upstream router itself ever decides to provide a subnet that matches. However, to bypass that in the same way that your AirPort has done, we can easily adjust the eero's subnet to have a 10.x.x.x format like the AirPort has. 

    To do this, please refer to the following steps:

    • Hook the eero up to the AirPort so that we can bring it online for the purpose of setting and applying these changes
    • In the eero app, go to the Menu > Network Settings > Advanced Settings > DHCP & NAT
    • From there, select the "Manual IP" bubble, which will give you the option to choose the prefix. 
    • A standard set of IPs for the 4 fields will be – – – for Subnet IP, Subnet Mask, Starting IP and Ending IP, respectively (You can modify the range and subnet mask as desired)
    • After saving these settings, the eero will reboot to apply them. 
    • From there, it should be a simple matter to connect the eero right to your ISP jack and bring the eero back online!

    Please give these steps a try, and if you have any difficulty please feel free to reply here, or give us a call at 877-659-2347 or email support@eero.com and we can assist you more directly! Thanks so much for your time, and have a great day!


    Drew, eero Community Team

    • Drew I discovered the "Manual IP" feature just a bit before your reply posted. I have also added the MAC addresses of both Ethernet ports to the database associated with the "Local Login" protocol here. The Gateway eero continues to try to connect as evidenced by the slow blinking white LED. This continues for a bit until the LED turns steady red. The iOS eero app continues to report INTERNET CONNECTION ISSUE and the other fields in the app show Status: Offline (with a red paragraph about turning the eero on and having it within 40 feet, ...), Gateway Connection details: Offline, IP Address: No data available. The eero does not raise the WiFi network.

      I think this reflects total inability of (your server?) to be able to contact the gateway eero, so the eero app cannot be depended upon to reflect reality.

      This is a very different debugging experience from all of my past WiFi networking as the eero is essentially a black box with no inputs or outputs save the LED. 

  • Drew so it must be the case the the WAN Ethernet port A is not getting an IP address from the LAN here, hence no connection is ever possible. (BTW, is the send of Left and Right for the Ethernet ports as viewed from the rear or the front?).

    So, what could possibly be different about plugging the same ethernet cable from the  gateway eero to the LAN vs connecting from the gateway eero to a LAN port on my AirPort?

    • jbthomson2 by experimentation, Left and Right Ethernet ports are as viewed from the rear of the eero.

  •  Drew It seems really easy to configure things so that you lose connectivity and all ability to control the eero. Once you get into a state such as I am seeing where the eero app reports "We are having difficulty connecting to the Internet. Check x, y, z ..." you cannot make any changes to the gateway eero like selecting Automatic, Manual IP (or any of the subnets) or Bridge mode. The option to "Save" never appears even if you just wanted to change the private LAN IP range.

    Example: after my failed attempt to connect to the local LAN here using 10.0.00, I could no longer connect via the AirPort until I recognized the new conflict with the AirPort LAN which I then changed to 172.16.0 .0 (or would have worked) to be able to talk to the gateway eero after a power Off/On cycle.

    Is there nothing you can do configuration wise directly between iPhone eero app and the gateway eero, like Bluetooth? Or raise the eero's WiFi network?

    Like 1
  • Drew After working with it some more, the problem simply has to be either that the Ethernet port (A in this case) is not getting an IP address from the local network I am trying to use for my ISP OR the local login protocol is interfering with the protocol which eero (the company) uses to establish the connection.

    The changes I've made to the range of IP addresses used on the eero's private LAN have made absolutely no difference which seems correct and obvious now that I think about it. Connecting the eero through my AirPort LAN continues to be all that works: the AirPort has no issues connecting its WAN port to the ISP local LAN, and, clearly the eero has no issues getting an IP from my AirPort. Whatever protocol you use to configure/establish a connection apparently is not being inhibited by the ISP local LAN because it clearly passes through my AirPort to the eero in this configuration.

    I tried configuring my AirPort as a bridge with the eero connected to the AirPort. This too fails because it is exactly the same situation as directly connecting to the ISP local LAN.

    The network parameters for the ISP local LAN are:

    Subnet mask is

    Router IP address is:

    None of these are what one would generally expect when connecting to an ISP's cable modem. Anything about these parameters that would be show stoppers for the eero gateway?

    • jbthomson2 My error in typing above response: Subnet mask is, not

  • Hi, jbthomson2 – 

    Thanks for providing this additional information. Yes, to confirm, the left and right Ethernet ports refer to a view from the back of the unit – when looking from the LED side, the sides are reversed. 

    In this situation, based on your description I'm a little confused about the nature of your ISP connection – do you have a Static IP that needs to be configured to match the information provided, or is that just the DHCP and subnet that it happens to use when handing out dynamic IPs? If there's no Static IP required, then the eero should be able to just come online immediately, especially if you've already configured the upstream router to recognize both the Ethernet MAC addresses. Additionally, with the eero able to come online behind the Airport, we know that the ports themselves are operational and that the eero is able to receive an IP address from DHCP as expected.

    Given the complexity of the situation and the moving pieces involved, I think it'll be most effective for one of our specialists to speak with you directly, and preferably with a support agent from your ISP or local condo IT admin as well, so please call 877-659-2347 at your convenience. You can conference us in and we can all work together to determine why your WAN jack isn't providing a signal that the eero can use. We absolutely appreciate the time you've spent on this already, and we look forward to hearing from you to get this resolved!

    Drew, eero Community Team

    • Drew The  network I am connecting to is an extensive network of Ubiquiti routers and access points which supports network services for all the guests of the resort. My observation is that my 8 year old AirPort Extreme (Model A1301) has no issue getting an IP address via DHCP. Further, my 5 year old AirPort Express (Model A1392) has no issue getting an IP address from the network. No static IP needs to be configured. Any tests I may have done with  static IP was to just see if that would work with eero.

      A scan of the network reveals hundreds of devices connected to the network here, many of them making IPv6 connections (recent iPhones, computers, etc) so it must be true that the network here uses DHCPv6. If 8 year old and 5 year old Apple AirPorts can easily get IP addresses, then they must be successfully negotiating with the DHCPv6 server to decline IPv6 addresses and drop back to IPv4 addresses.

      By extension, the eero (2nd Generation) must be failing the negotiation for an IP address. I found a reference that eero does not support IPv6 or DHCPv6, but you can't just punt when queried by a DHCPv6 server. IMO, the eero is not handling this relatively simply negotiation properly.

      I have filed direct tech support calls on this and have heard nothing since the last email that indicated second level support was looking into it on October 2, nearly a week ago. I wonder if (doubt that) anyone is actually looking at the problem.

  • @Drew I contacted  the contractor who manages the resort's network here. He declined to help me figure out the problem as they don't approve of anyone connecting their own WiFi routers (or other routers) to their network. I did find references to the network being strictly IPv4, no support for IPv6 now or planned. The network does support both VPN Passthrough and VPN NAT Traversal, but that should not make a difference with DHCP.

      • Drew
      • Drew
      • 5 yrs ago
      • Reported - view

      Hi jbthomson2 – Thanks for the update! I was able to see that my colleague emailed you back a couple days ago, so please double-check your inbox for our message. If you didn't get it, I can forward it to you again! It has some additional troubleshooting steps to consider, so hopefully that will point us in a good direction to get eero installed and configured for you!

      Drew, eero Community Team

  • @Drew Well it took over two weeks but I finally stumbled on the solution. On a whim, I replaced the red CAT5 ethernet patch cable I had been using for years (with the AirPort Extreme) with a blue CAT5 ethernet patch cable of the same vintage and was pleasantly surprised to see that the gateway eero as well as the eero Beacon are now up and running. Both the eero and my AirPort have Gigabit ethernet interfaces and the network speeds involved here are very low (throttled to under 5Mbps) so I am surprised. It has to be that the red patch cable has some issue which the eero cannot handle. The chipsets in the eero are 8 years newer technology than the AirPort which was 2009 vintage and likely way more sensitive. Anyway, the whitelisting of the eero Ethernet interface quite obviously worked.

Like Follow
  • Status Answered
  • 5 yrs agoLast active
  • 12Replies
  • 2371Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support