1

TiVo used with eero and can鈥檛 download program data!

This is allegedly a known issue but hasn鈥檛 been fixed for weeks now.  I鈥檓 probably ditching my eero today... 馃槙

20replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I have a TiVo Bolt and two TiVo mini's and I have never seen this issue with my Eero network which consists of three gen 1's, one gen 2, and one eero Beacon.  I do have a private static assigned to the TiVo Bolt with the required ports forwarded.  I would check that and possibly your network cable.

    Reply Like
  • I have a TiVo Roamio (6 tuners) connected to Eero Pro via WiFi with flawless performance. My TiVo Mini is connected via moca and also works well.

    Reply Like
  • TiVo Bolt, happened the past month. Today I had to connect the TiVo directly to the cable modem so that it could update the tv data as I had run out of  guide data.

    Reply Like
  • Does the Tivo require you to open some ports? This is the problem I had with my home automation gateway. It was connected to the internet, but couldn't communicate until I opened two ports.

     

    Good luck.

    Reply Like
  • I am having the exact same issue with my tivo and gen1 eero.  Had catv tech look at it and isolated it to the eero.  As soon as we hooked up the tivo directly to the cable modem tivo worked, hooked up eero again and nothing.

    Anyone have ideas?

    Does gen2 have same issues.

    My gen1 has worked no issues until the last month maybe an eero update is the issue?

    Reply Like
  • It sounds like you need to ask Tivo or search their support site to find out what ports need to be opened.

    Once you open the right ports, you should be able to put the Tivo behind the Eero.

     

    Good luck!

     

    PS. This article looks relevant:

    https://support.tivo.com/articles/Troubleshooting/Which-Network-Ports-and-IP-Addresses-Need-to-be-Open-When-Using-my-TiVo-DVR

    Reply Like
  • Problem solved, contacted Eero support and it was the latest update causing the issue.  They rolled me back to a previous issue and problem solved.  Great job by Eero team I still recommend eero to my friends!!!

    Reply Like
  • Hi, got the same issue before and ask help with my tech friend he said it was just a bug of the new update. just need to have the previous eero update to make it work. and so i did and now it all works fine. thanks...

    Reply Like
  • I am running into this issue now. Opening the ports required by Tivo did not resolve the issue, the Tivo will pass its port check and DNS check but something around the account status check fails. Question for everyone with the issue: Are you using you ISPs DNS or Eero Plus or some other provider?

    Reply Like
    • Hi, ciscomancer 鈥 thanks for taking the time to reach out, and welcome to the Community. I'm certainly sorry to hear you're having some trouble with TiVo. While we've been investigating this behavior with users that report it, we have no reason to believe it's got anything to do with your DNS settings. I definitely encourage you to give us a call at 877-659-2347 so we can take a look at your network and make any necessary adjustments to get things working!

      Thanks so much for joining us here on the Community, and we look forward to herring form you soon!

      Kindly,
      Drew, eero Community Team

      Reply Like
  • Hey Drew,

    Thank you for the reply, i reached out yesterday and your man Jesse is rolling back my firmware today. Thanks to the Eero crew for the prompt attention, I should be using this an an opportunity to finally cut the cord but as it is the holiday season if i disrupt the Hallmark Channel at all my wife is going to go full Grinch on me.

    Reply Like 1
  • Is there an ETA on when this will be resolved?  I've been using an older version of the firmware for 6 months now and unfortunately that means I can't take advantage of many of the new features that are being released.  

    Reply Like
  • Long time Tivo user and eero user here. I too have a problem connecting to the TiVo service. But - my TiVo is connected via ethernet. The TiVo goes to a switch directly connected to the router and does not interact with eero. On my network, eero is in bridge mode, with an Edgerouter ER-X doing the connection to my fiber ONT and it also does the DHCP work.

    I've been struggling with this issue for some time and I'm pretty much convinced it's a TiVo issue. My Bolt has this issue (on ethernet) and my Tivo Series 3 (on WiFi via eero) does not. I can force a good connection 100% of the time by going into my TiVo network settings, see that it failed, then force a new connection. That will also fail. Now, go back when you see the failure screen, and connect it again. It works for me 100% of the time. The connection step always fails in "Getting account status".

    TiVo technical/customer support is worthless, I'm about ready to configure a raspberry pi as a packet sniffer on ethernet and see exactly what the network activity is.

    I'm not saying there isn't a similar issue with eero, but if you look at the TiVo forums you see many other users with this (or similar) issues that have nothing to do with eero.

    Reply Like
    • oester On reddit, they stated that they're unable to reproduce the issue.

      Reply Like
  • By "They" I assume you mean eero - and I did read that -  which is why I suspect it's a Tivo issue that can occur regardless of network connection type. Tivo has never been one to really dig into any sort of connection issue. "A good reboot will fix anything".

    Reply Like
  • Unfortunately I've tried that many times.  Eero support was aware of the issue and reverted me back to a specific firmware revision on their product which has been working flawlessly so I'm not sure how much of an issue Tivo has since the Eero firmware changes fix or break the updates.

    Reply Like
  • Eero support is very disappointing. I've been on the old version for months, but eero plus won't work on the legacy version. Wish they would fix this so tivo users can also have a protected network. 

    Reply Like
  • Update for me - as I stated before, I was having this exact failure on my TiVo Bolt and it was connected via ethernet. In the past few weeks, the problem has disappeared and it now connects to the TiVo service every day with no issues. I would be interesting to see if you update to the new level if the problem still presents itself - I'm thinking TiVo changed something. Nothing has changed on my home network during this time.

    Reply Like
  • Anyone know if Eero finally fixed this issue?  I feel the same months ago I was reset to older version seems like a solution should have been gotten by now

    Reply Like
  • I hope so. I've been on 3.7.0 which was released last February.  I'd really like to take advantage of the new features.

    Reply Like
Like1 Follow
  • 1 Likes
  • 8 days agoLast active
  • 20Replies
  • 781Views
  • 15 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com