Solving Apple iPad 2 connection problem - turn off WPA3 experimental feature in eero labs

I set up my eero mesh wifi network in June 2020 and it worked very well and all my Apple devices and other devices connected to it without a problem. Then, in July 2020, the iPad 2 would not connect. Tried all the online solutions for iPad wifi problems, including a DFU reset. I had also reset the eero network, but nothing worked. Finally solved when I looked under the "Discover" tab in the eero app, and I found that I had turned on an "eero labs" experimental feature for WPA3 security. This feature is billed as "Provides added security for devices that support the WPA3 standard." Well, it also prevented the iPad 2 from connecting, as this feature apparently interferes with devices that do not support the WPA3 standard. After disabling this WPA3 feature on the eero network, the iPad 2 connected immediately.

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Yes, I can confirm that turning on eero labs' WPA3 feature will cause older iPad, running older iOS, to unable to connect to the eero wifi.


    As OP stated, as soon as WPA3 is turned off, everything works again.

    I suspect iPads are not the only ones that will have this problem. Please investigate and fix. Thanks & keep up the good work!

  • Same with the first generation of iPad Mini.  Have to double check with our 3rd gen Apple TV that I  noticed stopped connecting to the internet.   That could also be a separate issue too.   

  • I am confirming that I had this same issue and employed the same solution to fix a connection problem with a MacBook Air 2012.

  • Seen the same problem on ipad2s and on a new (2021) sole Treadmill 

  • Can confirm i have same issue with iPad 4th generation / late 2012 running iOS 10.3.3 , the last update issued for device. 

    Has me wondering if the erro 6 discover | eero labs | wpa3 preview support is in need of update to suppress advertising that wifi security support to devices that break when the see wpa2 and wpa3 security support response in connection negotiation.

    Has me wondering if its the underlying wifi hardware that has issue negotiating wifi connection when both wpa2 and wpa3 are advertised for securing connection or if the issue is in the iOS software.  If the latter then i might be willing to try some of the walk throughs i see search hits for outlining how to put newer iOS on devices that have reached end of life update support vs having to remove my wifi network support for wpa3 in addition to wpa2.

  • Yes wpa3 "transition mode" is supposed to mean you get wpa3 for devices that support that and wpa2 for devices that don't support wpa3, aka wpa3/wpa2 mixed mode.  That said all the older apple devices, that don't allow upgrading to latest iOS, don't work in mixed mode. See old iPad 10" with iOS 10.3.3 won't connec… - Apple Community .  So its unclear whether addressing this, if one wants to keep wpa3/wpa2 mixed mode enabled, is a responsibility of apple for those older devices of the wifi access point vendors adding some behavior that does better job of ensuring a wpa2 only older apple device can still connect without reverting to wpa2 only mode for them.

Like5 Follow
  • 7 mths agoLast active
  • 6Replies
  • 1083Views
  • 8 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support