1

Solving Apple iPad 2 connection problem - turn off WPA3 experimental feature in eero labs

I set up my eero mesh wifi network in June 2020 and it worked very well and all my Apple devices and other devices connected to it without a problem. Then, in July 2020, the iPad 2 would not connect. Tried all the online solutions for iPad wifi problems, including a DFU reset. I had also reset the eero network, but nothing worked. Finally solved when I looked under the "Discover" tab in the eero app, and I found that I had turned on an "eero labs" experimental feature for WPA3 security. This feature is billed as "Provides added security for devices that support the WPA3 standard." Well, it also prevented the iPad 2 from connecting, as this feature apparently interferes with devices that do not support the WPA3 standard. After disabling this WPA3 feature on the eero network, the iPad 2 connected immediately.

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Yes, I can confirm that turning on eero labs' WPA3 feature will cause older iPad, running older iOS, to unable to connect to the eero wifi.

     

    As OP stated, as soon as WPA3 is turned off, everything works again.

    I suspect iPads are not the only ones that will have this problem. Please investigate and fix. Thanks & keep up the good work!

    Like
Like1 Follow
  • 1 Likes
  • 1 mth agoLast active
  • 1Replies
  • 65Views
  • 2 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com