0

Custom DNS falling back to ISP DNS?

I am hitting a rather strange issue with the custom DNS options.

I have a local DNS server (a pi-hole) that I run on my network, I have my Eero set to use this server as my custom DNS. The behavior I am seeing is that when a device to the network it connects without internet, using the custom DNS, then switches back to the ISP DNS and connects to the internet.

 

I'm confirming this by using this command,

scutil --dns | grep 'nameserver\[[0-9]*\]'

 

I run this on my Macbook when it first connects to the Eero network and I see the custom DNS ip address, then a few seconds later when my Macbook actually jumps on the internet I see a local IP (10.*.*.*) address which I assume is my cable modem / the ISP's DNS since my network is a 192.168.*.* address. I'm debugging through this and I assume something is wrong with my local DNS server but I can't understand why the Eero is switching away from the configured DNS server.

TLDR: Is it expected behavior that the Eero would fallback to another DNS server if the custom server failed to work properly?

Reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
Like Follow
  • 12 days agoLast active
  • 14Views
  • 1 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com