WPA3 exclusivity

When I enable WPA3 in the Beta section, I can no longer connect with my older Epson printer. Is it possible to have WPA3 play nice with older devices by only dealing with WPA3-compatible devices, while leaving others alone? Thanks!

1reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I agree.  I attempted to add a new digital photo frame from Skylight that was a gift.  It would consistently get a 'signal lost' message on the frame.  I could see it connected to the network, but was unable to communicate and there was no data sent or received.  I attempted all the recommended troubleshooting steps including rebooting the frame, rebooting the network and attempting different areas of coverage.  I could connect the frame to my hot spot without any issues.  I attempted to enable the guest network and that did not work either (same message).  Finally disabling WPA3 allowed it to connect.  Every other device on the network worked just fine with WPA3 on for many months.  I think it just needs to be a little more discerning of the criteria to use WPA3 vs. WPA2.

    Like 1
Vote6 Follow
  • 6 Votes
  • 1 yr agoLast active
  • 1Replies
  • 72Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support