4

Fing reports Network netmask (prefix length) is not tuned correctly

My fingbox keeps reporting the following:

Network netmask (prefix length) is not tuned correctly

Home network is too wide: 192.168.4.0/22, up to 1024 devices

Is there a way to fix this on my Eero Pro?  I don't see a way for Fing to ignore the alerts.

 

More info:

Code 406: Network netmask (prefix length) is correctly configured

Failure case: Network netmask (prefix length) is not tuned correctly

Network check: information are gathered from your current network

 

Technical definition

The check verifies that your network subnet mask (or network prefix length) is not oversized. Although networking standards recommend to always prefer multicast and broadcast when searching for networking services and devices, many modern IoT devices have still been using unicast sweeps to find peers: this means that lookup, onboarding, pairing or service usage when you have a big network will make the device lookup for the service on a very big number of possible devices, instead of just 256/512. A good example of this is also Windows workgroup: NetBIOS is unicast, so lookup of other PC and printers in a big network takes much longer. The same happens as well to network monitoring software like Fing, Fingbox, and so on: these apps leverage ARP-sweep or ping or similar, so the time taken by a network discovery is proportional to the network size.

What it means for me

A subnet mask is a number that defines the range of (IP) addresses available within a network. It uses the same format as IP address, but in negative format, e.g. 255.255.255.0 is a typical Class C mask including a range of 256 addresses. An alternate form to express it is as network prefix length, meaning how many bits of the network address are stable: a class C network is /24, meaning that 24 bits, first 3 bytes of the address, are not varying.

How I can fix this

An oversized network is much slower than a correctly sized one. E.g. a home network with dozen devices not being a Class C is definitely not tuned correctly. In order to fix it you don't have to change your local PC configuration but rather login into the router configuration and edit it. To make sure every device gets the new updated configuration you should also power cycle or reconnect all connected devices.

18replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Same issue here. No idea why. restarted network, troubleshooted ISP... Changed DNS... nothing.

    Like
  • OK, but where can I access this field to edit it? I don't see anyplace in the Eero app that gives access to this. Trying to log in directly to the eero is denied...

    Like
  • Has this been addressed? I’m getting the same error.

    Like
  • *bump*

    Like
  • I appreciate what you did.    
        

    Like
      • Luella
      • Luella
      • 10 mths ago
      • Reported - view

      Luella 

      Thanks again >> MCDVOICE

      Like
  • Hello everyone,

    Based off what the OP posted it looks like you just need to change the subnet mask to change it to a class C. I didn't see a list of any troubleshooting steps taken so far so I will suggest changing to manual IP which is in Settings -> Network Settings -> DHCP & NAT. Select Manual IP and you will be able change the subnet to 255.255.255.0 which should solve this. Can anyone give this a try and let me know if the device is still reporting the message?

    Like 1
      • Calion
      • Calion
      • 11 mths ago
      • Reported - view

      James After changing DHCP & NAT from Automatic to Manual IP and changing the Subnet IP from 192.168.0.0 to 255.255.255.0, tapping Save, and tapping Reboot, I received the following message: “We couldn’t update your settings. We ran into an issue updating your settings. Please check to make sure you entered the right values and try again."

      Like
      • Calion
      • Calion
      • 11 mths ago
      • Reported - view

      Calion Am I doing something wrong here? Should I be changing the Subnet *mask*, not the Subnet IP, to 255.255.255.0? To be honest, I’ve never been quite clear on what these settings do.

       

      Like
      • Deborah
      • Deb
      • 9 mths ago
      • Reported - view

      James or Calion - Any confirmation as to whether or not this solves the issue? I'm seeing the same thing on my Fing and it doesn't look like this was fully resolved here...?

      Like
      • Calion
      • Calion
      • 9 mths ago
      • Reported - view

      Deborah I never got clarification on whether he was referring to the Subnet IP or the subnet mask, so no. 

      Like
      • Calion
      • Calion
      • 8 mths ago
      • Reported - view

      James Could you clarify the above? I am having difficulty following your instructions. 

      Like
      • bigtree
      • bigtree
      • 8 mths ago
      • 1
      • Reported - view

      Calion He is referring to the subnet mask.  By default, it is 255.255.0.0.  Change it to 255.255.255.0.

      Like 1
      • bigtree
      • bigtree
      • 8 mths ago
      • 1
      • Reported - view

      James yes, this resolves the problem, thank you.

      Like 1
  • bigtree said:
    He is referring to the subnet mask.  By default, it is 255.255.0.0.  Change it to 255.255.255.0.

     I am getting the same issue/notification from Fing. When I do the above in Manual IP and enter the 250.250.250.0 it says I also need to enter Subnet IP as well? Note that when I change setting to Manual IP the lease range is all blank (subnet mask, subnet IP, starting IP and Ending IP are all blank. Am I supposed to be entering something in these others as well? If so then what please?

    Like
      • bigtree
      • bigtree
      • 4 mths ago
      • 1
      • Reported - view

      PK 255.255.255.0 not 250.250.250.0.  Subnet IP can be 192.168.0.0 if that is what you have your IP address prefix set to. Other values can work, but I am using 192.168.0.20 for the starting IP and 192.168.0.254 for the ending IP.

      Like 1
      • PK
      • PKBris
      • 4 mths ago
      • Reported - view

      bigtree thanks for your input. I followed your advice and it now seems ok. So much for Eero settting it up automatically to the best settings. Mind you, I cant see that it has made any difference to speeds and such :-)

      Like
  • Odd. My Subnet IP is the same as my IP address prefix: 192.168.0.0. The starting is 192.168.0.20, and the ending is 192.168.0.254  I didn't set or change any of that. Maybe leave it on Automatic, restart the eero, and try again?

    Like
Like4 Follow
  • 4 Likes
  • 4 mths agoLast active
  • 18Replies
  • 423Views
  • 12 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com