17

Devices not connecting to closest eero

A quick background on my setup:

  • I am running the latest version (1.4) of the iOS app
  • I am running the latest firmware (2.1.0) on my three eeros.
  • My first eero is connected as follows:  modem -> eero --> switch
  • My other two eeros are hardwired via ethernet back into the switch.

 

Upon updating the iOS app, I started checking to see which devices are connected to which eeros. I was surprised at what I found.

  1. Most of my devices are connected to the primary eero.
  2. An iPad in an upstairs bedroom is connected (with a weak signal) to the primary eero which is downstairs in my den even though there is an eero in the same bedroom as the iPad. (The iPad stays in that bedroom, it never wanders around the house).
  3. My Rachio sprinkler controller is also connected to the den eero even though there is an eero much closer to the garage.

These are not the results I expected. I thought I placed the eeros to give me strong coverage throughout the house but the devices don't seem to want to connect to the closest available eero. I also thought since I wired them via ethernet that this would give me the strongest possible mesh network possible.

Did I do something wrong in my setup? Any suggestions on how to correct this?

Thanks,

Mike

181 replies

null
    • aarkayne
    • 3 yrs ago
    • Reported - view

    i have 3.20.0 and still face this problem!

      • Hewittm
      • 3 yrs ago
      • Reported - view

      my friends got eero as do I

       

      he had same problem as many on this thread and went to lynksys mesh .... everything works correctly now 

       

      Soneone at eero explain this why 2 vendors get it right with same devices but eero doesn’t ? 
       

      the chipsets of all the mobile devices haven’t changed what has is the chipsets of the mesh vendors being used 

      • austegard
      • 3 yrs ago
      • Reported - view

      aarkayne I don't think he even works for eero - he just has a religious zeal about this issue. All of us (and Apple, Sonos, Google, Dell, etc) are wrong, he and eero are right; thus there's notghing to be done except to complain to your device manufacturer... smh

      • txgunlover
      • 3 yrs ago
      • Reported - view

      aarkayne I'd take a look at the Wifi standard and find out for yourself who is violating it... Not "EVERY" manufacturer got it wrong...

      • txgunlover
      • 3 yrs ago
      • Reported - view

      austegard Recommend you work with the lead developers for eero over at eero's subreddit if you'd like to know more about the issue.  You can take their references, do your own research, and find out for yourself.

      • robertsd
      • 3 yrs ago
      • Reported - view

      txgunlover I’ve had Apple and Amazon devices, HP laptops, custom built PCs all affected by this, I don’t deny maybe Eero is trying to do the right thing wrt WiFi standard but obviously to some pedantic extreme. 

      • txgunlover
      • 3 yrs ago
      • Reported - view

      robertsd I have over 130 continually connected devices.  Very few exhibit this behavior.  I have no Apple devices.

    • austegard
    • 3 yrs ago
    • Reported - view

    The ask isn’t to violate WiFi standards, the ask is for eero to fulfill its promise of being a better WiFi system, which it is currently failing for a lot of customers. Implementing the v and/or k extensions could help? I can’t think of a single manufacturer of my 50 client devices that is consistently picking up the stronger signal, so I (and others) are looking for eero to come up with a creative option. TrueMesh is already just simulating WiFi, so they’re obviously not afraid of going their own way. 

    • speedlever
    • 3 yrs ago
    • Reported - view

    If we had the ability to reduce transmit power, that would go a long way towards facilitating client roaming. But that adds complexity to the relatively simple user interface. I have a mix of mobile clients and they roam seamlessly on my home system (UniFi) with reduced transmit power. I find tweaking wifi systems more of an art than science because of all the variables at play. 
     

    The eero system is a lot easier to setup than prosumer systems like unifi though. I’ve setup a couple eero systems for relatives and they’re all happy so far.

    • Jas_Hunt
    • 3 yrs ago
    • Reported - view

    I have several TP-Link smart switches at home. Two of switches are next to each other, but one of them keeps connecting to a weak and far away Eero beacon. Sometimes, both. Well, that should not be a problem, but the issue is that Echo/Alex reports that the switch is not responding, yet, it works in TPLink's Kasa app perfectly. I have to delete and re-discover these switches again and again, which affects the Alexa routines.  I have tried everything including reserving the IP address for it. Nothing helped, and I don't know whom I should complain to. When I unplug that beacon, the issue is not there.  I have 1 main Eero Pro and two beacons. The beacons have had many problems, and I ended up unplugging these beacons. It's the most frustrating product I have owned since Windows Vista. 

    • Zachdaddy
    • 3 yrs ago
    • Reported - view

    I have the same issue 3 years after you guys!  My Logi Circle baby monitor chooses to connect to a distant router with terrible signal strength despite a strong router just on the other side of the way about 5 feet away.  This is scary because a baby monitor can be a life or death piece of technology.  The fact that Eero doesn’t allow for a Mac Address black list on each router is astonishing, negligent, and in my case dangerous!! I expect my baby monitor to work and if it is connected to the wrong router I have no ability to switch it or force it to re-connect to another node.  
     

    Eero can you please respond to me here.  I have 3 Eero Pros and am not sure what to tell my wife.  Do I tell her too bad and let’s just hope it doesn’t fail us when we need it most?  Is that the recommendation from Eero?  
     

    I guess I could buy one more mode just for the baby room but that seems insane given my whole house is 1500 sqft on one floor and I already have 3 Eero Pros all connected to Cat6 Ethernet.  

      • Lhomer
      • 2 yrs ago
      • Reported - view

      Zachdaddy 

      Buying another mode to place in the same room will NOT help - I installed my EERO Pro a month ago and have the same problem discussed above. Installed three modes in the house, one 7 feet from my work laptop (that never moves) and can actually see when the difference when it switches to a distant mode in the house; everything obviously slows down. Put the laptop in airplane mode momentarily and the mode switches back to the nearby mode. After a few hours, the connection transfers (all by itself) back to a distant mode in the house. Not very happy with the system - guess what's next ....

    • Jimmie
    • 2 yrs ago
    • Reported - view

    This is years later and this issue still persists. Eero has done nothing to improve this it seems, very disappointed. 

      • txgunlover
      • 2 yrs ago
      • Reported - view

      Jimmie There is nothing they can do.  It's completely related to the client.  Clients choose what AP they connect to, not the other way around.

      • Jimmie
      • 2 yrs ago
      • Reported - view

      txgunlover That's not how their web page or troubleshooting reads. Turning off the wifi and turning it back on is supposed to be their solution. There's no reason that an access point <5 feet away doesn't get the connections but the access point 20+ feet away does, even though there's a brand new Eero Beacon in between the two points. 

      I've got a smart hub 3 feet away from an Eero point, the smart hub is instead routed to another Eero point 20+ feet and on another floor. Turned both off, again, handed off again to the access point on the other floor. That Eero point near hub is shown to have good connection to the gateway Eero, yet it instead connects to the further point with a higher ping and higher latency. 

      The gateway has zero connections, zero. Nothing connects directly to it despite it being the Eero Pro with gigabit connection. Not the streaming devices feet away, not the tablets in the room, not the cellphones. Just picking up the tablet now to check and the pings in the game are well over 500ms, speed tests are all high latency. There's no excuse, and no, it's not the devices. 

      This wasn't an issue with the Google WIFi system this replaced. 

      • txgunlover
      • 2 yrs ago
      • Reported - view

      Jimmie That's how WiFi works, and it is absolutely how eero works.  Clients determine what AP they connect to.

      • Jimmie
      • 2 yrs ago
      • Reported - view

      txgunlover 

      if a gateway Eero Pro won't take any connections from feet away, an issue many have, that's the Eero. It's nice of you to white knight for Eero, I'm sure Amazon is thankful. There's no way that the the most stable connection for the devices is a weak signal across the house when they first connect to the network.

      So as you're saying that multiple products of multiple brands all choosing the weakest signal with high latency to connect to is each individual devices fault for not connecting to the strong WiFi signal feet away when they connect to the network is the devices fault, you really don't see how ridiculous you sound. 

      A gateway access point taking ZERO connections at any point from devices feet away is absolutely an issue with the product, not the devices. Please, by all means, go on.

      • txgunlover
      • 2 yrs ago
      • Reported - view

      Jimmie Absolutely not.  A client chooses the AP it connects to. 

      • Jimmie
      • 2 yrs ago
      • Reported - view

      Jimmie repeating yourself doesn’t make it any less false. If an access point can’t take a connection it’s the access point. 

      • txgunlover
      • 2 yrs ago
      • Reported - view

      Jimmie I'm sorry you don't understand how clients choose AP's, but the bottom line is, what AP a client connects to is completely up to the client.  You can be right next to an AP and ultimately the logic on the client determines what AP it talks to.  Apple devices are notorious for choosing the first AP they "see" in their scan regardless of signal strength.   Your complaint here is with your client.  No amount of complaining about how WiFi works will change the client's logic.   Think about it logically, what kind of security risk would there be if AP could direct clients to whatever AP they wanted?  

      • Jimmie
      • 2 yrs ago
      • Reported - view

      txgunlover unless the client can't take connections, hence the 0 connections feet away. You keep trying, you're still wrong and going hard with the White Knight for Eero.

      Cool story bro.

      • txgunlover
      • 2 yrs ago
      • Reported - view

      Jimmie Clients don't take connections..  AP's do.  I've worked with some of the largest industrial Wifi networks for more than 20 years, and can assure you, AP's never dictate to a client what AP's MAC address to connect to, the client always chooses.

      AP's can "poison" a connection to force the client to re-scan, but once they disconnect to re-scan the logic on what AP to connect to is up to the client.

      Bank on it buddy. 

    • bitzerjdb
    • 2 yrs ago
    • Reported - view

    I know you like to beat this point and you are correct to a point.  The issue here is that with non Eero AP's the client switches quickly or connects to the closest one.  Replace the AP with an Eero and you don't get the same behavior.  Same client...different behavior.   I have tested this with ASUS & Dlink AP's.   I have a few Wifi lights that insist on connecting to a distant AP with a very low Signal, they ignore the Beacon that is 5ft away from them...  Replace the Beacon with another AP...and they connect to it 100% of the time.  Replace the Beacon with an Eero Pro, and they connect to it about 20% of the time.  

    I was able to trick them by turning off all the eeros except the beacon and a distant Eero Pro.  Once they "found" the Beacon, they stuck to it.  Brought up the rest of the Eeros and they continue to go to the Beacon.  

    Again, if I put the Asus AP in the Beacons place, the bulbs connected to it 100% of the time.  And this is with the entire Eero network up and running.  

    • Hewittm
    • 2 yrs ago
    • Reported - view

    I've tried it with Linsys Velop and BT Mesh and consistent results when moving round the house/garden  in terms of devices picking up the strongest AP device signal.  Switch back to Eero and it never switches from the first AP it connects to until I turn off some AP's and force it.  I should get the same behaviour with all my devices no matter what Mesh network I implement.  

     

    The device makes the decision!   So why does it make the logical decisions with Linsys and BT Mesh and make the wrong one with Eero?

    Seems nuts to me and this thread seems to be going round in circles

    • rexjak
    • 2 yrs ago
    • Reported - view

    I have this problem as well.  HP Laptop consistently connects to farthest eero (which results in 90% reduction in potential bandwidth).  Toggling Wi-Fi on laptop does not help: it always re-connects to the eero with the weaker signal.  My workaround is to unplug the farther eero.  This sucks :(

    The community posted the following feature request FOUR YEARS AGO and upvoted it 274 times:

    If you care about this issue, please upvote using the link above.

    Also, someone posted a newer feature request 6 months ago, adding a suggestion to be able to kick a device off a specific eero so the device can rescan:

    This 2nd one encompasses the request of the first one and adds a useful additional request, but it only has 4 upvotes and will take a long time before it accumulates enough to be noticed, so the first one still carries importance.  Please upvote BOTH. 

    Thanks!

    Rex in Hawaii

    • lmcvdtr
    • 1 yr ago
    • Reported - view

    Any update to this issue? Still got the problem to connect the closest beacon when roaming 

Content aside

  • Status Answered
  • 17 Likes
  • 3 mths agoLast active
  • 181Replies
  • 48958Views
  • 80 Following