17

Devices not connecting to closest eero

A quick background on my setup:

  • I am running the latest version (1.4) of the iOS app
  • I am running the latest firmware (2.1.0) on my three eeros.
  • My first eero is connected as follows:  modem -> eero --> switch
  • My other two eeros are hardwired via ethernet back into the switch.

 

Upon updating the iOS app, I started checking to see which devices are connected to which eeros. I was surprised at what I found.

  1. Most of my devices are connected to the primary eero.
  2. An iPad in an upstairs bedroom is connected (with a weak signal) to the primary eero which is downstairs in my den even though there is an eero in the same bedroom as the iPad. (The iPad stays in that bedroom, it never wanders around the house).
  3. My Rachio sprinkler controller is also connected to the den eero even though there is an eero much closer to the garage.

These are not the results I expected. I thought I placed the eeros to give me strong coverage throughout the house but the devices don't seem to want to connect to the closest available eero. I also thought since I wired them via ethernet that this would give me the strongest possible mesh network possible.

Did I do something wrong in my setup? Any suggestions on how to correct this?

Thanks,

Mike

181 replies

null
    • eero Community Manager
    • Jeff_C
    • 6 yrs ago
    • Official response
    • Reported - view

    Hey  Mike K

    Thanks for reaching out. It is awesome to hear that you are already testing out this new feature!

    In most cases, your devices will choose the best eero to connect to but sometimes connected devices may stay connected to eeros further away. It really depends on how that specific device handles roaming and handoff. While we support 802.11r, we're still working on full support for 802.11r Fast Transition. The issue is this protocol can cause issues for older WiFi devices, so we are working carefully on implementation. 

    With stationary devices like your Rachio sprinkler system, if you happened to unplug or reboot an eero, there is also a chance it just stayed connected to another eero within range. 

    If you see that a device isn’t connected to the closest eero, don’t worry as it may still have an excellent connection. However, if you’re seeing weaker connections when there is a closer eero, you can toggle wifi off and back on for the device to connect to a closer eero. It should automatically connect to the best eero.

    Again, at the end of the day, these decisions are ultimately made by the device. However, we are continuing to put in the work on our end to make sure eero can do whatever possible to make these experiences more seamless.

      • violet_button
      • 4 yrs ago
      • Reported - view

      Do you support

      • Providing an optimized list of APs to roam to, aka Neighbor Reports (802.11k)
      • Providing information about the traffic load on other APs (802.11v)
      • Speeding up the roaming process by providing fast authentication (802.11r)

      If not, when will they be supported.

      I just installed 3 eero’s wired to the router and constantly am not connected to the closest eero.  It appears to switch after a while, but I cannot tell if this is it does this consistently.  Thinking of returning the units as a mesh network shouldn’t work this poorly.

      • JustinThings
      • 4 yrs ago
      • Reported - view

      Jeff C.  could eero disconnect devices to move them to the right access point? I imagine eero can see if a request is getting a response. I have seen 3 bars of  signal on phone with no internet access until resetting wifi. Not sure what is wrong.

      • Jack_Fate
      • 3 yrs ago
      • Reported - view

      Jeff C. This is an unacceptable answer. This is the core advertised value of purchasing the (very expensive) device! 

      • txgunlover
      • 3 yrs ago
      • Reported - view

      Jack Fate Devices choose their access point, not the access point.  This is a core tenant of WiFi.

      • Jack_Fate
      • 3 yrs ago
      • Reported - view

      txgunlover C'mon! Be creative. Have the app turn off (or dim) the signal from the others while I toggle off and on my device's wi-fi. My device will find the node I prefer, because it is the only one it can find. Or better yet, it should always find the strongest choice. Really! Why are we spending a few hundred dollars to solve the signal strength problem if there is no hope that it will do as advertised?!

      • Jack_Fate
      • 3 yrs ago
      • Reported - view

      Jack Fate What did I get for my $400 over any other cheaper brand and model?!!!

      • bitzerjdb
      • 3 yrs ago
      • Reported - view

      txgunlover 

      Please explain why when I have 3 Asus Access points in the house, I Always connect to the one that is the closest to the client.  Move to the Basement and the laptop/phone hops to that Access Point.  With the eero mesh the client hangs on to the original one until the bitter end.  My laptop/phone stays on the upstairs unit, even with 2 bars of strength....  The Basement unit is 10ft away.

      Why does the client know how to behave with the ASUS APs but not with the Eero's?

      • Jack_Fate
      • 3 yrs ago
      • Reported - view

      bitzerjdb I guess I should have bought the Asus. And it costs way way way less than $400. The problem is that the ratings on Amazon don’t reflect this fundamental flaw with Eero, which gives it zero competitive advantage over systems that are 1/8 the price. I guess we need to do our duty and warn everybody. 

      • bitzerjdb
      • 3 yrs ago
      • Reported - view

      Jack Fate  I got tired of doing the Firmware updates on the individual access points and making sure that all the settings were the same.  Eero was great for management...set and forget.  I noticed this issue early on but thought it wasn't a big deal...unfortunately it is.  My bigger issue is that if I reboot the Network (or we have a power blip), the beacons come up first and all the devices connect to them.  Once on, the clients stick to them (regardless that a Pro unit is 5ft away).  I need to reboot them individually to force the clients to find another AP.   I NEVER had this behavior with multiple APs in the house.  Clients would connect to the first one up, and then balance out over time.  If this was simply a client decision, the behavior would happen to all systems, it doesn't,  Not sure what the secret sauce is in the ASUS APs, but it isn't in the Eero.

      • mpimenta
      • 3 yrs ago
      • Reported - view

      bitzerjdb I gave up. Bought the Nest-Google solution. And sent my eero kit to my father. Now he hates me. And I love Nest. 

      • diabolicus23
      • 3 yrs ago
      • Reported - view

      txgunlover The concept of virtual cell exists exactly for this reason and to overcome this limitations.

      • tobey
      • 2 yrs ago
      • Reported - view

      Jack Fate When I set up my second Eero, I had the same issue - one in the garage that's literally a few feet from my Nest cam and doorbell but they both connected to the main one in the living room that's farther away.

      I disconnected ethernet on the garage one and moved it to a different corner in the garage. When it was up and running, I unplugged the main Eero for 30 seconds and that got the Nest cam and doorbell to connect to the garage one - basically "dimming" the main one as you suggested, except manually.

      • maczuzakj
      • 2 yrs ago
      • Reported - view

      Jeff C.   I have the same problem with devices not connecting to the closest Eero resulting in poor signals.    My front door Doorbell Ring (stationary) connects to the Eero in the back of the house and my backdoor Doorbell Ring connects to the Eeero at the front of the house (4 feet from the front door).   Toggling the wifi off & on a Doorbell Ring is not practical.    I have the latest Eero 6.  Seeing this article is 4-years old and the problem persists is surprising.   Hope future updates fixes this primary expectation of "mesh" technology.  Thanks

    • Mdavidm
    • 6 yrs ago
    • Reported - view

    I've noticed the same issue with the same devices, but Rachio switched to a closer eero unit after a few hours, and the other devices (phones, laptops, etc.) switched more rapidly.  It appears that IoT devices (Rachio, Nest, Smartcams, etc.) accessing the internet less frequently are slower to change eero access.

    • Mike_K
    • 6 yrs ago
    • Reported - view

    Thanks Jeff C.

    Upon checking today, I see that the iPad now is connected to the eero in its room, without any change on my part. But the Rachio is still connected to the further (office) device. Maybe that will correct itself with time? I'll keep an eye on this to see if any patterns emerge. I would hope that my stationary IoT devices always are connected to the closest device to ensure a strong WiFi signal. With other mobile devices, where I'm moving around the house with them, I would assume that they bounce from one to the other depending on what is is range for where I am at any particular moment.

    Maybe it's a bad assumption on my part to think that a device will connect to the strongest device in range and that instead it stays connected to whatever it first attached to until/unless that signal disappears or falls out of range?

    • eero Community Manager
    • Jeff_C
    • 6 yrs ago
    • Official response
    • Reported - view

    Thanks for following up  Mike K and  Mdavidm

    Again, while eero is designed to work in this way, the decision of which eero to connect to (and switch to) is ultimately up to the device. If an IoT device, like a stationary sprinkler system, is within range of two eeros, it may connect to one and not the other. You can try toggling the WiFi off and back on for these devices (if the device doesn't have such an option, you can power cycle it) to see if it connects to the correct eero.

    We just recently began surfacing information on which eeros your devices are connected to in the app. If you have any feedback or suggestions on how to improve this feature based on your experience with it thus far, we're all ears!

      • Eero_Zero
      • 4 yrs ago
      • Reported - view

      Jeff C. a simple suggestion is there should be a feature to manually connect to a different eero. I.e override the default selection. My iPhone always pairs with the basement eero and won’t change to anything else even when I am two floors up. Very frustrating. 

      • txgunlover
      • 4 yrs ago
      • Reported - view

      Eero Zero Contact your phone's manufacturer... the phone determines what AP it connects to, not the AP.

      • Propho
      • 4 yrs ago
      • Reported - view

      txgunlover so ur suggestion is for everyone to contact the manufacturer of every device in their home not connecting to the right Eero?  So in my case, ur saying it's Samsung, LG, Google, Ring, Roku, Nvidia, and Microsoft's fault they don't connect to the correct Eero.. sounds about right.. thanks for the great tip!

    • jalcala
    • 6 yrs ago
    • Reported - view

    Jeff C. 

    Would it be possible to list all the devices connected to an eero from the device page itself?  For example, if I am viewing the information page on my Hallway eero can you list all the devices connected to it here.  Would help me determine if I am overloading a single device and how I might be able to spread the load.

    • eero Community Manager
    • Jeff_C
    • 6 yrs ago
    • Reported - view

    Thanks for joining the discussion,  jalcala 😬

    While that isn't currently a feature, that is great feedback! Happy to relay it to the team.

    • Pahusker
    • 5 yrs ago
    • Reported - view

    My iphone7 picks the main router and uses he 2.4 ghz even though there is another router sitting right next to me. 

      • Jzd5032
      • 5 yrs ago
      • Reported - view

      Pahusker 

      Experiencing the same issue on ios 11.3 & 11.4 with iphone 8 & iPhone 8 plus.  Getting slow speeds due to this. Specifically purchased this to eliminate this issue.  Waste of money

    • SARATOGA_STEVE
    • 5 yrs ago
    • Reported - view

    Just installed a new Gen2 Pro system today.  I found that my iPhoneX kept connected to a remote Eero even when I am right next to the main/router Eero.  I tried turning Wifi on/off a few times on the phone and even re-powered it, but it kept connecting to the remote one.  I finally did a 'reset' on the remote Eero that it was connected to from the app and then it connected to the one nearby.  But hoping the roaming will be a little more intelligent than that.  

    I'm thinking there should be an app button called 'Connect device to Best Eero' that would force it to reconnect?

Content aside

  • Status Answered
  • 17 Likes
  • 3 mths agoLast active
  • 181Replies
  • 48959Views
  • 80 Following