Chamberlain Smart Garage Hub won't connect with Eero

Has anyone had success pairing the Chamberlain Smart Garage Hub with their Eero? When I go through the setup process, I get to the step of choosing my Network, but my network shows up as a  non-secured network. I can select my network, but don't have the option of putting in a password as the Chamberlain app thinks it's unsecured. I've tried to manually put in the SSID and password, but it won't connect.

Every surrounding network shows as secured and I can connect to an older Linksys router without a problem.

TIA for any suggestions.

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Problem solved - just spoke to Eero tech support and it turns out MyQ products are not compatible with WPA3. I also have an older Epson printer that wouldn't connect. Tech support shut off WPA3 mode on my router and both devices connected. So if you've got devices that won't connect, this might be your answer. To disable WPA3 go to the eero Labs section under the Discover tab.

    Like 3
    • jtmag This was the solution needed for me with the MyQ Smart Garage Hub as well as the Sengled LED Smart Bulbs.  Thanks for contributing!

      Like 1
      • jtmag
      • jtmag
      • 2 yrs ago
      • Reported - view

      Starkdaddy74  glad it helped and thanks for the info on the bulbs

  • Home Bridge worked with Linksys EA4500 router (2.4 network). I "upgraded" to eero now run into this problem. I turned off WPA3 but it didn't work for me. Every time I get all the way to the end of setting up the Home Bridge (... Bridge Location selected, continue, Bridge Name, continue, "Bridge Added to My Home", continue "Error: There was an error connecting to the server. Please check your connection and try again".

  • Jtmag thank you so much for taking the time to give this answer. 2 hours of attempted setup 25 minutes on the phone with Chamberlain no luck. You answered my question and thank you!!!

  • Still having no luck connecting Eero to MyQ app network. I choose the Eero network, type in password and it just idles. I turned off the 5g network, turned off the wpa3 as mentioned above (which I I didn't know was an option). No luck, so which garage door should I replace it with or which product should I replace Eero with? one has to go.

    • one fancy username Another thing to look at is your network name and password. ensure neither has special characters, as some devices have issues processing certain characters. If the issue continues, give us a call and we can look into things further on our end.

    • Evan (eero support) There are no special characters and basic password that i retyped, literally a hundred times. I double check the eero app to ensure that the password matches what is in my eero app to the password i'm typing in the myq app when connecting to the network. I"m just frustrated. I've been back and forth with emails from eero support and not satisfied with Eero. I don't believe this is Eero problem as the crafstman is the problem.

  • OMG! finally solved. for the Eero device, open up Eero app > settings (bottom Right- notice it is next to Discover tab)> Guest network - turn it on (Tip: use only letters and numbers, no characters for the password). then select troubleshooting and turn off the 5g network. back out of settings by pressing Discover (hint: next to the settings tab), press the eero labs> then turn off WPA3 security. close out of Eero app. Go to your wifi network and connect to the Guest network . Then open your MyQ app.  Start the process of following the step by step instructions on the app. Press the yellow button on your Garage door opener three times and hear the beep. follow the prompts on the app to join the MyQ network. Select your Home wifi network (guest network), type your password. That should be it and it will connect everything together...hopefully!!  This is how I was able to get mine to connect! hope this helped you out. 

    • one fancy username Nevermind, the 5g network that was paused for 15 minutes, came online and disabled the garage door leaving it off line. MyQ not compatible with Eero. I called Eero customer support and they were unable to resolve the issue. 

  • Turn off “WPA4” under “Discover” and “Beta Labs”. Took me a week to figure this out.😳😊

Like1 Follow
  • 1 yr agoLast active
  • 11Replies
  • 773Views
  • 8 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support