Reliability Issues with AirPrint and Eeros?

Hey all,

We are running a network with 4 (first generation) eeros and trying to use AirPrint from iOS devices (iPads and iPod Touches running latest stable iOS 10.3) connecting to a Brother QL820NWB label printer (in "Infrastructure Mode", fwiw).

AirPrint works intermittently: sometimes the printer is undiscoverable by the iPods for stretches of time (1hr+). We have noticed anecdotally that we can more reliably discover and connect to the printer when we are physically close to one eero (the "base station" that's actually connected to the modem) than any of the others.

Is it possible that there is some firmware issue / weird interaction between the eeros and AirPrint when multiple "hops" are involved?

Any suggestions for resolving / improving reliability?

As a first step, we are considering physically plugging in the printer to one of the eeros with an ethernet cable to at least eliminate the concern of WiFi intermittency with the printer itself (although when we have encountered these issues, the printer reported a strong signal "full bars", as did the iPods/iPads).

8replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi  sherbondy


    Thanks for reaching out! To start, I'm curious; do you have an ethernet switch in your current network setup? If so, could you check to see if you have IGMP snooping turned on? If you do, go ahead and turn it off to see if that helps the issue. If not, please let us know and we'll take further steps.

    Thank you!

  • Hey Joey, I think you are spot on. We have a managed switch on the network, and it looks like the model we are using does have IGMP snooping on by default. Will try disabling first thing tomorrow and report back about reliability changes of AirPrint over the network.

    Thanks for the tip, hope it works out.

  • I'm having the same issue, and I don't have any swtiches on my network- just the Eero plugged into a cable modem. Just like sherbondy discovered, AirPrint works if I make sure my Mac or iOS device is connected to my "main" Eero, which is inconveniently not near the printer. The Eero app confirms that my printer is connected to one of my "other" Eeros.  

      • Drew
      • Drew
      • 5 yrs ago
      • Reported - view

      ericwi Sorry to hear you're having some trouble here, but we're happy to help out! If you don't have a switch in the mix, then the issue could be a different manifestation with similar symptoms. If you haven't yet, please give us a call at 877-659-2347 so we can gather some more details from you and help get to the bottom of this!

      Drew, eero Community Team

  • Same problem. Sometimes i can print and sometimes no. I have an epson workforce 645. When i run a report the printer will tell me i have multiple access points. When i scan for wifi networks the printer will find two or three eero networks. Sometimes i print from my laptop it won't find the wireless printer ,,, and later that evening it will print ,,, sometimes my ipad will print and sometimes it will say "no airprint printers found". At the same time i have an epson app on the ipad and it will see the printer and give me print in levels for each color cartridge so i know the ipad sees the printer ,,, its crazy.

    any one have similar problems and a solution?

    Like 1
  • Hi,

    I'm having the same issue. I came on here to see if there was a way to manually change the frequency that a device was on because the printer is using 2.4 Ghz while some devices we want to print use 5 Ghz. Could that give symptoms like this? Thanks for any help.

    Like 1
    • scottsek I've been trying to figure out if this could be the case as well. I'm at my wit's end. I work from home and have a Brother MFC laser that worked perfectly for years, but suddenly can only be found intermittently now that my network setup is based on an Eero. I don't even have multiple access points, just a single Eero as a router, so other than frequencies I'm not sure what the problem could be - but it literally will work one minute, then be "invisible" the next. I'm going batty.

  • Hi,

    I have a problem with DNS: when I publish hostname via mDNS, I can't resolve DNS hostname...a problem of IGMP snooping or because Eero don't have DNS server?

Like Follow
  • 2 yrs agoLast active
  • 8Replies
  • 1984Views
  • 10 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!

Quick links

Community Guidelines

Help Center

Contact eero support