2

eero Refuses to use Ethernet Backhaul

I have three eero Gen2 all in bridge mode and connected via ethernet to a gig ethernet switch that is plugged in to my ISP firewall/router/modem.  Everything worked great for the last few months.  The ISP replaced the modem today and everything came up as expected with one exception.  One eero refused to connect via ethernet, the app shows it connected wirelessly.  Previously it has always connected via ethernet.

Troubleshooting steps:

  1. Verified the ethernet cable works by plugging in a different device
  2. Restarted the eero via the app
  3. Hard booted the eero via unplugging it
  4. Restarted the entire eero network (all three APs) via the app
  5. Unplugged the ethernet... waited... plugged it back in
  6. Reset the problem eero to factor default and re-added it to the network.

The eero in question is still connected via wireless and not ethernet.  Despite this I have a link light on the switch which tells me the ethernet connection is active.  I'm stumped.  There is no way to force the device to use ethernet backhaul unfortunately.

Why is it choosing wireless now?  Is it smart enough to decide that wifi is a better option than ethernet in this case?  

7replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi lacey303

    Thanks for reaching out and sorry to hear the issue you are experiencing.

    When connected via Ethernet, your eeros will automatically default to a wired backhaul. If you are continuing to see a connection type that is wireless, please contact support at support@eero.com . Our team can see more details regarding the connection type.

    If the issue is hardware related (such as an issue with the Ethernet jack), our warranty will cover a replacement. If the issue is cosmetic, our team will escalate the matter to engineering so they can take a look at what is happening.

    Thanks again!

    Like
  • Hey Jeff. Thanks for the reply. I checked back in the app periodically and it appears about 90min after being powered up/rebooted the eero in question switched back to Ethernet backhaul on it’s own.  All is good now. I’ll keep an eye on it. 

    Like
  • Had a similar problem today, 11/27/20, with the subordinate eero in the living room, which lead me to re-booting, diagnosing, and updating eero software. It turned out that the problem was in the app (Android version). On the app home page, it showed that eero correctly as Wired, using the Wired icon ("<-->"), but when I selected the location for more detail, it displayed the word "Wireless" and the Wireless icon. For the other eero's it described the connection correctly on both screens: Wired for the main eero in the office, and Wireless for the other subordinate one in the garage. I would have saved myself some time if I had noticed that glitch in the app right off, but I was looking at the detail page and hadn't paid attention to the icon on the home page. It was using Wired all along.

    Like 1
      • ttnicky
      • ttnicky
      • 5 mths ago
      • 1
      • Reported - view

      Al Schmeder I'm having the same exact issue. Main page uses the wired symbol but when clicking on the Eero for additional details it says wireless connection. I'm also on Android.

      Can we get some verification that this is a software bug or is there some way to test the connection ourselves?

      Like 1
      • RobGinNC
      • RobGinNC
      • 5 mths ago
      • 1
      • Reported - view

      ttnicky Glad you posted this. I have been driving myself crazy for the last hour thinking my wired network was misbehaving

      Like 1
  • When I pull the Ethernet cable from the subordinate eero, the app changes to showi the wireless symbol on the list page. When I reconnect the Ethernet cable it goes back to showing the wired symbol. So it's not completely arbitrary. But the detail page shows wireless at all time. If you have a laptop with an Ethernet connection, you could plug it into the subordinate eero drectly and run an Internet speed test. If it making a wireless hop, the speed should be slower than when you plug it into your main eero, assuming that  the main eero is on a wired connection to your dsl or cable modem. 

    Like 1
      • ttnicky
      • ttnicky
      • 5 mths ago
      • Reported - view

      Al Schmeder Great idea, thanks! I had looked for changes on the eero (e.g., connection LED) or the detail page (trying to get "wired" logo to appear), I didn't think about seeing if the logo on the main list page would change when I unplugged the eero.

      Like
Like2 Follow
  • Status Answered
  • 2 Likes
  • 5 mths agoLast active
  • 7Replies
  • 4643Views
  • 6 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com