2

eero Refuses to use Ethernet Backhaul

I have three eero Gen2 all in bridge mode and connected via ethernet to a gig ethernet switch that is plugged in to my ISP firewall/router/modem.  Everything worked great for the last few months.  The ISP replaced the modem today and everything came up as expected with one exception.  One eero refused to connect via ethernet, the app shows it connected wirelessly.  Previously it has always connected via ethernet.

Troubleshooting steps:

  1. Verified the ethernet cable works by plugging in a different device
  2. Restarted the eero via the app
  3. Hard booted the eero via unplugging it
  4. Restarted the entire eero network (all three APs) via the app
  5. Unplugged the ethernet... waited... plugged it back in
  6. Reset the problem eero to factor default and re-added it to the network.

The eero in question is still connected via wireless and not ethernet.  Despite this I have a link light on the switch which tells me the ethernet connection is active.  I'm stumped.  There is no way to force the device to use ethernet backhaul unfortunately.

Why is it choosing wireless now?  Is it smart enough to decide that wifi is a better option than ethernet in this case?  

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi lacey303

    Thanks for reaching out and sorry to hear the issue you are experiencing.

    When connected via Ethernet, your eeros will automatically default to a wired backhaul. If you are continuing to see a connection type that is wireless, please contact support at support@eero.com . Our team can see more details regarding the connection type.

    If the issue is hardware related (such as an issue with the Ethernet jack), our warranty will cover a replacement. If the issue is cosmetic, our team will escalate the matter to engineering so they can take a look at what is happening.

    Thanks again!

    Reply Like
  • Hey Jeff. Thanks for the reply. I checked back in the app periodically and it appears about 90min after being powered up/rebooted the eero in question switched back to Ethernet backhaul on it’s own.  All is good now. I’ll keep an eye on it. 

    Reply Like
Like2 Follow
  • Status Answered
  • 2 Likes
  • 1 yr agoLast active
  • 2Replies
  • 1817Views
  • 3 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com