Satechi Dual smart outlet ST-HK20A cannot connect to my eero pro 6

Hi Everyone,


I hope all is well,


I got 2x devices like this, and I cannot connect to my Eero WIFI network.

I found on the vendor website they are 2,4 only, but even if I pause my 5ghz, I cannot connect them.

I tried to pause 5 GHz and also disable eero labs feature Band Steering.


and they were working pretty well on my previous dual-band router 

I just found If I disable WPA3 they are working well!


3 replies

    • robusto400
    • 2 yrs ago
    • Reported - view

    I have the same issue trying to set-up and connect various smart bulbs and plugs. My older dual band router was device addressable as my eero is not. Where is the WPA3 setting you changed? Don't see it under settings.

      • b42d
      • 2 yrs ago
      • Reported - view

      robusto400 in the phone applications go to the discover options and disable WPA3

    • Brittany
    • 2 yrs ago
    • Reported - view

      Thank you for posting that it could be just the thing to give inspiration to someone who needs it! Keep up the great work!


Content aside

  • 2 yrs agoLast active
  • 3Replies
  • 44Views
  • 3 Following