0

Eero won't let me set my own DNS servers

Hi all,

Odd one: I've setup Eero on my home network, and wanted to set my own DNS servers: 1.1.1.1 and 1.0.0.1. However, after I do that, Eero is passing to DHCP clients 3 different DNS servers: itself (192.168.1.4) and then the ones I specified.

That's far from ideal obviously. I though that that's because I had DNS caching enabled, but I disabled it and the result is the same.

Any help would be most appreciated.

11replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This is caused by local DNS caching being enabled. I just tested to confirm this. I know you said you you still see the 3 DNS servers after disabling local DNS caching, but did you try disabling WiFi on your device and then re-enabling? You also have to wait for your eero network to restart after disabling/enabling local DNS caching.

    Like 1
      • dannyboy
      • dannyboy
      • 1 yr ago
      • Reported - view

      cMoo92 Thanks, I reset my Eero and retested, and you're correct, the extra DNS goes away after disabling caching. Something must have gotten messed up in my original configuration.

       

      Still, though... if the cashing is enabled, surely the other DNS should be hidden from the DHCP client, and only address of the Eero exposed? Otherwise caching would only be to some random queries.

       

      Another observation: if the DNS is in fact enabled, the Eero seems to be using public DNS servers to resolve the queries. and not the ISP one. I can clearly see that by running DNS leak test with DNS server set to Eero's IP address (or when caching is enabled). 

      I know it's a beta feature, but it looks like it needs A LOT of work. This is something that Apple's Time Capsule has been doing for years.

      Like
    • dannyboy is the DNS leak test showing an AWS related DNS server?

      I think the reason for the 3 DNS servers listed is so your device has a fail back in case the DNS caching isn’t working. It makes sense that your device could go look up on it’s own. Otherwise it’s completely dependent on the eero with no alternative. It will check the eero DNS first since that’s listed as the primary.

      Like
      • dannyboy
      • dannyboy
      • 1 yr ago
      • Reported - view

      cMoo92 It would make sense, but for example Windows doesn't work like that, it uses the DNS servers provided from DHCP at will, so there's no primary/secondary per-say. 

      Ironically, now that I disabled DNS caching... it looks like Eero, even though it doesn't send its own IP as DNS: it does resolve DNS queries, using configured DNS servers, and it seems to be caching them too, so it almost works better this way :) Just wish my DHCP clients could be pointed to it without the side effects of enabling DNS caching in the Lab. 

      Seems like there's a long way to go for this feature.

      Thanks for your input, I'll probably try to submit feedback to Eero. 

      DAn

      Like
      • dannyboy
      • dannyboy
      • 1 yr ago
      • Reported - view

      cMoo92 oh, also, no, it’s showing bunch of Cisco OpenDNS (Ireland) and Google (Brussels) servers.

      Like
      • dannyboy
      • dannyboy
      • 1 yr ago
      • Reported - view

      cMoo92 Ok, so interesting: after it was all well since your reply to me: the Eero's IP address came back in new DHCP requests as DNS (!) even though the DNS caching is disabled. I'm going to reset them again to see if this is something that gets messed up after turning caching on once.

      Like
  • Ok, I think I've got it. It appears that when HomeKit support is enabled, Eero sets itself as DNS server regardless of ones configured, and uses OpenDNS and Google DNS for that. Frustrating. I disabled HomeKit support and it's all back ok again.

    Like
  • I’m having the same issue and I do not have DNS caching turned on.

    Like
  • I see a note in Eero that says to modify the DNS all eero Secure features must be disabled. Once the DNS settings are changed they can be turned back on again.

    Like
      • Skyedog
      • Skyedog
      • 9 mths ago
      • Reported - view

      How did you disable your Secure features? I have the same issue. I started with one modem that provides DHCP address, then changed providers who require Static IP. I was able to successfully change the IP address/subnet/gateway, but cannot set DNS due to same message. 

      Like
  • I called tech support and they were a little stumped. They had to reset my profile to temporarily disable Security features, then they requested I fully close the eero app. I opened the app back up and was able to set my DNS manually - for IPv4 they recommend 8.8.8.8 and 8.8.4.4. When you save the config, it requires a reboot and then all is set correctly...and you can edit it again if necessary.

    Like
Like Follow
  • 9 mths agoLast active
  • 11Replies
  • 1719Views
  • 5 Following

Need Help? We're here for you!

We're big on support, and we want to make sure you always have the best eero experience possible. Here are several resources you can use if you ever need our help!


Quick links

Community Guidelines

Help Center

Contact eero support

@eerosupport

eero.com